Disk have become unbootable [Solved]

My manjaro was working perfectly, then I unplugged the disk and installed windows on another disk. Now I cant boot manjaro even if it is the only disk connected.

Err message:
"Reboot and Select proper Boot device
or Insert Boot Media in selected Boot device and press a key"

I can however boot into a bootable usb with manjaro and all the partitions seams to still be there when I look with gparted. And I can access the files

/dev/sda1 - fat32 - boot, esp
/dev/sda2 - ext4
/dev/sda3 - linux-swap

I have no clue what has happened or how to fix it.

I would put my disks back just the way they were when you installed Windows and then re-install grub as per https://wiki.manjaro.org/index.php/Restore_the_GRUB_Bootloader

You can boot up your installed Manjaro by using the grub in the install media.
You can also boot up using the install media in the "Detect EFI boot loaders" entry.

After booting up, at terminal,

sudo grub-install

1 Like

That seems way easier than how the wiki does it, cool.

1 Like

Sry for being thick, but I dont get how I boot to my old system from the instructions given in the link. And I have no idea where to find the "Detect EFI boot loaders" entry

Tried the wiki way aswell. But I think it installed i386 grub

What makes you think that? Was there an error, did the behavior change, are you back to two drives.

Please help us help you and give some more details if possible. :smile:

Yes, there was an error. But I dont have it infront of me now, because I tried the later methods after. And i cant boot back into the installation media because i messed with the grub loader as per the alternative method.

The steps I finished on the alternative method:
grub> search -f /boot/intel-ucode.img --set=root
grub> configfile /boot/grub/grub.cfg

Then I have no clue what to do, so I rebooted

Well that is strange, the wiki has never failed for me yet. Do you have a Manjaro usb live media?

Yup, albeit slightly tempered with as I described in the previous post. And there seamed to be a missing step on that wiki page as well.

When installing mhwd-chroot pacman coudlnt find the database files for 'core', 'extra', 'community', 'multilib' so had to pacman -Syu first

Hmmff, I guess I am really confuse for some reason. If you have used the link given by @gohlip you should have used the grub terminal from the install media which as far as I know can not change anything on the usb drive.

So the boot media should still boot.

That was my first thought as well. But screen turns black -> no signal -> sleep mode after i select boot manjaro from the menu.

And I only this from the link:

grub> search -f /boot/intel-ucode.img --set=root
grub> configfile /boot/grub/grub.cfg

Yep been there, out of ideas.
Have you checked other terminals? Ctl-Alt-F2

What hardware is this? $ inxi -b if possible.

ctrl - alt - f2 does nothing right now. Unrespoinsive. But to clarify I got to the manjaro boot start menu where you can set lang and drivers, and i can still open grub with c

I reburned the iso so I got a fresh installtion medium now.

$ inxi -b shows>

CPU~Quad core Intel Core i5-4690K (-MCP-) speed/max~1354/3900 MHz Kernel~4.9.50-1-MANJARO x86_64 Up~1 min Mem~560.1/7891.2MB HDD~515.6GB(1.0% used) Procs~179 Client~Shell inxi~2.3.38

It works. I can boot into my old installtion now.

Turns out I had always had legacy and UEFI modes enabled in my motherboard. But somehow when I installed windows legacy mode got set as default. I have now turned it to only UEFI mode.

And ofc. then the “Detect EFI boot loaders” entry showed up as an option. And I did as gohlip wrote: "sudo grub-install" And everything works fine.

I was starting pulling my hair out because I could not find any info about a “Detect EFI boot loaders entry" , but it was there all along.

Thank for your patience and help.

Wow, I cant believe you did not see it. We need to work on that I think. Sorry

I think you misunderstand me, my english is bad. The “Detect EFI boot loaders entry" was not visble becuase it didnt boot into UEFI per default. After I switched to only UEFI the option showed up. I have since switched back to both legacy and UEFI to allow windows boot as well. And it works fine

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by