Display Terminals require manual intervention after changing "TearFree on" flag

after having some visual tear artifacts in radeon video display ( in VLC , smplayer) I solved it by using the "TearFree on" option in the X config file.

Although every time I startup in order to get a working XFCE display I have to manually ( via keyboard alt +F2 ) call tty2 interface ( or any other tty ) followed by calling tty1 ( alt + F1) ...

Does anyone else had this behaviour ?

I am using SSDM as session manager ( By default I am using XFCE but I also have i3-wm window managers) and before this "TearFree on" option activation everything were Ok ...

My hardware is an ATI BARTS ( HD6850 ) with the default radeon open source driver what am I missing here ?
Where do I start ?

Logs, inxi -Fxxxz, content of your radeon.conf, ssdm.conf content... The more info, the better for the guys to try and help you.

Sorry for the lack of information on the initial post...

here is the inxi result :

           Desktop: Xfce 4.12.4 tk: Gtk 2.24.32 info: xfce4-panel wm: xfwm4 dm: sddm Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: P8P67 v: Rev 1.xx serial: <filter> BIOS: American Megatrends 
           v: 3602 date: 11/01/2012 
CPU:       Topology: Quad Core model: Intel Core i7-3770 bits: 64 type: MT MCP arch: Ivy Bridge rev: 9 
           L2 cache: 8192 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 54420 
           Speed: 1600 MHz min/max: 1600/3900 MHz Core speeds (MHz): 1: 1600 2: 1600 3: 1600 4: 1600 5: 1600 
           6: 1600 7: 1600 8: 1600 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Barts PRO [Radeon HD 6850] vendor: ASUSTeK EAH6850 
           driver: radeon v: kernel bus ID: 01:00.0 chip ID: 1002:6739 
           Display: x11 server: X.Org 1.20.1 driver: ati,radeon unloaded: modesetting alternate: fbdev,vesa 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: AMD BARTS (DRM 2.50.0 / 4.19.0-1-MANJARO LLVM 6.0.1) v: 3.3 Mesa 18.2.1 
           compat-v: 3.1 direct render: Yes 
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: ASUSTeK 
           driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1c20 
           Device-2: AMD Barts HDMI Audio [Radeon HD 6790/6850/6870 / 7720 OEM] vendor: ASUSTeK 
           driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 1002:aa88 
           Sound Server: ALSA v: k4.19.0-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 v: kernel port: d000 
           bus ID: 05:00 chip ID: 10ec:8168 
           IF: enp5s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 238.11 GiB used: 157.69 GiB (66.2%) 
           ID-1: /dev/sda vendor: Crucial model: CT240M500SSD1 size: 223.57 GiB speed: 6.0 Gb/s 
           serial: <filter> rev: MU05 scheme: MBR 
           ID-2: /dev/sdb type: USB vendor: Kingston model: DataTraveler 2.0 size: 14.54 GiB serial: <filter> 
           rev: PMAP scheme: MBR 
Partition: ID-1: / size: 64.05 GiB used: 45.37 GiB (70.8%) fs: ext4 dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 41.0 C mobo: N/A gpu: radeon temp: 42 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 205 Uptime: 11h 26m Memory: 15.64 GiB used: 1.81 GiB (11.6%) Init: systemd v: 239 
           target: multi-user.target Compilers: gcc: 8.2.1 alt: 7 clang: 6.0.1 Shell: bash v: 4.4.23 
           running in: xfce4-terminal inxi: 3.0.21 

Because the problem is easily solved by calling the tty2 via keyboard and then call tty1 , i am simply asking if someone else has this behaviour .

The radeon.conf in "/usr/share/X11/xorg.conf.d/10-radeon.conf"
has only this that I edited by adding the TearFree on option ...

Section "OutputClass"
        Identifier "Radeon"
        MatchDriver "radeon"
        Driver "radeon"
        Option "TearFree" "on"

thanks in advance

What's the xorg logs show? Both in /var/log and in ~/.local/share/sddm.

Edit: corrected link. The ~/.local/share/sddm/xorg-session.log is updated realtime.

My Xorg.0.log has now 58Mb ...
mostly with the last 3 lines

[    39.987] (II) RADEON(0): Modeline "1440x900"x0.0   88.75  1440 1488 1520 1600  900 903 909 926 +hsync -vsync (55.5 kHz e)
[    39.987] (II) RADEON(0): Modeline "1600x1200"x0.0  162.00  1600 1664 1856 2160  1200 1201 1204 1250 +hsync +vsync (75.0 kHz e)
[    39.987] (II) RADEON(0): Modeline "1680x1050"x0.0  119.00  1680 1728 1760 1840  1050 1053 1059 1080 +hsync -vsync (64.7 kHz e)
[    39.987] (II) RADEON(0): Modeline "1440x900"x0.0  136.75  1440 1536 1688 1936  900 903 909 942 -hsync +vsync (70.6 kHz e)
[    40.053] (WW) RADEON(0): flip queue failed in radeon_scanout_flip: Invalid argument, TearFree inactive until next modeset
[    40.053] (WW) RADEON(0): drmmode_wait_vblank failed for scanout update: Invalid argument
[    40.053] (WW) RADEON(0): drmmode_wait_vblank failed for scanout update: Invalid argument
[    40.053] (WW) RADEON(0): drmmode_wait_vblank failed for scanout update: Invalid argument
.  .   . 
[ 65813.035] (WW) RADEON(0): get vblank counter failed: Invalid argument
[ 65813.035] (WW) RADEON(0): drmmode_wait_vblank failed for scanout update: Invalid argument
[ 65813.130] (WW) RADEON(0): get vblank counter failed: Invalid argument

.  . . 

I see that it would be better if I remove that Tearfree option ....

Any other ideas ?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by