Displaylink screen redraw issues

Hi There,

I'm using a Lenovo T490 with a Thinkpad USB-C displaylink dock and an external monitor the NEC MultiSync EA244WMi.
I've installed the displaylink driver using these steps: https://wiki.archlinux.org/index.php/DisplayLink

The monitor works but I think i'm experiencing the issue ' Screen redraw is broken' as described on that page. My screen isn't correctly updating it's information under my mouse cursor and shows graphical glitches on screen. I've tried to correct this by adding new modes to xrandr but can't get it to work.

I've used Manjaro KDE en there I could fix it by setting the compositor backend from OpenGL2.0 to Xrender or disabling the compositor completely. This isn't a good workaround because of visual issues in theming.

I've installed Linux Mint and installed the official driver and there it worked flawlessly. I grew quite fond of cinnamon as a DE for now but like Manjaro a lot more, so I installed Manjaro Cinnamon. The issue I had on KDE is also persistent there. I can't seem to find a 'workaround' like on KDE there.

Does someone knows a real fix for the redraw issues or has a workaround for cinnamon?

TL:DR
Experiencing screen redraw issues on Manjaro KDE and Manjaro Cinnamon, not on Linux Mint but I want to use Manjaro. Someone knows a proper fix or workaround for Manjaro Cinnamon?

Official driver of what?
That is a hybrid GPU laptop, intel and nvidia GPU, so what drivers have you installed on Manjaro and how?
If in doubt, follow this:

My notebook isn't a hybrid GPU notebook, it only has a Intel UHD 620 intergraded graphics chip and i'm using the free drivers which Manjaro installed by itself.

I was referring to the official displaylink driver that I used on Linux Mint:
https://www.displaylink.com/downloads/ubuntu

On Manjaro I'm using:
https://aur.archlinux.org/packages/displaylink/

Here is described as hybrid
https://www.lenovo.com/us/en/laptops/thinkpad/thinkpad-t-series/T490/p/22TP2TT4900
Here is described as optional NVIDIA® GeForce® MX250
https://www.lenovo.com/sg/en/laptops/thinkpad/thinkpad-t-series/T490/p/22TP2TT4900

Regarding the displaylink driver, the AUR package is using the Ubuntu one, so the only difference could be in the kernel version. Try with 5.4 kernel on Manjaro.
Eventually provide from terminal:
inxi -Fxxxza --no-host

I should've mentioned that, sorry.
My exact model is Lenovo T490 20N2006KMH.

I made sure that i used the same kernel on Linux Mint then on Manjaro Cinnamon (or KDE) on both the linux54 LTS.

The output on my Manjaro Cinnamon installation of the command 'inxi -Fxxxza --no-host' is:

System:
  Kernel: 5.4.44-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=10e92c79-a643-4829-a78f-c13712f428d6 rw quiet apparmor=1 
  security=apparmor resume=UUID=abac53fc-64d0-4b57-ad77-318af7b41bbd 
  udev.log_priority=3 
  Desktop: Cinnamon 4.6.3 dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: LENOVO product: 20N2006KMH v: ThinkPad T490 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: LENOVO model: 20N2006KMH v: SDK0J40697 WIN serial: <filter> 
  UEFI: LENOVO v: N2IET88W (1.66 ) date: 04/22/2020 
Battery:
  ID-1: BAT0 charge: 44.1 Wh condition: 48.5/51.0 Wh (95%) volts: 12.5/11.5 
  model: Celxpert 5B10W13877 type: Li-poly serial: <filter> 
  status: Discharging cycles: 26 
CPU:
  Topology: Quad Core model: Intel Core i7-8565U bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 8E (142) stepping: C (12) 
  microcode: CA L2 cache: 8192 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 32012 
  Speed: 800 MHz min/max: 400/4600 MHz Core speeds (MHz): 1: 800 2: 801 
  3: 801 4: 800 5: 800 6: 801 7: 800 8: 800 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:3ea0 
  Display: x11 server: X.Org 1.20.8 driver: intel unloaded: modesetting 
  alternate: fbdev,vesa resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) v: 4.6 Mesa 20.0.7 
  direct render: Yes 
Audio:
  Device-1: Intel Cannon Point-LP High Definition Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:9dc8 
  Sound Server: ALSA v: k5.4.44-1-MANJARO 
Network:
  Device-1: Intel Cannon Point-LP CNVi [Wireless-AC] driver: iwlwifi 
  v: kernel port: 3000 bus ID: 00:14.3 chip ID: 8086:9df0 
  IF: wlp0s20f3 state: up mac: <filter> 
  Device-2: Intel Ethernet I219-V vendor: Lenovo driver: e1000e v: 3.2.6-k 
  port: efa0 bus ID: 00:1f.6 chip ID: 8086:15be 
  IF: enp0s31f6 state: down mac: <filter> 
  IF-ID-1: wwp0s20f0u7 state: down mac: <filter> 
Drives:
  Local Storage: total: 476.94 GiB used: 10.42 GiB (2.2%) 
  ID-1: /dev/nvme0n1 vendor: Western Digital 
  model: PC SN730 SDBQNTY-512G-1001 size: 476.94 GiB block size: 
  physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> 
  rev: 11130101 scheme: GPT 
Partition:
  ID-1: / raw size: 459.81 GiB size: 451.59 GiB (98.21%) 
  used: 10.42 GiB (2.3%) fs: ext4 dev: /dev/nvme0n1p2 
  ID-2: swap-1 size: 16.83 GiB used: 0 KiB (0.0%) fs: swap 
  swappiness: 60 (default) cache pressure: 100 (default) dev: /dev/nvme0n1p3 
Sensors:
  System Temperatures: cpu: 34.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 0 
Info:
  Processes: 256 Uptime: 1m Memory: 15.30 GiB used: 1.17 GiB (7.6%) 
  Init: systemd v: 245 Compilers: gcc: 10.1.0 Shell: bash v: 5.0.17 
  running in: gnome-terminal inxi: 3.0.37 

I removed my Linux Mint installation but will reinstall it if needed to also give output.

No worries, that is why we try to cover every aspect.
Once you installed the driver you rebooted i guess, but did you also installed the evdi-gitAUR package ?

Yes, i've installed evdi-git. This are the steps I took to make it 'work':

  1. Install these packages:
[2020-07-07T18:32:22+0200] [ALPM] installed displaylink (5.3.1.34-2)
[2020-07-07T18:31:18+0200] [ALPM] installed dl-switch (1-1)
[2020-07-07T18:31:41+0200] [ALPM] installed evdi-git (1.7.0.r6.g9b124a6-1)

Create this config:

/usr/share/X11/xorg.conf.d/20-evdidevice.conf

Section "OutputClass"
	Identifier "DisplayLink"
	MatchDriver "evdi"
	Driver "modesetting"
	Option  "AccelMethod" "none"
EndSection
  1. Reboot system
  2. Check if display is recognized with: xrandr --listproviders
  3. Change setting to use displaylink with: xrandr --setprovideroutputsource 1 0

Then the dock is 'usable' with all it's devices connected including the display altough it has the redraw issue. Which result in graphical glitches moslty where the mouse cursor is on screen (dragging a window, selecting text etc.)

Screen redraw is broken

If you are using udl as your kernel driver and the monitor appears to work, but is only updating where you move the mouse or when windows change in certain places, then you probably have the wrong modeline for your screen.

I tried changing the modeline for my screen which is connected to the dock but that doesn't solve it.

Getting a proper modeline for your screen with a command like

gtf 1366 768 59.9

where 1366 and 768 are the horizontal and vertical resolutions for your monitor, and 59.9 is the refresh rate from its specs. To use this, create a new mode with xrandr like follows:

xrandr --newmode "1368x768_59.90" 85.72 1368 1440 1584 1800 768 769 772 795 -HSync +Vsync

and add it to Xrandr:

xrandr --addmode DVI-0 1368x768_59.90

Ad did you try to switch the iGPU driver? Remove the xf86-video-intel
In some cases you need to check a few options with it.
https://wiki.archlinux.org/index.php/intel_graphics

2 Likes

Nope I haven't tried that, good idea!
I'll try that tonight (after work) and post back when i've tested it.

Awesome, it works!
I didn't knew there was a seperate driver installed.

Thanks for your help, this issue is solved!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by