Displayport to VGA-adapters freezes the system

I'm running XFCE, and I'm trying to use a Displayport to VGA adapter since I want to use a CRT, for which there are no VGA ports on my graphics card. Both of the adapters I have seem to crash the computer when plugged in though. No kernel panic or anything like that, it just completely freezes. If I boot up the computer while the CRT is connected through the adapter, the CRT turns on during the boot process, but the login screen never shows up then. I have previously connected a CRT through such an adapter, but on another installation of Manjaro, so it's likely some sort of software-related issue and not an issue with the adapters themselves. Also, when I only connect an adapter to the Displayport without plugging in the CRT monitor, no crash occurs, nothing happens whatsoever.

[user@jetset ~]$ inxi -Fx
System:
  Host: jetset Kernel: 5.5.6-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.2.1 Desktop: Xfce 4.14.2 Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: ASRock model: AB350M Pro4 serial: <root required> 
  UEFI: American Megatrends v: P5.90 date: 07/03/2019 
CPU:
  Topology: 6-Core model: AMD Ryzen 5 1600 bits: 64 type: MT MCP arch: Zen 
  rev: 1 L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 76673 
  Speed: 1375 MHz min/max: 1550/3200 MHz Core speeds (MHz): 1: 1375 2: 1375 
  3: 3358 4: 1373 5: 1374 6: 1357 7: 3392 8: 1357 9: 1375 10: 1374 11: 1375 
  12: 1356 
Graphics:
  Device-1: AMD Baffin [Radeon RX 550 640SP / RX 560/560X] 
  vendor: Sapphire Limited driver: amdgpu v: kernel bus ID: 06:00.0 
  Display: x11 server: X.Org 1.20.7 driver: modesetting 
  resolution: 1280x1024~60Hz 
  OpenGL: renderer: Radeon RX 560 Series (POLARIS11 DRM 3.36.0 
  5.5.6-1-MANJARO LLVM 9.0.1) 
  v: 4.5 Mesa 19.3.4 direct render: Yes 
Audio:
  Device-1: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / RX 560/560X] 
  vendor: Sapphire Limited driver: snd_hda_intel v: kernel bus ID: 06:00.1 
  Device-2: AMD Family 17h HD Audio vendor: ASRock driver: snd_hda_intel 
  v: kernel bus ID: 08:00.3 
  Device-3: JMTek LLC. USB PnP Audio Device type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-5:2 
  Sound Server: ALSA v: k5.5.6-1-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8169 v: kernel port: e000 bus ID: 03:00.0 
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: 74:da:38:a1:32:ea 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASRock driver: r8169 v: kernel port: d000 bus ID: 04:00.0 
  IF: enp4s0 state: down mac: 70:85:c2:3b:b2:bd 
Drives:
  Local Storage: total: 5.46 TiB used: 4.59 TiB (84.0%) 
  ID-1: /dev/sda vendor: Western Digital model: WD20EZRZ-00Z5HB0 
  size: 1.82 TiB 
  ID-2: /dev/sdb vendor: Western Digital model: WD40EZRZ-19GXCB0 
  size: 3.64 TiB 
Partition:
  ID-1: / size: 23.91 GiB used: 16.20 GiB (67.8%) fs: ext4 dev: /dev/sdb3 
  ID-2: /home size: 3.56 TiB used: 3.03 TiB (85.1%) fs: ext4 dev: /dev/sdb2 
Sensors:
  System Temperatures: cpu: 50.1 C mobo: N/A gpu: amdgpu temp: 52 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1022 
Info:
  Processes: 282 Uptime: 40m Memory: 15.63 GiB used: 10.92 GiB (69.9%) 
  Init: systemd Compilers: gcc: 9.2.1 Shell: bash v: 5.0.16 inxi: 3.0.37 
[user@jetset ~]$ 

:+1: Welcome to Manjaro! :+1:

You could have 2 problems here:

  • Dodgy monitor (does it work under Windows?)
  • Dodgy Cable

Before connecting your current cable, try by setting all resolutions to pure VGA (640x480):

  • grub
  • Greeter (login screen): I don't have XFCE, cannot help you there
  • Desktop Environment itself: Normally done by right-clicking on the desktop in all environments I know.

Then shut down, connect and boot.

  • If that works, try ramping up to 800x600, 1024x768, ...
  • If that does not work and you have no other OS to test on, buy an adapter that claims it's compatible with Linux and test again. If it still doesn't work with a compatible adapter in 640x480 mode, the monitor itself is dodgy: it can still display pure text (80x25) but cannot switch to graphics mode (640x480) any more: get rid of it...
1 Like

Thank you for your reply.
I do have access to a computer running Windows 10, and it also has direct VGA output from the motherboard through integrated graphics. I just tested the monitor there, and it worked perfectly. Unfortunately, that same computer does not have a Displayport, so I can't test the adapters there. However, it seems way more likely that it's some kind of configuration error on my Linux PC than that 2 adapters were DOA. I had used two other Displayport to VGA adapters on this very computer, but with a different installation, I think I used Arch Linux back then. Unfortunately I don't have these adapters anymore since i didn't bring them with me when I moved.
I'd love to try that thing with setting a lower resolution, but considering all the stuff I'd have to change and then change back for that, I think I'll wait a while until other users have said their word on this.

buy an adapter that claims it's compatible with Linux and test again

A Displayport to VGA adapter saying that it's Linux-compatible would be kinda like a keyboard saying that it's Linux compatible. The adapter is essentially a virtual Displayport monitor that instead converts the digital DP signal to analog VGA. Even if I do find an adapter that says so on the box, it likely doesn't mean anything whatsoever.

1 Like

It should mean that they've tested it at least once on a Linux system. :innocent:

And yes: I've seen multiple Cheap! Crap! Inc! :tm: anything to anything display adapters not working on Linux whereas they did work on Windows, and one is coincidence, 2 is happenstance, but 3 is enemy action!

:joy: :stuck_out_tongue_winking_eye: :crazy_face:

P.S. Yes, 2 is unlikely but not impossible...

1 Like

Eh, one of the ones I had before was really cheap and unbranded, so that explanation feels even more unlikely, especially since the system freezes when I plug them in rather than just nothing happening at all.
The latest one I've tried supposedly uses some chip by Sunix which is considered very good, but I'll check with my brother if we can test it on his Windows computer.
EDIT: I'm gonna try these adapters booting from a Linux Live CD as well, might work.

I'm not saying that all the Cheap! Crap! Inc! :tm: adapters don't work! I've seen too many in the last 25 years that don't work is what I'm trying to convene, whereas I've never seen an active one misbehave, even the cheaper ones...

In a nutshell: don't absolutely, positively rule out that both of your cables might be busted...

¯\_(ツ)_/¯

Is there a DVI output on the GPU? A DVI to VGA adaptor should be more likely to work than DisplayPort to VGA. I know fewer cards have them with the advent of HDMI and DisplayPort but it's worth a crack if you have one. You should have, Sapphire usually include one on there cards still.

1 Like

Yeah, there's DVI output, but it's only DVI-D which doesn't include VGA in the signal. When I built this computer I looked far and wide for a decently new GPU that had analog output, but I just couldn't find one.
The Displayport to VGA adapters that this thread refers to are obviously converters and not just passive adapters.

Alright, I just tested out booting from a Live CD, more specifically GParted Live, while the CRT was connected through an adapter. I've tested both of my Displayport to VGA adapters, and they both work just fine when done like so. This seems to clearly be a software error of some sort.

1 Like

:sunglasses:

So if it's definitely a software error, what happens if you boot in the Manjaro fallback option from grub? Freeze again?

(sorry for all the dumb questions, I'm just following the same approach I would if I would be sitting next to you and narrow down which susbystem / driver is the culprit here...)

Alright, I'd love to test what happens in fallback mode, but unfortunately my installation appears to boot directly into the OS without even showing me the GRUB menu. Is there a way around this?

Yeah! Google Manjaro show grub and this is the first hit:

:stuck_out_tongue_winking_eye:

I used one of these for years without any problems. I still have a couple in the drawer from Sapphire AMD cards I no longer own


Also to get the GRUB menu keep tapping ESC or F8

Alright, just tested fallback mode. If I have the CRT connected through an adapter from the start, it gets stuck in the boot process with only an underline in the top left corner, and I can't even get the GRUB menu to show in that case. So I decided to plug the monitor in right after I have selected Fallback, but the same thing happens then.

Can you hook up 2 monitors because now it's starting to smell like a GPU issue...

:thinking:

I do unfortunately not have any monitors with a Displayport, so I can't really test that on my main installation. My GPU only has one DVI port which is used for my main monitor, and a Displayport which I'm trying to connect a CRT to through an adapter. That being said, 2 monitors works fine when booting from GParted Live.

OK, that's what I wanted to hear! :innocent:

Summary of current status is:

  • The CRT works in GParted Live (Do you know which resolution?)
  • The Computer works and boots on the DVI connected to another monitor
  • The computer "freezes" when both the DVI monitor and CRT are connected:
    • before booting
    • when already booted

You must've tried another kernel than 5.5.6-1 by now. If not, try in the following order: 4.19, 5.6, 5.4.

Only 640x480 or whatever it was, this is seemingly the only resolution that can be selected when I open the resolution settings. At least one of the adapters have specifications that go way higher, but this might be a limitation in GParted Live.

I actually haven't, I'll check that out later this evening.

So we're back to here:

¯\_(ツ)_/¯

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by