Do not Lock, suspend or hybernate when closing lid

Can anyone advise what I need to do to make the Manjaro Xfce version not go to sleep/suspend or lock when the laptop lid is closed? I use an external monitor.
This is easily doable in Mint as an option.
Thank you for your help.

Hi and welcome on the forum! Follow this links: Applications -> Settings -> Settings Manager and open the Settings of Manjaro. Open the Power Manager and coming on the tab of the screen. Then, desactivate the options of the screen. I hope to be help.

And - if you don't want it to sleep/power off while the login screen is active (ie. your not logged in), you need to add this:

In: /etc/systemd/logind.conf

HandleSuspendKey=ignore
HandleHibernateKey=ignore
HandleLidSwitch=ignore
HandleLidSwitchExternalPower=ignore
HandleLidSwitchDocked=ignore

Then run:

systemctl restart systemd-logind.service

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by