Docker containers cannot connect to internet/each other

So first of all, sorry that this post is actually a repost; my first post is this here:

However, sadly the issue did not get fixed via any updates until now and I also couldn't figure it out by myself.

So here I am again, asking for your much appreciated and professional grade help.

A tl:dr of my problem is as follows:

  • Containers started via docker or docker-compose cannot connect to each other or the internet
  • I can still ping other containers from within an alpine image, but calling wgetor anything beyond simple pinging fails. In case of wget:
    wget: can't connect to remote host (172.17.0.3): Host is unreachable
  • I have not changed anything about docker configs, especially none which configure how networking works
  • Currently I think the most likely culprit is my firewall which just drops everything that is sent to/from the docker interface
  • I have also not changed any firewall settings (well, actually I did after my first post, but I only tried to open as many ports and services as possible, so that can't really be the issue here)
  • Even if I kill firewalld, docker containers can't connect to anything
  • I tried to iptables-restore the output of iptables-save from a friend of mine, to get back to a "sane" iptables config, but this didn't help either

As far as I know this issue still isn't widespread at all, so I'm really at a loss here :frowning:

Any help is really appreciated!

2 posts were merged into an existing topic: Docker images fail to communicate with each other

Forum kindly sponsored by