Docker - segmentation fault

This command:

strace docker run -ti node:4-wheezy bash

consistently give me a 139 error (segmentation fault). I've checked on a few different machines with Manjaro and got the same result. On Debian it works just fine :thinking:

Running sh instead of bash works, but running bash, wget, or curl in that sh causes segfault as well

System:    Host: manjaro Kernel: 4.19.36-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.3.0 Desktop: Xfce 4.13.3 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: SAMSUNG product: 900X3C/900X4C/900X4D v: 0.1 serial: <root required> 
           Mobo: SAMSUNG model: SAMSUNG_NP1234567890 v: FAB1 serial: <root required> UEFI [Legacy]: Phoenix v: P02AAC 
           date: 06/01/2012 
Battery:   ID-1: BAT1 charge: 31.6 Wh condition: 34.0/40.3 Wh (85%) model: SAMSUNG Electronics status: Charging 
CPU:       Topology: Dual Core model: Intel Core i5-3317U bits: 64 type: MT MCP arch: Ivy Bridge rev: 9 L2 cache: 3072 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 13574 
           Speed: 1071 MHz min/max: 800/2600 MHz Core speeds (MHz): 1: 948 2: 937 3: 914 4: 910 
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics vendor: Samsung Co driver: i915 v: kernel bus ID: 00:02.0 
           Display: x11 server: X.Org 1.20.4 driver: intel unloaded: vesa resolution: 1600x900~60Hz 
           OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 4.2 Mesa 19.0.3 direct render: Yes 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Samsung Co driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 
           Sound Server: ALSA v: k4.19.36-1-MANJARO 
Network:   Device-1: Intel Centrino Advanced-N 6235 driver: iwlwifi v: kernel port: efa0 bus ID: 01:00.0 
           IF: wlp1s0 state: up mac: c4:85:08:60:af:31 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Samsung Co driver: r8169 v: kernel 
           port: 2000 bus ID: 02:00.0 
           IF: enp2s0 state: down mac: e8:03:9a:dc:02:28 
           IF-ID-1: br-0e0ba1d65143 state: down mac: 02:42:28:d7:d2:86 
           IF-ID-2: br-26f121612e64 state: down mac: 62:8f:ff:6c:5d:35 
           IF-ID-3: br-b127cc216625 state: down mac: 02:42:f2:8e:3b:34 
           IF-ID-4: br-c700c178c12f state: down mac: 02:42:47:41:db:19 
           IF-ID-5: br-cf57363ae05f state: down mac: a6:2c:15:87:b9:c0 
           IF-ID-6: br-da9aaccb108c state: down mac: 02:42:db:bb:12:be 
           IF-ID-7: docker0 state: down mac: 02:42:7c:fd:4f:b5 
Drives:    Local Storage: total: 223.57 GiB used: 183.72 GiB (82.2%) 
           ID-1: /dev/sda vendor: Kingston model: SMS200S3240G size: 223.57 GiB 
Partition: ID-1: / size: 218.57 GiB used: 183.45 GiB (83.9%) fs: ext4 dev: /dev/dm-0 
           ID-2: /boot size: 487.9 MiB used: 279.9 MiB (57.4%) fs: ext4 dev: /dev/sda1 
Sensors:   System Temperatures: cpu: 56.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 242 Uptime: 1h 22m Memory: 3.56 GiB used: 2.15 GiB (60.4%) Init: systemd Compilers: gcc: 8.3.0 
           clang: 8.0.0 Shell: zsh v: 5.7.1 inxi: 3.0.33 

Did you tried to add vsyscall=emulate to your Kernel command line?

On plain Arch I can reproduce your problem with the current linux package. Interestingly it does not happen with linux-lts . Adding vsyscall=emulateto the Kernel command line helps for the current linux Kernel in Arch.

3 Likes

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by