Docker service fails to start

So I just tried to install docker in my machine, after installation I tried to run it with systemd and got this:

● docker.service - Docker Application Container Engine
     Loaded: loaded (/usr/lib/systemd/system/docker.service; disabled; vendor preset: disabled)
     Active: failed (Result: exit-code) since Mon 2020-04-20 20:06:56 -03; 3min 51s ago
TriggeredBy: ● docker.socket
       Docs: https://docs.docker.com
    Process: 208647 ExecStart=/usr/bin/dockerd -H fd:// (code=exited, status=203/EXEC)
   Main PID: 208647 (code=exited, status=203/EXEC)

abr 20 20:06:56 manjaro systemd[1]: docker.service: Scheduled restart job, restart counter is at 3.
abr 20 20:06:56 manjaro systemd[1]: Stopped Docker Application Container Engine.
abr 20 20:06:56 manjaro systemd[1]: docker.service: Start request repeated too quickly.
abr 20 20:06:56 manjaro systemd[1]: docker.service: Failed with result 'exit-code'.
abr 20 20:06:56 manjaro systemd[1]: Failed to start Docker Application Container Engine.

I took a look at the journal but there's also nothing there.

Try again with sudo .

Jesus, I thought I was already doing it with sudo, but probably not since I now can see the problem is probably with containerd:

-- Defined-By: systemd
-- Support: https://archived.forum.manjaro.org/c/technical-issues-and-assistance
-- Documentation: man:core(5)
-- 
-- Processo 287690 (containerd) travou e despejou o núcleo.
-- 
-- Isso normalmente indica um erro de programação no programa que travou e
-- deveria ser relatado para seu fabricante como um erro.
abr 21 12:56:50 manjaro systemd[1]: systemd-coredump@3-287691-0.service: Succeeded.
-- Subject: Unit succeeded
-- Defined-By: systemd
-- Support: https://archived.forum.manjaro.org/c/technical-issues-and-assistance
-- 
-- The unit systemd-coredump@3-287691-0.service has successfully entered the 'dead' state.

OK, so next question is: why is containerd is segfaulting... ? (Hint: it also has journal entries :wink:)

Tbh I'm not sure, all I can think is that containerd got corrupted somehow during installation, manually asking pacman to reinstall it made everything go back to normal tho. I think my hard drive might finally be in his last breaths lol.

1 Like

try to run

dockerd

and see what's wrong

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by