Doom Eternal, AC: Odyssey, Proton, system monitoring, and other issues

First of all, I really effing hate that those big companies don't port games to Steam so that everyone can enjoy their friggin' games :rage:

Now that I've got that out of the system, under is my system (pun intended).

System:
  Host: linux-box Kernel: 5.7.0-3-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 10.1.0 Desktop: KDE Plasma 5.18.5 Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: ASUSTeK model: ROG STRIX B360-F GAMING v: Rev 1.xx 
  serial: <root required> UEFI: American Megatrends v: 1901 
  date: 02/20/2020 
CPU:
  Topology: 8-Core model: Intel Core i7-9700F bits: 64 type: MCP 
  arch: Kaby Lake rev: D L2 cache: 12.0 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 48016 
  Speed: 807 MHz min/max: 800/4700 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
Graphics:
  Device-1: NVIDIA TU104 [GeForce RTX 2080 SUPER] vendor: ASUSTeK 
  driver: nvidia v: 440.82 bus ID: 01:00.0 
  Display: x11 server: X.Org 1.20.8 driver: nvidia tty: N/A 
  OpenGL: renderer: GeForce RTX 2080 SUPER/PCIe/SSE2 
  v: 4.6.0 NVIDIA 440.82 direct render: Yes 
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
  Device-2: NVIDIA TU104 HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 01:00.1 
  Device-3: Corsair Corsair VOID PRO USB Gaming Headset type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-8:3 
  Sound Server: ALSA v: k5.7.0-3-MANJARO 
Network:
  Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e 
  v: 3.2.6-k port: efa0 bus ID: 00:1f.6 
  IF: eno1 state: up speed: 1000 Mbps duplex: full 
  mac: 04:d9:f5:82:6a:13 
Drives:
  Local Storage: total: 931.51 GiB used: 186.00 GiB (20.0%) 
  ID-1: /dev/nvme0n1 vendor: Kingston model: SA2000M81000G 
  size: 931.51 GiB 
  ID-2: /dev/nvme1n1 vendor: Kingston model: SA2000M8250G 
  size: 232.89 GiB 
Partition:
  ID-1: / size: 915.89 GiB used: 185.97 GiB (20.3%) fs: ext4 
  dev: /dev/nvme0n1p1 
Sensors:
  System Temperatures: cpu: 27.8 C mobo: N/A gpu: nvidia temp: 42 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
Info:
  Processes: 258 Uptime: 12m Memory: 15.56 GiB used: 2.78 GiB (17.8%) 
  Init: systemd Compilers: gcc: 10.1.0 Shell: zsh v: 5.8 inxi: 3.0.37

I wanted to play Doom Eternal through Steam (Proton) but the launcher tells me that I am using an old driver (same thing with AC: Odyssey) and that I need to update it. Unfortunately, there is nothing to update because I already am using the latest Nvidia driver for Linux. If I press 'Play anyway' the launcher closes and the game does not start. As for AC: Odyssey, I can sort of play it... the game launches, but I get an annoying pop-up that the drivers are outdated and it only lets me play on potato graphics.

I've tried searching ProtonDB to see if it runs and it seems as if some people manage to do so. I am apparently too stupid to figure out how ProtonDB works as well, because the comments tell me nothing; no settings, no workarounds, no nothing. Is there any workaround for this?

Next up:

  1. Since thermal monitor doesn't seem to work, are there any alternatives that are possible to use? That applet seemed perfect, as it monitors everything from disks to CPU, but it seems that it is broken.
  2. Is there an alternative to MSI's Afterburner? I want to set my graphics card to not pass the 70°C (that's 160°F for you yankees :stuck_out_tongue_winking_eye:). If it's possible to do so using terminal or whatever, please teach me how to do so.
  3. I have a Razer DeathAdder Elite mouse and I remember that on Ubuntu there was an open source alternative to their Synapse (which, imo, sucks anyways as it is super-bloated) - is there something similar for Manjaro? If so, what packages do I need to use in order to make it work?
  4. Is it possible to set the fan speeds for the CPU? I am using a Corsair H115i processor cooler.

I know this is a lot to ask, but I'm afraid to bork my system by installing all sorts of crap. And, because this is the first time I've managed to use Linux without trouble, I'd like to keep it that way :joy:

Many, many thanks to this wonderful community for making me stick to Manjaro and helping me countless times before. Even if you can't help, you're still the reason why I will continue using this distro!

EDIT: forgot to mention that the scroll wheel doesn't work any more when trying to scroll thing such as the pacman GUI and if I try to click the scroll bar, I almost need surgical precision or else it will click something else.

What is the exact wording?

You need to show what the terminal outputs for people to help you. You can launch steam via terminal, then try to launch the game, and it'll output information.

Are you 100% sure you're running the game with your NVIDIA dGPU and not your Intel iGPU?

And did you follow the suggestions on Protondb?

Please make separate forum posts for these. Don't bunch up a lot of things in one post.

Alright. I was running Steam as a flatpak, so I tried uninstalling it and instead installed Steam and LSI from the official repos and now it runs perfectly. It just crashed the first time I launched (this time I didn't even get the prompt up, so I am guessing it was flatpak's fault), so I disabled the intros and launched it with gamemode enabled and now it runs almost as if I had Winblows installed :partying_face:

Duly noted. Should I make a separate post for each item or can I bunch them up in the new one?

How do I check this? Since I run it through Steam which, in turn, opens up Uplay in order to play AC, I'm suspecting that everything runs through Wine; which is why it keeps pestering me with "wrong driver".

As each one is a different topic, yes you should make separate posts. Bunching up everything in one thread makes responses complicated, and harder for other users to use the forum's search engine to find info. You can also research some of these yourself before asking. You don't need to look in Manjaro specifically, you can use a search engine to look for Linux programs.

Well, I assume you installed Proton in Steam to run these games.

Disregard, that Intel i7-9700F doesn't have an iGPU.

1 Like

I should get a medal for being as ■■■■■■■■ as I am: I just did some googling and found a video on YT on how to apply the parameters... turns out I just had to set them in the launch options. I tried going into Wine to search for the parameters they were talking about on ProtonDB, so no wonder I couldn't figure out where to apply them :sweat:

Everything works great now. Thank you for the time you took to answer me - appreciate it!

Yeah, I already did, as I knew it doesn't have an integrated GPU. But you sure got me wondering :laughing:

Alright, I'll do some digging and if it doesn't matter if I'm using Manjaro, I'll try that. If that doesn't work, this won't be the last time you hear from me :joy:

EDIT: screenshot with the benchmarks. Still not as good as Winblows, unfortunately, but more than satisfied with the results!
Screenshot_20200626_233310

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by