Downloading XCom2 on steam makes KDE lagging

This is a weird problem. XCom 2 on steam. When downloading it the whole KDE gets slow and the graphic are lagging. It doesn't happen with other games I downloaded. Granted that XCom2 is over 60 GB download, but it shouldn't affect the performance of KDE. I didn't had that problem with eOS.

Specs:

[strom@universe ~]$ inxi -Fxxxza --no-host
System:
  Kernel: 5.7.0-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.7-x86_64 
  root=UUID=763e00cd-aa0d-49cd-9d8a-b001b4e49b3c rw iommu=pt 
  udev.log_priority=3 
  Desktop: KDE Plasma 5.18.5 tk: Qt 5.15.0 info: latte-dock wm: kwin_x11 
  dm: SDDM Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: ASUSTeK model: PRIME X370-A v: Rev X.0x 
  serial: <filter> UEFI: American Megatrends v: 0805 date: 06/20/2017 
Battery:
  Device-1: hidpp_battery_0 model: Logitech Wireless Solar Keyboard K750 
  serial: <filter> charge: 84% rechargeable: yes status: Charging 
  Device-2: hidpp_battery_1 
  model: Logitech Marathon Mouse/Performance Plus M705 serial: <filter> 
  charge: 55% (should be ignored) rechargeable: yes status: Discharging 
CPU:
  Topology: 8-Core model: AMD Ryzen 7 1700X bits: 64 type: MT MCP 
  arch: Zen family: 17 (23) model-id: 1 stepping: 1 microcode: 8001126 
  L2 cache: 4096 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 108628 
  Speed: 2150 MHz min/max: 2200/3400 MHz boost: enabled 
  Core speeds (MHz): 1: 1991 2: 2105 3: 1746 4: 1744 5: 2798 6: 2808 
  7: 1732 8: 1736 9: 2161 10: 1778 11: 1858 12: 1796 13: 1805 14: 1798 
  15: 3132 16: 3164 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Full AMD retpoline, STIBP: disabled, RSB filling 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: NVIDIA GP104 [GeForce GTX 1070] vendor: ASUSTeK 
  driver: nvidia v: 440.82 bus ID: 2a:00.0 chip ID: 10de:1b81 
  Display: x11 server: X.Org 1.20.8 driver: nvidia compositor: kwin_x11 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: GeForce GTX 1070/PCIe/SSE2 v: 4.6.0 NVIDIA 440.82 
  direct render: Yes 
Audio:
  Device-1: NVIDIA GP104 High Definition Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 2a:00.1 chip ID: 10de:10f0 
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 2c:00.3 chip ID: 1022:1457 
  Sound Server: ALSA v: k5.7.0-3-MANJARO 
Network:
  Device-1: Qualcomm Atheros AR9227 Wireless Network Adapter 
  driver: ath9k v: kernel bus ID: 27:01.0 chip ID: 168c:002d 
  IF: wlp39s1 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8169 v: kernel port: f000 bus ID: 28:00.0 
  chip ID: 10ec:8168 
  IF: enp40s0 state: down mac: <filter> 
Drives:
  Local Storage: total: 1.14 TiB used: 22.31 GiB (1.9%) 
  ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 250GB 
  size: 232.89 GiB block size: physical: 512 B logical: 512 B 
  speed: 6.0 Gb/s serial: <filter> rev: 2B6Q scheme: MBR 
  ID-2: /dev/sdb vendor: Toshiba model: DT01ACA100 size: 931.51 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: A750 scheme: GPT 
Partition:
  ID-1: / raw size: 232.42 GiB size: 227.77 GiB (98.00%) 
  used: 8.74 GiB (3.8%) fs: ext4 dev: /dev/sda5 
  ID-2: /home raw size: 931.51 GiB size: 915.89 GiB (98.32%) 
  used: 13.58 GiB (1.5%) fs: ext4 dev: /dev/sdb1 
Sensors:
  System Temperatures: cpu: 49.6 C mobo: N/A gpu: nvidia temp: 49 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
Info:
  Processes: 309 Uptime: 7m Memory: 31.30 GiB used: 1.82 GiB (5.8%) 
  Init: systemd v: 245 Compilers: gcc: 10.1.0 Shell: bash v: 5.0.17 
  running in: konsole inxi: 3.0.37 
[strom@universe ~]$ 

best regards
Storm

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by