Drivers missing for many components and chipset of Legion Y540

Hello Community,

I have install Manjaro in Legion Y540. However, I have some missing drivers for its components and chipset as shown in the below snapshots:

image

image

I would like to install them. How can I know which are these unknown devices and where can I find their drivers. Just as additional info, the machine came with following drivers/software preinstalled in windows: Precision Driver for touch-pad, TPM 2.0 security chip (Firmware TPM 2.0 integrated in chipset), Dolby Atmos for Gaming (Audio), Lenovo Vantage software. I want to install open source or proprietary drivers for unknown devices.

Device configuration and hardware details can be found here (small 1 pager).

Following the output of inxi -Fxxxz:

System:    Host: manjaro-009 Kernel: 5.3.7-2-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 Desktop: Xfce 4.14.1 
           tk: Gtk 3.24.12 info: xfce4-panel wm: xfwm4 dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 81SY v: Lenovo Legion Y540-15IRH-PG0 serial: <filter> Chassis: type: 10 
           v: Lenovo Legion Y540-15IRH-PG0 serial: <filter> 
           Mobo: LENOVO model: LNVNB161216 v: SDK0Q55722 WIN serial: <filter> UEFI: LENOVO v: BHCN32WW date: 08/29/2019 
Battery:   ID-1: BAT0 charge: 35.2 Wh condition: 52.5/52.5 Wh (100%) volts: 11.8/11.3 model: LGC L17L3PG1 type: Li-poly 
           serial: <filter> status: Discharging cycles: 3 
CPU:       Topology: Quad Core model: Intel Core i5-9300H bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 38408 
           Speed: 1000 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 1000 2: 1000 3: 1001 4: 1000 5: 1000 6: 1001 7: 1000 
           8: 1001 
Graphics:  Device-1: NVIDIA vendor: Lenovo driver: nvidia v: 440.26 bus ID: 01:00.0 chip ID: 10de:1f91 
           Display: x11 server: X.Org 1.20.5 driver: nvidia tty: N/A 
           OpenGL: renderer: GeForce GTX 1650/PCIe/SSE2 v: 4.6.0 NVIDIA 440.26 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:a348 
           Device-2: NVIDIA vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:10fa 
           Sound Server: ALSA v: k5.3.7-2-MANJARO 
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel bus ID: 00:14.3 chip ID: 8086:a370 
           IF: wlp0s20f3 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169 v: kernel port: 3000 
           bus ID: 07:00.0 chip ID: 10ec:8168 
           IF: enp7s0 state: down mac: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 10.33 GiB (2.2%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB512HBJQ-000L2 size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> rev: 3L1QEXF7 scheme: GPT 
Partition: ID-1: / size: 227.68 GiB used: 10.33 GiB (4.5%) fs: ext4 dev: /dev/nvme0n1p2 
Sensors:   System Temperatures: cpu: 47.0 C mobo: N/A gpu: nvidia temp: 45 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 230 Uptime: 1h 57m Memory: 7.70 GiB used: 1.59 GiB (20.7%) Init: systemd v: 242 Compilers: gcc: 9.2.0 
           Shell: bash v: 5.0.11 running in: xfce4-terminal inxi: 3.0.36 

Awaiting your feedback on the same. Thanks in advance for your help.

Regards,
User Manjaro.

I think you are expecting too much with such new hardware. Give it a few months for Linux developers to catch up with most of the unidentifiable hardware but you won't ever get proprietary Dolby Atmos support in Linux.

Also, for now try kernel 5.4 even though it is a release candidate.

As for TPM, refer to this

3 Likes

The corresponding solution in linux is this https://wiki.archlinux.org/index.php/Touchpad_Synaptics if the touchpad doesn't work with the preinstalled libinput. If the touchpad works, there is nothing to do then.

For that consult this https://wiki.archlinux.org/index.php/Trusted_Platform_Module

It seems the audio is detected as

Doesn't work? It had some features in Win that are not available under Linux? Please exemplify.

According to this https://forums.lenovo.com/t5/Pre-Installed-Lenovo-Software/is-there-is-a-levovo-vantage-for-ubuntu/td-p/4140365

Currently there is no Vantage for Linux.

According to this https://bashelton.com/2019/05/linux-on-the-lenovo-y740-legion-2019/ you don't have to do much. The Laptop works ...

3 Likes

Hi Micsim35,

Thanks for your instant reply.
I understand that, but is there a way to get them working as of now? I bought this machine because I need this hardware for my Data Science/ML/AI work and exams.

I know, I won't get Atmos in linux. But AFAIK, there's way to get same level of audio using open source tools such as pulse audio. As this is more hardware dependent and not software.

I went through the guide for TPM, but it contains procedure for TPM1.2, mine is TPM2.0. So don't know how to get TPM2.0 (Firmware TPM 2.0 integrated in chipset) working.

Thanks.

if the laptop is functioning then they already are even if not being identified by name properly. TPM is beyond my remit

then maybe stick with W10? I know it's not the answer you want to hear but if you are using the device for such critical work, a rolling linux distribution is probably not the wisest choice.

you can always run linux in virtual machine if you need access to opensource programs windows doesn't support.

2 Likes

Hi bogdancovaciu,

Thank you for the quick reply.

It works, then suddenly touchpad disappears from the settings menu and it stops working. I have then do the 30-touchoad.config trick and reboot to get it back working. Again after 2-3 reboots it stops working.

As I mentioned, I went through the guide for TPM, but it contains procedure for TPM1.2, mine is TPM2.0. So don't know how to get TPM2.0 (Firmware TPM 2.0 integrated in chipset) working.

As? Sorry I didn't understand it :sweat_smile:. It's not detected. Audio is shown as Intel and Nvidia, check my screen shots attached in the 1st post. :slight_smile:

Like, Intel ME and Intel graphics (I tried to installed it with MHWD, it failed at first and then installed. But when I use switchable graphics from my BIOS, the screen blacks out and I'm not even able to start TTY session. After wasting 2 days, I had to settle for Discrete Graphics option in bios along with Nvidia Proprietary dirvers.). Still switchable graphics option is unusable for me, and I don't want to format my system again and waste another day to 2 to setup the machine. Anyway to get it working? Other ME like intel specific features.

I have not dual booted the system as only 512 GB SSD is available right now. I did try the TLP software but it doesn't help with start and stop thrresholds for charging, infact it shows unknown for charging state.

Can you suggest some alternative like TLP, or how to make it work with TLP.

Had a look at that before installing manjaro on Y540 :smiley:. Still waiting for his part 2 :stuck_out_tongue:

Thanks for your reply though :slight_smile:

If you get any info regarding the same (TPM2.0), let me know :slight_smile:

That will be my last option :sweat_smile:. Don't want to go on that road, Fingers crossed :slight_smile:

Thanks for your help so far though.

Apart from the obvious problems like Dolby, can you guys help me with TLP (for vantage like charging control), get Dolby level of Audio using open source software/Firmware like Pulse Audio (as I have a hardware capable enough for that), TPM2.0, Intel Graphics, ME and intel specific features.

Thanks :smiley:

Lenovo Technical specification for audio is useless:

Harman® speakers with Dolby Atmos® for Gaming
registered brand names just obstruct finding model number of standard Realtek codec

there is only one Linux audio driver for this device and you have it - snd_hda_intel
but driver may need reconfiguration or kernel patch to function correctly

please run alsa-info.sh --upload and post the link from the response here

4 Likes

There is a TPM 2.0 there in that arch wiki ...

I don't trust screenshots, but i trust the inxi, and in your case

Is the audio, the onboard, working or not?
If not, see the post from @nikgnomic :wink:

2 Likes

quote="nikgnomic, post:9, topic:109653"]
please run alsa-info.sh --upload and post the link from the response here
[/quote]
@nikgnomic:
The requested details are here.

@bogdancovaciu:
I thought there should be steps just like those mentioned for TPM1.2 in that wiki. I'll look for it again.

@bogdancovaciu:
I have tried with both libinput and synaptics, but the trackpad is still not working. Can you help me with this please.

Thanks.

Is it enabled? touchpads can be turned on and off with function keys. Also, they can be disabled if you plug in another pointing device.

I've tried enabling and disabling the touchpad from fn keys. But since the touchpad itself is missing from the menu, there's no effect. I tried removing mouse and rebooting, still no luck :frowning:

Trying once again, with reinstalling both Synaptics and Libinput; and re-creating their config files in xorg.config.d directory. Fingers crossed :slight_smile:

Let me know, if you recall some other idea.

Thanks

Still No Luck.
Awaiting help on this issue :slight_smile:

ALSA information looks good at hardware level for Realtek ALC257

only thing that looks off is audio recording levels

'Capture' and 'Internal Mic Boost' are both on [100%] [30.00dB]
30dB+30dB is way too much; would expect microphone to sound like unintelligible distortion

likely need to turn them down in alsamixer --card 0
(use keyboard arrow keys to find and adjust settings)
start with 'Internal Mic Boost' on 0.00
increase to 10.00dB if needed - should not need any more on a Lenovo

to save any changes to ALSA: sudo alsactl store

audio playback should be functional, but probably not good quality of sound
Linux audio driver does not have any software audio processing like Realtek windows drivers
but there are a few generic effects, including an equalizer, available in pulse-effects

some Pulseaudio configuration changes (to file daemon.conf) can also improve audio quality
should be a few previous discussions on here dealing with that

3 Likes

Hi All,

Hope, you are having a good day :slight_smile:
Sorry for the late response, was busy in exams.

@nikgnomic:

Thanks for the reply. I need to check those mic settings.

I'm actually getting crackling audio output. Can I fix it? It's not usable at mid or high volumes.
And Low volume is not so audiable :sweat_smile:

@bogdancovaciu @anon71843593:
I actually got my touchpad and brightness working using following:
Step1:
In /etc/X11/mhwd.d/nvidia.conf
Option "RegistryDwords" "EnableBrightnessControl=300

Step2:
In /etc/default/grub
GRUB_CMDLINE_LINUX="acpi_backlight=video acpi_osi=off"

With above, both Brightness and Touchpad are now working fine.

However, now I'm unable to change my resolution using NVIDIA-settings. I only get option of scaled resolutions in NVIDIA-settings (which doesn't display entire screen contents). In Display settings of XFCE, I only get the option of 1920x1080.
Also, when I'm trying to "Print-Screen" using PrtSc button, while resolution options of Nvidia-settings is selected, I'm unable to do so. To PrtSc, I have to click elsewhere on screen, then it works. However, it closes the resolution drop-down menu. Also, the super key doesn't work when the drop-down box is select.
How can I get my resolution and key's not working issues fixed? I don't want scaled resolutions, which doesn't display all screen contents. Also, I would like if my keys are working fine and when any application is running.

Any help is appreciated.

Thanks in advance :smiley:

Regards,
UserManjaro

1 Like

PS: I had to use delayed screenshot for to capture this snaps:

NVIDIA-Settings:
image

Display settings:
image

Now PrtSc is not working while selecting Display-settings as well.

go to alsamixer --card 0
find level control marked 'Speaker'
reduce level from 100% to 50%

reduce level at final control for playback in alsamixer to allow greater range of control for preceding level controls in Pulseaudio

Ok. I'll do that and try. Thanks.

Sorry, I didn't get you :sweat_smile:. Can you please explain it to me :sweat_smile:
Thanks

last part was general explanation that i should have done better
was trying to keep it brief whilst you are juggling more than one issue

audio in system first goes through Pulseaudio then ALSA
Pulseaudio [Playback > Output Devices] > ALSA [Master > Speaker] > jack socket
usually, adjusting volume is done in Pulseaudio and ALSA levels stay fixed

this is similar in principle to any other OS
user adjusts volume at application/software level
level setting for hardware devices is usually set once for comfortable listening level
if the hardware level is too high may only be able to use lower level settings in software

if hardware level is reduced by 50% user gets 2 times amount of useable range in the software level control

1 Like

Forum kindly sponsored by