Drivers not working for Nvidia GTX 1650

The things I've tried so far

I installed Manjaro KDE from the live usb. It worked sorta fine, occassional screen flickering on logging out but generally fine.

I installed the non-free drivers from the configuration utility and the GUI stopped coming on. It'll load until the startup message and nothing would show up. I could switch to other TTYs but startx did not work.

Then I uninstalled the nvidia driver and followed this guide to install optimus manager and rename the xorg config files etc and now I've non-free drivers installed and the system boots but it's still not right.

The few things I noticed amiss are that,

  • Sometimes KDE won't log in, blank screen but I can switch TTY and reboot
  • Screen flickering sometimes after screen turns off, like when logging out
  • nvidia-settings won't open saying unable to load info from any available system.
  • optimus-manager-qt fails to load saying unable to detect GPU

but other than these

  • systemctl status optimus-manager.service seems to be fine, says there's a key error intel but seems ok
  • inxi -G says
Graphics:  Device-1: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] driver: N/A 
Device-2: Advanced Micro Devices [AMD/ATI] Picasso driver: amdgpu v: kernel 
Display: x11 server: X.Org 1.20.7 driver: amdgpu FAILED: ati unloaded: modesetting resolution: 1920x1080~120Hz 
OpenGL: renderer: AMD RAVEN (DRM 3.35.0 5.4.23-1-MANJARO LLVM 9.0.1) v: 4.5 Mesa 19.3.4

So, out of all this, I'm not really sure what should I fix. I'd really like some help with this, first time using linux on an Nvidia graphics card. Any hint would be appreciated.

My system is a laptop with a Ryzen 5 processor and a Geforce GTX 1650.

That's not all too surprising. You have an AMD-NVIDIA hybrid so can't just use the NVIDIA drivers.

Install the video-hybrid-intel-nvidia-440xx-prime driver profile and use prime-run when you want to use the NVIDIA GPU.

2 Likes

Yes, as @jonathon said, optimus-manager is not meant for AMD-NVIDIA combo.

In a way, AMD-NVIDIA is a bit easier, because there are no 3 modes, you operate only from Hybrid mode, where system will use AMD by default but if you want to run Nvidia, you add prime-run to the start command. So no need to switch anything.

I assume you already have video-hybrid-intel-nvidia-440xx-prime installed, so you need to undo what you did for optimus-manager:

To uninstall the program, simply remove the optimus-manager package. The auto-generated Xorg config file will be automatically cleaned up. Restore mhwd configs and others if they weren't restored automatically.

You can also force cleanup by running optimus-manager --cleanup.

And of course you should remove optimus-manager-qt as it is useless in this case.

2 Likes

Thank you both of you guys, I installed the video-hybrid-intel-nvidia-440xx-prime driver and it seems to be ok now.

I had trouble uninstalling the non free driver as there was an mhwd.conf in /etc/X11 somewhere which still mentioned nvidia. My desktop wasn't loading because nvidia module was not found. But once I renamed the file, it started coming on again and I was able to install the video-hybrid-intel-nvidia-440xx-prime

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by