Dual boot Manjaro alongside Windows 10 in Dell G3

Greetings guys, I have use manjaro linux before, previously I just use solely manjaro on a pc, it runs fine. Now I have a new laptop, Dell G3 with the following hardwares:
processor: Intel i5-8300H
ram: 8gb + 4gb ddr4 ram
gpu: Nvidia GTX 1050
ssd: intel 256gb
hdd: 1 tb hdd

It comes with Windows 10 installed in the SSD. I have created an empty partition in the SSD for the manjaro installation.

I have disabled secure boot in BIOS and change fast boot to minimal.
I have changed the ssd mode from RAID to AHCI
I am using the manjaro XFCE 17.1.11 (the latest from the manjaro stable release). I burn the iso into a usb then try to boot from the usb.
The first time I booted from the usb with no changes, it successfully booted but after a few second it freezes, so I have to force shut down and boot it again.
This time it won't enter the manjaro desktop, it stops at "Started TLP system startup/shutdown".
I edit the boot command, added "acpi_rev_override=1" but it is still doesn't boot.
Therefore, I couldn't manage to install manjaro xfce alongside Windows 10.

Any helps would be appreciated.


1 Like

Just to get it out of the way:

  • Did you check the iso sum if it's correct?
  • Did you try creating live usb with different program?
  • Did you try different usb (it's weird but it's sometimes helping)?

Also, what is fast boot minimal? Shouldn't be just no fast boot at all? This shouldn't affect install thou.
As to RAID to AHCI, why the change?

Yea, I did checksum on the iso. I using terminal to create the usb on my old laptop running manjaro.
I haven't try it with another usb, would give it a try.
The fast boot options in BIOS only has thorough, auto and minimal, so I chose minimal.
The change from RAID to AHCI is because I follow this guide from github.

Hmm... I thought that Dell supports usually Linux well. I'm stunned that one have to do all the tweaks to boot it. Usually it just works out of the box. Tried it on Lenovo, Asus, Toshiba, Alienware, all hassle free.

The latest iso seems to be from march this year so it's possible that something has changed and the instructions from this guide may be a bit obsolete and need some tweaking, at least for your machine. What exactly? Hard to tell.

You may try out Manjaro Architect or different flavor like Manjaro KDE or something else and then add Xfce to it later. Xfce usually don't cause problems with other DEs but it will be in very raw state after installing and it needs lot of work to make it look and work decent thou.

Tried it with another USB with the iso image of manjaro-17.1.11 xfce to no avail.
I went with manjaro-architect, I also chose xfce as the desktop environment during the installation process. Followed the official guide of manjaro-architect, a few hiccups is I am not sure which partition for the UEFI boot, I simply chose 1 4M partition and the bootloader choice, I went with system.d since it said it could auto detect windows.
After going through the entire installation process, it said I don't have bootloader installed and no users account defined but I clearly did that.

I rebooted and it doesn't have the options to choose which OS to boot into. On the bright side, Windows is still being booted, I didn't wreck windows. I am flabbergasted at this point, not sure what more can be done. Probably create a small partition on the drive for the UEFI boot thing and try manjaro-architect again.

I think your hardware is new enough that the 4.17 kernel may not be recognizing your hardware properly. You might want to try one of @philm's newest builds using the 4.18 kernel series and see if there is a difference.


1 Like

Ah...now that you have done that,
And if that means you have an installed partition
maybe we can help some.

Take a look at this.
If this still does not help, check if you really have an installed partition with boot and kernels in it.
We still can do something.
Oh, and provide the info required as per the link.
If in livecd, substitute findmnt -s with /etc/fstab of the installed partition.
Since you had experience with manjaro, I guess you know what I'm talking about.
If you don't know, it's okay, ask.

I tried the manjaro-architect method again, this time i created a small partition of 300mb for the uefi boot. But after all the process, when I am about to exit the installer, it mentioned that I don't have bootloader installed but I clearly installed grub without any error message.

I give up! Look like I am stuck with windows 10 for the time being.

Thanks for the help and advice provided guys.


I think that @gohlip got you quite good info to follow. Also, did you Manjaro beta iso's with newer kernel that @c00ter mentioned about?
You still haven't used all the options so giving up is premature IMO.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by