Dual boot problems

Sorry if this is a dumb problem but I’m having some trouble dual booting Manjaro. The live boot works and I’ve partitioned the drives but when I restart it and unplug the usb, the computer boots up to windows 10. Any help would be appreciated, thanks.

This may be of help Using livecd v17.0.1 (and above) as grub to boot OS with broken bootloader .

The author is a Grub wizard.


maybe the windows boot loader is being loaded before grub, you can check that on your BIOS or UEFI, the menu you hold down F2 or some other key for at the begining of your boot

There doesn’t seem to be an option for GRUB. Only the boot loader. Is there any way to fix this?

Thank you, I think that ended up working.

1 Like

Nevermind, it did allow me to boot up to the install but only with the usb in. When it’s out windows bootmanager is the only option.

When booted, provide output at terminal

sudo parted -l
sudo blkid
efibootmgr -v
findmnt -s

Well it was worth a try. I see that gohlip has responded, you are now in good hands.

1 Like

Thanks, here is the output.

sudo parted -l
[sudo] password for J: 
Model: ATA HGST HTS721010A9 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name                          Flags
 1      1049kB  316MB   315MB   fat32           EFI system partition          boot, esp
 2      316MB   450MB   134MB                   Microsoft reserved partition  msftres
 3      450MB   538GB   537GB   ntfs            Basic data partition          msftdata
 7      538GB   559GB   21.0GB  ext4
 8      559GB   567GB   8389MB  linux-swap(v1)
 9      567GB   615GB   48.2GB  btrfs
10      615GB   615GB   30.4MB  fat32                                         msftdata
 4      616GB   617GB   1022MB  ntfs                                          hidden, diag
 5      617GB   977GB   361GB   ntfs            Basic data partition          msftdata
 6      977GB   1000GB  22.8GB  ntfs            Basic data partition          hidden, diag

Model: Lexar USB Flash Drive (scsi)
Disk /dev/sdb: 32.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      32.8kB  1753MB  1753MB  primary               boot
 2      1753MB  1757MB  4194kB  primary               esp

J@Paulings ~]$ sudo blkid
/dev/sda1: LABEL="SYSTEM" UUID="FEC1-C808" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="c7f23e84-9454-4f72-811b-7309d939a8a7"
/dev/sda2: PARTLABEL="Microsoft reserved partition" PARTUUID="b7a090be-3801-47fb-abdc-f1b4620a0771"
/dev/sda3: LABEL="OS_Install" UUID="847CC2E77CC2D35A" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="ce5a3f8b-18f7-4f9a-9882-aa4090115c35"
/dev/sda4: UUID="00EA413CEA412EEA" TYPE="ntfs" PARTUUID="38abc7f7-3483-41bd-8b9a-e5db98a3b2b0"
/dev/sda5: LABEL="Data" UUID="B29CAB669CAB2437" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="0334452b-7d59-41e3-95ce-54a556609f9f"
/dev/sda6: LABEL="BIOS_RVY" UUID="52E8CAAEE8CA8FA1" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="b2dc578c-8220-407a-b0cb-a9f2d54b2944"
/dev/sda7: UUID="88335d4a-591a-43ff-abd0-41adc8ececb4" TYPE="ext4" PARTUUID="87bfe58b-e48e-4bba-9efb-344267858d56"
/dev/sda8: UUID="197de6e2-799c-472b-90d4-968311a43901" TYPE="swap" PARTUUID="b182f1c5-c2d0-4898-b1c4-0bc727c7499d"
/dev/sda9: UUID="2cb21815-a99c-4770-8a7f-48b99e055ced" UUID_SUB="85f325e3-1030-42d8-a658-cb54fed9e13f" TYPE="btrfs" PARTUUID="670e5906-43ba-4670-9377-4a9d7de1e513"
/dev/sda10: UUID="5CE0-E58A" TYPE="vfat" PARTUUID="924eff5c-30c4-4dca-a0e3-324b36544489"
/dev/sdb1: UUID="2018-04-15-00-11-46-00" LABEL="MJRO1718" TYPE="iso9660" PARTUUID="e01b2faf-01"
/dev/sdb2: SEC_TYPE="msdos" LABEL="MISO_EFI" UUID="3FC5-5E55" TYPE="vfat" PARTUUID="e01b2faf-02"
[J@Paulings ~]$ efibootmgr -v
BootCurrent: 0001
Timeout: 2 seconds
BootOrder: 0001,0000
Boot0000* Windows Boot Manager	HD(1,GPT,c7f23e84-9454-4f72-811b-7309d939a8a7,0x800,0x96000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}...5................
Boot0001* UEFI: Lexar USB Flash Drive 1100, Partition 2	PciRoot(0x0)/Pci(0x14,0x0)/USB(7,0)/HD(2,MBR,0xe01b2faf,0x343b7c,0x2000)..BO
[J@Paulings ~]$ findmnt -s
TARGET    SOURCE                                    FSTYPE OPTIONS
/         UUID=88335d4a-591a-43ff-abd0-41adc8ececb4 ext4   defaults,noatime
swap      UUID=197de6e2-799c-472b-90d4-968311a43901 swap   defaults,noatime
/home     UUID=2cb21815-a99c-4770-8a7f-48b99e055ced btrfs  defaults,noatime,space_cache,autodefrag
/boot/efi UUID=5CE0-E58A                            vfat   defaults,noatime

I have no idea what I'm saying, I'm just trying to understand what's happening because I'm interested now. From what I see, from your efibootmgr -v output, the bootloader first tries to launch the Windows Boot Manager, than boot from your USB, but never launch grub. My guess is that grub failed to install or maybe just failed to position himself in the boot order

Okay, boot up to Manjaro installed OS again, and at terminal (as per the link)

sudo grub-install
sudo update-grub
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo efibootmgr -c -d /dev/sda -p 10 -L “manjaro” -l “\EFI\Manjaro\grubx64.efi”

Note: "-p 10" as your $esp is in sda10
When done, note output of "efibootmgr"
and post output next time you reply.

Reboot normally (without livecd)
BTW, what's computer make and model?

Good luck.

ps: if it fails to boot again (hopefully not), when booted (with livecd), check "efibootmgr" again and post new output with the previous output of "efibootmgr"

Thanks for helping out. Much appreciated.
I don't get much help other than from @AgentS :wink:

1 Like
BootCurrent: 0001
Timeout: 2 seconds
BootOrder: 0002,0001,0000
Boot0000* Windows Boot Manager
Boot0001* UEFI: Lexar USB Flash Drive 1100, Partition 2
Boot0002* manjaro

There's the output, I'll try rebooting now. The computer is an msi ge62 but some components may not be original because it was bought used.
By the way, thanks for the help. I'm not very familiar with linux as of now and it's been very helpful being able to ask someone.

It ended up booting to windows again, here is the new output.

BootCurrent: 0001
Timeout: 2 seconds
BootOrder: 0001,0000
Boot0000* Windows Boot Manager
Boot0001* UEFI: Lexar USB Flash Drive 1100, Partition 2

I wouldn't know but is it possible that something in the BIOS removed the GRUB bootloader or something like that? I would think that because it's not listed as one of the options. I'm booting with UEFI without safe boot on.

Right. Check this website and this as well and both say to turn TPM (trusted platform module) to 2.0.

Turn off secure boot
Set boot to UEFI (DO NOT USE CSM)
Set TPM to 2.0 with 1.x compatibility

I first set my BIOS to turn off secure boot
Set Boot to UEFI and not CSM
Set TPM to 2.0 mode with 1.x compatibility mode TPM mode setting is for if you plan to self encrypt your drive. (I didn't) I set it anyway.
pretty straight forward but it worked like a charm. Many people are having issues with MSi Laptops and Ubuntu

Hope this helps. Let us know. Good luck.

It doesn’t look like this computer has any TPM module. If it helps, the GRUB bootmanager doesn’t show up as an option in the BIOS even after configuring it and everything.

Okay. I've read somewhere that in MSI uefi bios-setup, you need to 'drag' the boot device in the boot priority.
I couldn't find that page again, but here there's a post

I have a different motherboard so it may be different, but there are two places to set the boot order.

  1. At the top you can drag the different bootable devices over to set your boot priority.
  2. In the hardware section the boot priority can be set too.

See if you can find it. I don't have MSI.
Good luck.

I try to help with the little I know, also to further my understanding of linux, I try to read the forums and see if I can help from time to time ^^

Does the boot option for manjaro in grub dissapear after having booted manjaro a few times, or only dissapears after launching Windows Boot Loader ?

I don't know if you've tried this https://wiki.manjaro.org/index.php/Restore_the_GRUB_Bootloader but it could bring things you haven't tested out yet. In it they say to enter root mode using sudo su as they are booted in the live cd, be sure to never do that if you're on your own installed system unless you know what you're doing, it's safer to just add sudo before your specific commands.

Please try to boot in the Manjaro installation manually following the link at the first answer given.
Then follow the same tutorial to force-add the Manjaro UEFI boot option.
I think that you haven't done this, I maybe wrong. Am I?

I just did the dual boot today, and I have the same problem, but managed to fix it by referencing an article in 'It's FOSS'.
In Windows 10, run Command Prompt as administrator (type 'cmd' in start menu and right click on it to select) then copy & paste the command below:
bcdedit /set {bootmgr} path \EFI\manjaro\grubx64.efi
You should see the GRUB menu after reboot.

Forum kindly sponsored by