Dual boot tutorial - a question

Ah yes, VERY good point.

I guess if a newly installed Kernel does not work properly it could get you in trouble not having the Bootloader installed. So at any rate it's a very good point. Not sure how I missed that concern myself. Thanks

So, can I install the grub bootloader and make it ONLY show up if there are multiple kernels to choose from? Thanks

Absolutely! Manjaro 18.0 is setup for a quiet grub as-is, but you can easily change that. You will need to search @philm's announcements, but the details are there.



Yes. Why? Because!! Linux systems need a boot loader. You may use syslinux, grub or refind, but.. you need one!

Showing Grub boot menu is a different thing. You may hide it if you don't like it. Read the Announcements intro about how to enable/use hidden grub.
You can also set it independently from grub options (/etc/default/grub).

1 Like

Thank you very much for tips and reminders. However I noticed that the OP doesn't mention where to put the bootloader (between steps 8 and 9) and in the drop down I had like 6 different choices. So I selected the bottom one that said "System Partition (/)" since it was defaulting to an Unknown 16.0 MiB partition and no mention in the guide if that was OK.

I have not yet moved forward, so is the system partition root ok for the bootloader? Thanks

Understanding the boot process would be a start ...


1 Like

If I understand correctly, NO!!!
If your system is MBR (it should since there is an option for the bootloader) you have to install grub on the DRIVE (i.e. /dev/sda), not a partition. Or I did not understand, I have not used Calamares for an installation for years...

That's why there is no Bootloader selection. What is yours?

Not right.

1 Like


Thanks, yeah I figured that was wrong but if the /boot/efi fat32 partition is created for grub, I am not sure why I would also select a bootloader location. The creation of that fat32 boot/efi partition has already done that for me. So do I let it install boot loader on the default option of /dev/nvme0n1? Thanks

Before potentially messing up your bare metal system I would recommend replicating your setup in Virtualbox VM and practice installing Manjaro there.

Read up on MBR, UEFI, bootloaders, grub, systemd, etc ... and actually understand what you are doing before diving in head first.

You can practice both Legacy BIOS and UEFI installs to understand the differences, experiment with different partition setups, even learn how to dual boot multiple Linux OSes on one system.

Key point is to take your time, learn at your own pace, and do it right the first time on your actual system.

1 Like

You don't need a /boot/efi partition if your are not using UEFI.
Are you???

If not, then your extra /boot/efi partition will create conceptual problems, since you seem to have only little knowledge about the matter.
You surely need some studying.. :slightly_smiling_face:


I have it installed already bud, so thanks. Not sure what I need to study to answer that one tiny question. Anyway, I bet my question was not formatted correctly. So let me try again, it's very late here and I am very tired.

I am new at UEFI installs, and my system is a UEFI based system, obviously. I have never seen this /boot/efi creation before, obviously, and I have been installing Linux distros longer than I can remember, well almost. I have used Linux on and off for roughly 20+ years, or ever since the mid to late 90's. But before now (now as in this last summer) I was always using a Intel x58 based system, which is legacy BIOS (so were all the machines before then) and I have installed linux hundreds of times on legacy bios systems. I didn't know that I would need to re-read tons of material just to install it on this new system, but maybe I should anyway, I guess.

Therefor, the ONLY part I was confused about was the missing d. step above. (as I am suggesting below)
8. Select the unpartitioned space → Create
a. Size → Use remaining
b. Filesystem → select ext4
c. Mountpoint → select / (root) → OK
d. Select the location for the bootloader, normally the MBR device, in this case "/dev/nvme0n1" for the bootloader.

d. was missing and since this is a UEFI install and I created this /boot/efi per the guide, which is new to me, and I thought that maybe this bootloader location was not needed, or needed to be changed from the default to something else, like the /boot/efi maybe, etc (again I assumed this was for the bootloader location already). If one is to just ignore that option in the manual installation, then at least a "d. Ignore the bootloader location and let it stay on the default option" would have been helpful, or simply "d. Ignore all other options on this page".

I already know how to use Manjaro (amongst many others), just not exactly how to install onto my NVMe device on a UEFI system (I was thinking the process was slightly different, which is why I am in this thread now). So please point me to any reading material you think I should look at, because all the links I was already pointed to I have already read years ago and many many times. I don't believe any of them would answer this question "does the bootloader location change when installing on a UEFI system and manually creating the /boot/efi partition". I somehow doubt that would be answered.

Oh and just ignore my first Grub Bootloader question above, I simply forgot about all the new kernels I might be installing in the future, which obviously Grub is needed for. That was a big DUH on my part, sorry.

Anyway thanks man, Manjaro is installed and running great so far, and without the question answered. Tested Windows 10 and it too is still running great. Happy to finally be back in this fine OS. Oh, and earlier this year I FINALLY got my uncle to leave Mint (he was a mint user for like 10 years now I think) and he is blown away by Manjaro... Today he told me he will never be going back to Ubuntu based distros, lol. Good for him...

Thanks @AgentS

Starting from this.. provoking statement, I will answer with a question.
How have you come up with that idea? Εμείς μπρίκια κολάμε;

Let me give you a picture:

  1. Buy a coffee machine
  2. Read the user manual
  3. Make coffee

Apparently you have caught a bug in the Tutorial! AFAIK, in an Auto installation with Calamares (I 've never used it on UEFI) this option should not exist and taken care .. automatically. In a manual installation you are supposed to take responsibility of the custom choices, which Linux, by principle, provides to the users, so you are supposed to know what to select. In Manjaro (Archlinux based), our Bible is Archwiki, with the finest published material in the web. You may find Installation guide and UEFI details, for in-depth knowledge.
Briefly, in UEFI there is no MBR. Only GPT (partitioning) and $esp partition (instead of MBR). You usually have one $esp, but you can have more. That's why in some cases, a user may want to use a different $esp than the (existing) one. Your confusion may have been due to some poor GUI of the installer (Calamares), or due to your age lack of in-depth updated knowledge. You may open an issue on this if you think so.
I am sure @linux-aarhus will be glad to fine-tune this tutorial with your contribution, which has been trivial!!

When the jet engines were first invented on airplanes, a propeller pilot would be fine flying them, but he would still be needed to go through some quick training course, I guess.. :rofl::joy::grin:

Safe landings pal!!

No mention of bootloader between 8 and 9 because the UEFI bootloader's partition is defined in step 6.

You are installing as BIOS/MBR system - and the guide is targeted at UEFI system.

There are several points for at BIOS/MBR system which is not mentioned. One of them you already know :slight_smile:

The second point is with Calamares when booted as BIOS/MBR will not display the mount option /boot/efi for the first partition, this option is only available on UEFI systems.

However, I think it is possible - though strongly discouraged - to create a bootable UEFI system using the old BIOS partition scheme. That is ultimately a bad cocktail.

Strictly speaking Grub is not mandatory. You could use systemd-boot. How to setup systemd-boot is described in this Arch Wiki article.

I am not at all sure it is possible to select between different kernels at boot time - but it will suffice for your described need - Windows and Manjaro.

Are you sure? He's already flying his plane!..

UEFI cannot be installed on MBR, or he just thinks he flies a jet, though instead he flies a propeller? :sunglasses:

Well, the mechanics are certainly different :roll_eyes::airplane::small_airplane::rofl:


It needs to be flagged as boot,esp rather than msdata which it will default to as part of the normal process when setting up partitions in GParted, etc.


If you followed the guide you would have created an $esp partition with the boot and esp flags.

But as you probably has used a BIOS partition scheme you would not have the option of flagging the partition as boot and esp which is required for the UEFI to be able to boot.

The mixing of UEFI and BIOS partition scheme are the recipe for disaster - maybe not right now but later when Windows has updated and made changes to the disk and your Manjaro installation disappears from boot.

This mixing is the very reason I have defined several options to be disabled in the firmware, among others is CSM and BIOS boot so this mixing could not occur. But nothing prevents the user from selecting MBR scheme when creating a new partition table.

1 Like


Yeah today I found time to mess around with the install only to quickly figure out that the installation, or installer was in fact in bios mode. I thought I had csm disabled but after the new 5.10 asrock bios I installed last week apparently I forgot to disable it again. Also I didn't use the win32writer app that Manjaro recommended, I had used rufus. I tried again today using Rufus and low and behold it actually didn't work.

So I downloaded the recommended win32writer and tried again. This time during the manual installation the option to select the bootloader location was GONE. That is what I was expecting yesterday to no avail and why I was forced to ask the question. Glad that I didn't spend any time setting it up how I like, lol.

So I was bitten by believing that I was in fact installing in UEFI mode when somehow I was not. Again, today marks the very first time I had ever tried installing a Linux distro on a brand new UEFI capable system. I simply had no experience and thus wasn't aware that the bootloader location option button should not be present using the gui installer. My bad...

But today she is installed and working well. I should have checked back here this morning but I had already figured it out on my own within minutes of getting on the computer. Thanks to sleep, coffee and bacon. Hahaha

Thanks for the input. What issues have you guys heard about on Ryzen systems? Anything serious to be aware of?


or @AgentS ? :wink:

1 Like

lmao... or yeah @petscam, or @vietnam, or @AgentS even.

I corrected the typo, thanks

Since this is a tutorial we shouldn't spoil with irrelevant discussion, besides corrections IMO. Do some search, there are a lot to discover to come inline with the present!! :grin:
For any troubles start a new topic and we 'll fly again! :wink:

1 Like

Forum kindly sponsored by