Dual Boot Windows & Manjaro, after fresh install of Windows, getting "Operating System Not Found"

Yes, it boots into Linux Mint Live OS

Then good.
At LM. go update everything first
apt update && apt upgrade
grub install /dev/sda

All as root.
Then check if manjaro entry is included.
ps: it won't boot manjaro, but it's okay for now.

Tell us first the situation, will follow up on next action to boot manjaro from there.

It may be awhile. I haven't slept yet.

1 Like

Yes, the Linux Mint LiveUSB boots into Linux Mint Live OS, so do you mean I should mount the Mint partition? /dev/sdb8: LABEL="MINT"

$ sudo mount /dev/sdb8 /mnt

then run as root...

apt update && apt upgrade

grub install /dev/sda


Not sure if this is what you mean

No, ..
At LM live CD, what did you mount as /mnt? If you mount LM partition, can you reboot to installed LM OS?

If you mount manjaro as /mnt, can it reboot into manjaro installed OS?

Tell us what you mounted, and tell us if it can reboot into the said OS. Don't just say fail.

Oh.. You did not mount anything when you did the grub-install command.

Go ahead, mount manjaro partition to /mnt using LM live CD OS. Then do the commands, then reboot.

Please, if error, write down the error message. Its important.

1 Like

No, I did not run the grub-install command.

I have just mounted Manjaro partition to /mnt using LM liveUSB. then ran command....
"$ sudo grub-install --boot-directory=/mnt/boot /dev/sdb"

mint@mint ~ $ sudo grub-install --boot-directory=/mnt/boot /dev/sdb
grub-probe: error: failed to get canonical path of `aufs'.
Installing for i386-pc platform.
Installation finished. No error reported.
mint@mint ~ $ 

but it shows the same 'grub-probe: error'

after I mount manjaro as /mnt, I tried reboot, but still getting “Operating System Not Found”

Right, It is now fairly clear.
The most telling is

You can boot livecd from usb and 'ls' gives only usb output.
You do not have disks output from 'ls' and together with various output of “Operating System Not Found” when reboot, it cannot detect the disks at bios and at boot time. {note that you can detect the disks after the livecd OS is booted up - just to be sure we understand this}.


So, sorry to say, hughparker1, it's something you have to do first.
But let us know whatever you do, ya. Keep us in the loop.
Take care now and cheers.

ps: of course, if there's anything you want to ask, go ahead.
We'll try, as always.

Thanks @gohlip for your continued help and support. I will check out motherboard over the weekend to see where the fault lies.

I will keep you in the loop on the results of investigation. Take care :+1:

1 Like

There might also be a BIOS setting for disk drives (ie. AHCI)
Others might know more..

Hi @gohlip & @AgentS I just wanted to provide an update on my boot problem.

There is Good News and Bad News.

The Good News is I am updating this topic on my Sony Vaio laptop after it booted successfully :slight_smile:

The Bad News is I am a very stupid noob.

I decided before I took my laptop apart, I would review all your feedback to see if there was anything I didn't check, and noticed you both had mentioned BIOS earlier...

plus your last post @AgentS ....

So I pressed f2 during boot and found the following settings...

Boot Priority:
Select 1st Boot Priority: [External Device]
Select 2nd Boot Priority: [Internal Optical Disk Drive]
Select 3rd Boot Priority: [Network]

I noticed there was only three Boot Priorities available to the user, but there are four possible choices to chose from, the fouth choice was [Internal Hard Disk Drive]

So I used keys +/- to change options...

Select 1st Boot Priority: [External Device]
Select 2nd Boot Priority: [Internal Hard Disk Drive]
Select 3rd Boot Priority: [Internal Optical Disk Drive]

Don't understand why there is only three Boot Priorities available to the user, but four possible choices to chose from, so there will always be one missing.

I can't figure out how this could have changed (maybe it was me, I honestly can't remember) but I am now back in business, just sorry I didn't do this earlier on. It was very careless of me.

I want to thank you both for your help and guidance, and appologise for being so stupid :frowning: :sleepy:


Ho! Ho! Ho!

Glad you found that out.
And more glad that you admitted your error and come back to us.
This is important as if you did not get back to us, others (including I) may not know about this likelihood of the 'missing' priority.

So cheers and take care.
See you around.

and for this, your punishment is to mark your topic as solved without any help. Just search the forum for "how to mark topic as solved".
Have fun! :grin:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by