Dual boot with Windows 10 + Manjaro doesn't show up a grub menu

I installed Windows 10 Pro on my SSD. Then I created necessary partitions for / and /home before proceeding with Manjaro installation. I successfully installed Manjaro (UEFI, GPT), but when I booted several times, no grub menu has been shown. My new PC boots straight into Windows 10.

I spent a lot of time trying to Google for correct answer but nothing worked out so far. I disabled Fast Startup in Windows, I even re-installed Manjaro, I used /boot/efi mount with appropriate labels (esp, boot) for my existing FAT32 partition. No luck. I have a working Live USB flash disk of Manjaro, but need some help in order how to proceed now... Thanks!

Use this tutorial and if nothing works, post info as it is advised


I successfully booted to Manjaro on my SSD, here's the output of the commands I've used:


sda = SATA disk used just for data
sdb = USB Flash disk
sdc = USB Flash disk
nvme0n1 = SSD disk with Windows and Manjaro partition

I asked you post info as advised in tutorial. Have done it?

efibootmgr -v 
sudo parted -l 
sudo blkid 
findmnt -s 
findmnt /boot/efi 
cat /etc/fstab

Sorry for delay... here's the output: https://pastebin.com/GuecXtLT

Your partition table doesn't have any Linux partitions. I suggest you try this. You should make the partitions with the live usb and only use windows for shrink it's own main partition. I recommend you do the following.

  1. shrink the main windows using the disk management tool in windows.
  2. assuming secure boot has been disabled boot into the live usb
  3. create the partitions from the free space you made with the windows disk management tool.

For example my output from sudo parted -l is

Disk Flags:

Number Start End Size File system Name Flags
3 1049kB 16.8GB 16.8GB linux-swap(v1)
1 16.8GB 17.1GB 315MB fat32 boot, esp
2 17.1GB 75.1GB 58.0GB ext4
4 75.1GB 256GB 181GB ext4

In your case the second ext4 would be for the home directory so you'd check off the mount point as /home in the installer.

1 Like


How? Using the link petsam provided and from the livecd menu? (Tell us)
If that is correct (you using the link), you are not booting up the livecd menu in uefi mode.

[joe@sc ~]$ efibootmgr -v
EFI variables are not supported on this system.

This time, make sure you boot the lviecd in uefi mode and when booted to the installed Manjaro OS, at the terminal do this.

sudo grub-install
sudo update-grub
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo efibootmgr -c -d /dev/nvme0n1 -p 2 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"

You need to read the link thoroughly.


I do have Linux partitions (4 and 5): https://pastebin.com/FEztfKXF

#4 is /
#5 is /home

I don't use a partition for swap, since I use SSD. I will use a swap file.

My primary disk is /dev/nvme0n1, not /dev/sda.

I booted to Manjaro using the link petsam provided (by pressing "c" for entering a grub shell). How can I boot livecd in uefi mode?

Set the bios F2 setup to boot only uefi.
see link again.

1 Like

My LiveUSB is not in UEFI mode, so regardless the BIOS setting I could not boot UEFI Manjaro. I used etcher in order to make the Manjaro LiveUSB in UEFI mode, but unsuccessfully. After creating Manjaro LiveUSB with etcher, selecting UEFI mode only in BIOS (previously it was Legacy + UEFI), I can't see my UEFI USB made with etcher. :roll_eyes:

The same Livecd can be booted in both/either uefi or/and bios-legacy.
If it can be booted in bios-legacy, it can be booted in uefi.
Nothing to do with how it's made.

Recheck your computer/motherboard website on how to boot in uefi.

I use MSI's Click Bios 5, which means I can not use UEFI for LiveUSB. :unamused:

I wonder if I could achieve this by this tool called UEFIShell:

I really don't know about this tool though it appears to be a efistub which boots kernels and initrd files directly. I cannot therefore help much on it and whether it will work on a liveusb is another matter.

As to your MSI Click Bios 5, the simplest way I can think of out of this is to boot your manjaro in bios-legacy. But that would mean needing an unallocated bios_grub partition in the first partition. and booting windows and manjaro separately through the boot set up key - if your MSI allows it. Again, how that affects your windows is another different matter as to whether your bios will think your disk is msdos and will not boot windows in uefi.

The final analysis is that it is highly uncertain it could succeed.
Perhaps you might end up with booting windows and manjaro both in bios-legacy and having your disk in msdos.

Let us know what you ended up with and how you achieve it.
And good luck. Cheers.

ps: a request to you to change your avatar while cognizant of the fact that you might not be aware of the sensitivities it may have in the eastern part of the world. (it's like a swastika to those in the european part of the world or like a confederate flag to the black part of america). Thanks.

1 Like

I have MSI click Bios 4 and I have it with Legacy + UEFI and can see my UEFI USB without problems. Your bios is a bit more modern but it should be available in anyway. Can you leave a screenshot of your entries when you push F11 and jump into boot options?.

1 Like

Have you tried this? (Maybe the proper entry "UEFI-USB drive name" was hidden in the list, so you have to scroll to find it)


There's a "UEFI USB Key" entry, but if I put it on the very first position in my boot sequence and leave my LiveUSB in USB port, my Windows 10 boots right after (LiveUSB will be skipped). You can check an example on the following screenshot (Boot Option #5):

Don't use the BIOS menu method.
Use the Quick Boot menu method (possibly press F12 during boot).

Each BIOS firmware has own way to customize first boot device. Most of them (if not all) have a key for Quick Select Boot Device (or similar wording..)

1 Like

There is no such thing in this BIOS, I'm afraid. There is something they call MSI Fast Boot, but this is an option within the BIOS and it removes a few sec of booting time.

I just contacted MSI Support in order to find out how the heck could I use UEFI in order to boot from USB. Waiting for their response...

It seems to be the only thing that holds me to succeed. Click Bios 5 seems to be the culprit. Everything else seems feasible:

1 Like

Forum kindly sponsored by