Dual booting with Windows 10 build 1903 in Dell

Hi to all
I was using manjaro xfce on my previous machine, as a clean install.. Now that I have upgraded myself to a new laptop, I am finding it difficult to do a dual boot of manjaro gnome 18 with Windows 10. I used a live bootable usb
Tried whatever tricks were available online, from disabling secure boot to decrypting the default settings, but nothing worked.
The problems I faced were as follows:

  1. Disabling secure boot made me confront bitsecurity on windows. Which I did manage to bypass
  2. once live booted, on trying to install, the installer doesn't recognise the hard drive at all!! It only detects the usb it is on as a separate partition!! In fact, on opening boot options from bios, it also shows the usb as 2 separate entries - one as the usb, and second with the same name and partition 2 written next to it
    I am attaching a screenshot of the live installer
    Request for help please!!
    My configs are as follows:
    Dell Latitude 5400 with i5 8th gen, 8 gb ram, 2 gb radeongraphics, 256 gb ssd, win 10 build 1903
    11

Try changing your disk from RAID mode to AHCI in BIOS. Boot up again from your Manjaro live usb and run the installer. Hopefully it will detect your disk.

1 Like
1 Like

please change version iso to 18.1

I tried this @Swagglepuf... But didn't work.. it still didn't detect the SSD.. thanks for the link though...

Thanks.. will try it tonight again

What does "bitsecurity" do? Encrypt or otherwise hide the disk from other operating systems?

If you have security software designed to hide the disk from people doing exactly what you're doing (using a live environment to bypass the OS security and gain direct access to the disk) then you're not going to have any success with any other OS under any circumstances.

Bitlocker could be unlocked - there is tools for that - but it does not solve your immediate problem - you need to turn off bitlocker - (if at all possible without formatting) - security measures are in place for a reason - and if you are not the owner - trying to get access to the data on the windows partition - you are into serious legal issues.

1 Like

@jonathon, bitlocker encrypts the disk...
However, @linux-aarhus, decrypting it does turn it off. I am the legit owner :stuck_out_tongue:
Did that too, but still it doesn't detect the ssd
Though have yet to try suggestion of changing from RAID to AHCI, just hope it doesn't crash the ssd. Any experience on this, guys??
Give me a couple of days, and i'll update.

Of course you are - just saying :slight_smile:

This may crash your Windows installation.

The fake raid implemented on bios level often cause you disk devices to be unrecognizable by Linux.

This article from Arch Wiki may be helpful

https://wiki.archlinux.org/index.php/Installing_with_Fake_RAID

Hi all, couple of days turned into a week... My system had crashed bcoz the bios was not detecting the ac adaptor, hence was off any charge on the laptop :laughing:
Anyways, got the MB changed, and all going fine.. This time, now, I did try changing from RAID to AHCI... ANd guess what - didn't work... didn't boot up to windows at all!!!
Perhaps, first booting up from live installer, installing the manjaro, and then changing back to RAID might do the trick??? Just throwing out ideas...
@linux-aarhus, you were right about AHCI crashing my windows installation..
Any suggestions, guys??

Again @linux-aarhus,
I checked the wiki article, and it's all greek n latin to me.. couldn't understand what it meant to say...:slightly_frowning_face: , sorry....
I'm only aware of the basics, since I'm not a computer developer / coder, and whatever basic CLI I know is on the job training while using Linux over so many years.. Through guides and wikis....
So, if there could be a simplified way of taking things and doing it... a big thanks to you..

Which also gives me another thought...While live booting from USB, it asks for drivers, and I leave it at default, ie, free drivers..
Would changing it to non-free help??
Crazy thought,but was going through community editions support, and most of them say non-free drivers

AHCI crashing my windows installation..

I have two radical suggestions, you should probably exhaust all your other options before listening to me, but here it is:

  1. Would you be willing to format your entire drive and reinstall Windows 10, leaving enough unpartitioned space for a Manjaro dual boot? Reinstalling Windows 10 with the correct settings in BIOS (AHCI enabled, legacy boot and compatibility mode disabled, and UEFI enabled, assuming your hardware supports it) would probably make it easy to install Manjaro.

  2. If you don't mind physically opening and tinkering with you laptop's hardware (and assuming there are no warranty issues), you could buy another HDD (or SSD) and physically replace the drive in your laptop with the new one, and just install Manjaro on that one. Not much of a dual boot, but once you start using Linux on a regular basis for a couple of months, you'll probably find that you don't really need Windows anymore. But if for some reason you really need to boot up the old Windows system, you can always replace the drive again, and it will be as if nothing had happened (obviously, this is not something you would do on a regular basis). That's what I did for my laptop some 10 or so years ago. I still have its original Windows 7 HDD at the bottom of some drawer, haven't used it once since... I should probably reformat that and use it as a backup USB drive. :grin:

@kresimir,
That is radical!! First option, I would have happily done.. however, there are now a couple of apps, which although have an open source alternative, but, they work better with the windows install...
2nd option, it's a new laptop, so warranty is an issue...
However, the other option I am now looking at is running Linux as a virtual machine...

Hi all,
I did try using a virtual machine, but then it runs too slow.. and for me to use photo editing software on it.... well, just doesn't gel in as much as I would like it to.
I guess I'll have to stick to windows for now, and decide about purchasing adobe photoshop...
Or the last option would be to wipe the slate clean and put in a fresh install of manjaro
Or perhaps save some money and keep a new machine for Linux..... :stuck_out_tongue:
Anyways, it's gonna be a few months before I actually sit down to restart my photography and use Linux.. Till then I'll use windows... Then, will see...

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by