Dual Graphics ***AMD***& Nvidia best setup?

So basically: video-hybrid-intel-nvidia-440xx-prime + video-modesetting = Works also on AMD CPU (NOT GPU!)

This humble padawan ask his Jedi master to confirm his assumption is correct...

:innocent: :grin:

just this one, uninstall any others first

1 Like

modesetting works on amd apu's, not sure how well it works on amd dgpu's though. both modesetting and amdgpu can work with render offload depending on how you set it up.

1 Like

So do I get it right that modestting driver works for Intel and AMD CPUs?

That would make sense then since as I suspect, modesetting is used for hybrid setup and currently no other CPU driver can be used for it.

you can use the intel driver with render-offload if you wanted to, same with amdgpu but i doubt either of them would work better than modesetting :man_shrugging:

1 Like

Can I not use something like this so that I have the option to switch?

Reason I ask is it says " If you already use video-hybrid-intel-nvidia-440xx-prime configuration, this guide is also for you." and as the 440xx driver is one of the available for this card of mine I was thinking this was what I was looking for..?
Thank you to any who have and all who can assist. Communities always great over here :slight_smile:

Well, that didn't work.. Ok so if it's easier to scrapthe idea of using the igpu, and only the nvidia card for everything, which I think I canwork around, how do I go about it?

Optimus-manager is for INTEL-NVIDIA combo. For AMD-NVIDIA just use the default video-hybrid-intel-nvidia-440xx-prime (uninstall and undo any changes done by optimus-manager) and then start programs with:

prime-run

so like

prime-run steam

That is all. There is no switching between modes in AMD-NVIDIA, all works only as a Hybrid mode.

it can be used in modes but with amd/nvidia combo it doesnt make much sense since prime synchronization doesnt work with it. i put together a modified optimus-switch for amd/nvidia for use with lightdm and both amd only and nvidia prime modes work but no prime sync which is why i didnt bother pursuing it further. so render offload prime seems to be the only suitable solution for it :man_shrugging:

1 Like

What do you mean by "prime sync"?

when using PRIME (not render offload prime), prime synchronization is what syncs the nvidia gpu to the intel gpu, without it you get severe tearing. the good thing about prime sync for gaming is that you dont need in-game vsync at all and doesnt give you the input lag associated with it. it's what the nvidia_drm.modeset=1 does.

i was able to get the amd/nvidia combo working with modesetting/nvidia and with amdgpu/nvidia but no prime sync :frowning_face:

from mine, using prime intel/nvidia

~ >>> xrandr --prop                                                                                     
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 16384 x 16384
eDP-1-1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 500mm x 281mm
	EDID: 
		00ffffffffffff0031d8000000000000
		051601036d321c78ea5ec0a4594a9825
		205054000000d1c00101010101010101
		010101010101023a801871382d40582c
		4500f4191100001e000000ff004c696e
		75782023300a20202020000000fd003b
		3d42440f000a202020202020000000fc
		004c696e7578204648440a2020200005
	PRIME Synchronization: 1 

with amd/nvidia it's always a 0 (not working)

1 Like

so when I mhwd -l I don't see that "prime" driver listed as an option

How so? There should be two prime options:

video-hybrid-intel-nvidia-440xx-prime
video-hybrid-intel-nvidia-435xx-prime

I think I've discovered that I'm just a lil special.. installed the nvidia-440xx "default/nonprime"... installed nvidia-prime from community.. restored default xconfigs for amd chip. use prime-run for everything i want to run on my nvidia card... seems to be working?!?

1 Like

Screenshot_20200308_124346

No prime options here that I see..

Post output of inxi -Fxzc0

OK, looks good, you have two GPUs so you should have hybrid options. Looks like MHWD is not working correct for your hardware setup. In theory, you can omit MHWD and set it all by yourself manually, but that's a risky process and it's easy to break things. Hmm...

@dglt, do you have any suggestions? How to force mhwd to show hybrid configurations to install?

i'm thinking maybe the hardware id's are not included in the mhwd db so it's not detected as a dual gpu? @philm might need to add them?

@Tandrias either way, you should still be able to manually install the package via mhwd even if not automatically detected.

sudo mhwd -i pci video-hybrid-intel-nvidia-440xx-prime

also, are you sure you ran a full update before doing any of this?

1 Like

just to be certain, I redownloaded, reflashed and reinstalled 19.0.2 kde performed an update and executed

sudo mhwd -i pci video-hybrid-intel-nvidia-440xx-prime

it installed no prob, I rebooted and still had gui so something must have worked. I still notice no change on the mhwd screen.


however prime-run still works fine even without manual install of nvidia-prime from community.

Forum kindly sponsored by