Dual Graphics ***AMD***& Nvidia best setup?

Screenshot_20200308_124346

No prime options here that I see..

Post output of inxi -Fxzc0

OK, looks good, you have two GPUs so you should have hybrid options. Looks like MHWD is not working correct for your hardware setup. In theory, you can omit MHWD and set it all by yourself manually, but that's a risky process and it's easy to break things. Hmm...

@dglt, do you have any suggestions? How to force mhwd to show hybrid configurations to install?

i'm thinking maybe the hardware id's are not included in the mhwd db so it's not detected as a dual gpu? @philm might need to add them?

@Tandrias either way, you should still be able to manually install the package via mhwd even if not automatically detected.

sudo mhwd -i pci video-hybrid-intel-nvidia-440xx-prime

also, are you sure you ran a full update before doing any of this?

1 Like

just to be certain, I redownloaded, reflashed and reinstalled 19.0.2 kde performed an update and executed

sudo mhwd -i pci video-hybrid-intel-nvidia-440xx-prime

it installed no prob, I rebooted and still had gui so something must have worked. I still notice no change on the mhwd screen.


however prime-run still works fine even without manual install of nvidia-prime from community.

Upon multiple attempts I've noticed the hybrid-prime driver is not in use. When I use mhwd to install it as above, the install takes place but i'm given a message that no hardware is found for that driver...
no solution yet :frowning:
And sorry for the error above not certain if my adjustment to my launchers weren't saving but prime-run is not working for me..

I swear I've read every post I can find about configuring this card and nothing works.. ironically enough i don't have access to use my nvidia card and yet it kills my battery life.. Don't even get the perk of using the igpu.. Anyone have any thoughts? shy of go to pop os? shoot me now..

i ended up creating an SDDM version of optimus-switch yesterday for another user for use with amd/nvidia laptops.

so right now there's a lightdm version and an sddm version, but you use GDM so give me a few and i'll put together a git repo that should work with your setup and simple line by line commands to set it up.

while im doing that, please post these full outputs here in the forum.

mhwd -li
ls -laR /etc/X11 ; cat /etc/X11/xorg.conf.d/*.conf
ls -la /etc/modprobe.d ; cat /etc/modprobe.d/*.conf
ls -la /etc/modules-load.d ; cat /etc/modules-load.d/*.conf
pacman -Qs | grep -Ei 'nvidia|xf86-video|vesa|optimus|bbsw|prime'
grep -v /usr/share/X11/xorg.conf.d/*.conf

ok, i created a separate repo for optimus-switch that should work with SDDM. to set it up follow these instructions carefully

  • get a list of currently installed drivers with mhwd -li then uninstall them. this command assumes you have video-linux and video-hybrid-intel-nvidia-440xx-prime installed so edit as needed
sudo mhwd -r pci video-linux
sudo mhwd -r pci video-hybrid-intel-nvidia-440xx-prime
  • also make sure your do not have prime, prime-run, or optimus-manager installed

  • this setup assumes your still using the 5.4 kernel as shown in your inxi output from earlier. if you have other kernels installed (check with mhwd-kernel -li) then make sure to add it to the pacman command below so each installed kernel has the matching kernel headers installed. if you have 5.4 and 5.6 installed you would make sure linux56-headers and linux54-headersare installed.

  • get rid of any custom video related .conf files from these directories. if you didnt create any you can skip this part but i would still double check just in case.

/etc/X11/xorg.conf.d/
/etc/modprobe.d/
/etc/modules-load.d/
  • install drivers needed for this setup
sudo mhwd -i pci video-linux
sudo mhwd -i pci video-nvidia-440xx
  • install optimu-switch. run these exact commands one at a time, if any command fails then stop and post it here
cd ~
sudo pacman -S linux54-headers dkms acpi_call-dkms git xorg-xrandr
git clone https://github.com/dglt1/optimus-switch-amd-gdm.git
cd ~/optimus-switch-amd-gdm
chmod +x install.sh
sudo ./install.sh

if all that goes well, after a reboot you should be using PRIME mode and you should have all your external video ports working and the nvidia gpu is the primary. let me know how it goes.

First, Thank you so much. I apologize but given the state of the world things have been a little busy lately..
Here are the outputs you mentioned.

I've executed the commands and all appears well. going to reboot now but incase I come back to no display I just wanted to thank you so much for your time @dglt
Really means a lot! I'll post back update.

Welp. Seems to work fine when set to amd but when set-nvidia.sh and reboot, no display other than tty

My guess is that since there is no Intel, mhwd is not recognizing your hardware as fit for video-hybrid-intel-nvidia-440xx-prime.

Frankly, I have no idea how this setup would work but currently you are set to use AMD CPU and Nvidia GPU, or at least it looks like it at a quick glance. It will be a good setup for gaming.
If I understand correctly, you want to use AMD for CPI and GPU and Nvidia only on demand to have lesser battery usage on daily basis?

I'm not sure if MHWD script is equipped to handle properly such unusual hardware setup.

Yeah so far it seems like I'm unable to utilize my nvidia card at all atm. but it's powered on...

So AMD is used at the moment for CPU and GPU? Are you sure it's not Nvidia used for GPU for everything?

I don't know what are the ways to check it (I'm sure there are many) but personally I just like to open Steam and System Information to see which GPU and driver is really used at the moment.

This is how it looks like for me right now on Intel mode (where I can start Steam with Intel or with Nvidia and Nouveau drivers; for non-free drivers I have to switch to hybrid or Nvidia mode):

Screenshot-2020-04-02-19-37-36

I like my setup, because I can switch to any GPU on any driver (free or not free) at any time, all from GUI (so I don't have to mess manually with configs). Unfortunately, your situation is different, and we simply lack of experience with such unusual hardware mix.

I was able to get the hybrid intel nvidia 440xx prime setup working on my RTX 2060. and ryzen 7 on my Asus TUF 505D. Only that driver should be installed. I also had to load the OS using UEFI. for some reason, if i tried to load the OS through BIOS, without selecting UEFI, the screen would look like a bunch of rainbow static.

Ive recently installed the AMD version, which has same config as intel one. No issues so far.

1 Like

@DaBricksz Many thanks! I've installed and am testing now.. so far so good..

glxinfo | grep "OpenGL renderer" && prime-run glxinfo | grep "OpenGL renderer" OpenGL renderer string: AMD RAVEN (DRM 3.35.0, 5.4.28-1-MANJARO, LLVM 9.0.1) OpenGL renderer string: GeForce GTX 1660 Ti/PCIe/SSE2

...

1 Like

Still sub 1 hour of battery life and switching with this setup seems to be inconsistent...

because the gpu cant fully power itself down using render offload prime. for the power management to work on turing gpu's you need to have the option enabled, it's disabled by default.

run this, then reboot.

echo "options nvidia "NVreg_DynamicPowerManagement=0x02"" | sudo tee -a /etc/modprobe.d/nvpower.conf

that allows your nvidia gpu to go into it's lowest power state when it's not being used. see if power usage is better that way and dont use nvidia-smi to monitor power usage as it uses a process on the nvidia gpu causing it to come out of it's lowest power state

1 Like

switching with this setup seems to be inconsistent...

If I'm not mistaken the AMD - Intel - Hybrid setup runs the AMD GPU by default. if you want to run the Nvidia card, you use the command prime-run. For example prime-run steam or prime-run virtualbox.

Forum kindly sponsored by