Dual Monitor setup in Manjaro KDE

Hi there. Just migrating to Manjaro KDE from Mint Cinnamon as I wanted to take KDE for a spin again after leaving Kubuntu some time ago

My immediate issues are around getting Dolphin to see my Synology NAS, which I will post seperately and getting Manjaro to recognise my Dell monitor which I used to be able to extend to above my laptop via the docking station

I have tried Googling and watched some videos as well re using "xrandr" and related commands but still struggling to get it to work

Here is my xrandr output:
[raaj@raaj-CHiP ~]$ xrandr -q
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 193mm
1920x1080 120.11*+ 60.01 60.06 59.97 59.96 59.93
1680x1050 59.95 59.88
1400x1050 74.76 59.98
1600x900 59.99 59.94 59.95 59.82
1280x1024 85.02 75.02 60.02
1400x900 59.96 59.88
1280x960 85.00 60.00
1440x810 60.00 59.97
1368x768 59.88 59.85
1280x800 59.99 59.97 59.81 59.91
1152x864 75.00
1280x720 60.00 59.99 59.86 59.74
1024x768 85.00 75.05 60.04 85.00 75.03 70.07 60.00
1024x768i 86.96
960x720 85.00 75.00 60.00
928x696 75.00 60.05
896x672 75.05 60.01
1024x576 59.95 59.96 59.90 59.82
960x600 59.93 60.00
832x624 74.55
960x540 59.96 59.99 59.63 59.82
800x600 85.00 75.00 70.00 65.00 60.00 85.14 72.19 75.00 60.32 56.25
840x525 60.01 59.88
864x486 59.92 59.57
700x525 74.76 59.98
800x450 59.95 59.82
640x512 85.02 75.02 60.02
700x450 59.96 59.88
640x480 85.09 60.00 85.01 72.81 75.00 59.94
720x405 59.51 58.99
720x400 85.04
684x384 59.88 59.85
640x400 59.88 59.98 85.08
576x432 75.00
640x360 59.86 59.83 59.84 59.32
640x350 85.08
512x384 85.00 75.03 70.07 60.00
512x384i 87.06
512x288 60.00 59.92
416x312 74.66
480x270 59.63 59.82
400x300 85.27 72.19 75.12 60.32 56.34
432x243 59.92 59.57
320x240 85.18 72.81 75.00 60.05
360x202 59.51 59.13
360x200 85.04
320x200 85.27
320x180 59.84 59.32
320x175 85.27
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 disconnected (normal left inverted right x axis y axis)

I then tried:
xrandr --output eDP-1 --auto --output HDMI-1 --auto --above eDP-1

Whilst there were no errors I got no second display either!

Why does it say my HDMI port is not enabled? Cables are fine as it works in Windoze..

Grateful for your advice


What says?

grep "connected\|disconnected" /var/log/Xorg.0.log

Maybe this could lead to a solution? Monitor doesn't detect DisplayPort connection, if it's turned on after the computer

Thanks for the quick reply. Output below:
[raaj@raaj-CHiP ~]$ grep "connected|disconnected" /var/log/Xorg.0.log
[ 7.240] (II) modeset(0): Output eDP-1 connected
[ 7.240] (II) modeset(0): Output DP-1 disconnected
[ 7.240] (II) modeset(0): Output HDMI-1 disconnected
[ 9.349] (--) NVIDIA(GPU-0): DFP-0: disconnected
[ 9.349] (--) NVIDIA(GPU-0): DFP-1: disconnected
[ 9.350] (--) NVIDIA(GPU-0): DFP-2: disconnected

Whilst tinkering about I notice I have done something else. Laptop still boots fine but I now notice a red error message at shutdown and start-up: "Failed to start DisplayLInk Manager Service"

I seem to have rectified the displaylink error...

Post output of:

inxi -Fxxx0

I suspect you may have hybrid GPU laptop and the issue is elsewhere, namely in drivers, which won't support multi-monitor setups (appears as if nothing was detected). This is because Manjaro recently switched to 440xx Nvidia driver line which allows for hybrid setup and that is what Manjaro installs by default. Unfortunately hybrid setup won't work with external monitors and you have to use other setups: optimus-manager, optimus-switch, nvidia prime, etc.

Of course, this is my guess, so I may be wrong, but lately this is the trend. Almost all users with similar problems have it because the new hybrid mode in Nvidia drivers. That is the cost of being on cutting-edge... Luckily, 450xx drivers are on the way and the issue will be gone, because external monitors will start to work on hybrid mode.

Is the dockingstation a "USB(-C) to Displayport" type?

Thanks. Output below:

[raaj@raaj-CHiP ~]$ inxi -Fxxx0
System: Host: raaj-CHiP Kernel: 5.6.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 Desktop: KDE Plasma 5.19.3
tk: Qt 5.15.0 info: cairo-dock wm: kwin_x11 dm: SDDM Distro: Manjaro Linux
Machine: Type: Laptop System: HP product: OMEN by HP Laptop 15-ce0xx v: N/A serial: Chassis: type: 10
Mobo: HP model: 838F v: 40.21 serial: UEFI: American Megatrends v: F.08 date: 09/29/2017
Battery: ID-1: BAT0 charge: 51.3 Wh condition: 57.2/57.2 Wh (100%) volts: 16.8/15.4 model: HP Primary type: Li-ion serial:
status: Unknown
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master serial: 4069-76-b8-e6-79
charge: 100% (should be ignored) rechargeable: yes status: Discharging
CPU: Topology: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP arch: Kaby Lake rev: 9 L2 cache: 6144 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44817
Speed: 3417 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 3406 2: 3433 3: 3529 4: 3416 5: 3513 6: 3603 7: 3493
8: 3594
Graphics: Device-1: Intel HD Graphics 630 vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:591b
Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] vendor: Hewlett-Packard driver: nvidia v: 440.100
bus ID: 01:00.0 chip ID: 10de:1c8c
Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia unloaded: intel,nouveau alternate: fbdev,nv,vesa
compositor: kwin_x11 resolution: 1920x1080~120Hz
OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 20.1.3 direct render: Yes
Audio: Device-1: Intel CM238 HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1f.3
chip ID: 8086:a171
Sound Server: ALSA v: k5.6.19-2-MANJARO
Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard driver: r8169 v: kernel
port: c000 bus ID: 03:00.0 chip ID: 10ec:8168
IF: enp3s0 state: down mac: ac:e2:d3:54:c5:55
Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel port: c000 bus ID: 04:00.0 chip ID: 8086:095a
IF: wlp4s0 state: up mac: 9c:da:3e:d1:22:fc
Drives: Local Storage: total: 1.14 TiB used: 15.42 GiB (1.3%)
ID-1: /dev/nvme0n1 vendor: Toshiba model: N/A size: 238.47 GiB speed: 31.6 Gb/s lanes: 4 serial: 97IS10KPTP4T
rev: AAHA4102 scheme: GPT
ID-2: /dev/sda vendor: HGST (Hitachi) model: HTS721010A9E630 size: 931.51 GiB speed: 6.0 Gb/s rotation: 7200 rpm
serial: JR1000BN1P8A6E rev: A3T0 scheme: GPT
Partition: ID-1: / size: 66.79 GiB used: 15.34 GiB (23.0%) fs: ext4 dev: /dev/nvme0n1p5
Sensors: System Temperatures: cpu: 60.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info: Processes: 267 Uptime: 1m Memory: 15.53 GiB used: 1.23 GiB (8.0%) Init: systemd v: 245 Compilers: gcc: 10.1.0
Shell: bash v: 5.0.18 running in: konsole inxi: 3.0.37

HI it's a Toshiba Dynadock 3.0 but I am connected via HDMI. My Laptop is a HP Omen Gaming laptop

It's no native Displayport/HDMI connection.
The dock uses only USB Connection withOUT Displayport Alt-mode.
The graphics is done over USB and converted to HDMI with a DisplayLink chip.

Have you already tried to search for DisplayLink in this forum?

I was right, you have hybrid GPU laptop. This means that Manjaro installed video-hybrid-intel-nvidia-440xx-prime setup. You can check it with this command:

mhwd -li

As said earlier, you won't be able to detect ANY secondary monitor, dock or no dock.

If you need to have secondary monitors, you have few options:

  • wait for 450xx drivers to be available, then use MHWD to make the switch to newer driver series (never do it manually, it breaks Manjaro),
  • set Nvidia Prime or Nvidia only setup (this will use more energy on battery and will heat laptop more)
  • use either optimus-manager or optimus-switch to be able to switch between Intel, Hybrid and Nvidia mode. Your secondary monitors should work with Intel modesetting and Nvidia mode. Hybrid mode is what you have right now.

Thanks again for quick reply. Cleanest option appears to be new drivers...do you have any idea when they could be available?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by