DualBoot Win10 & Manjaro - Launching Grub & adding Windows to the List

1 Like

if you check with

sudo parted -l

there is only one partition /boot/efi with esp & boot flag

yes you are right @stephane

Number  Start   End     Size    File system     Name                          Flags
 1      1049kB  556MB   555MB   ntfs            Basic data partition          hidden, diag
 2      556MB   661MB   105MB   fat32           EFI system partition          boot, esp
 3      661MB   677MB   16,8MB                  Microsoft reserved partition  msftres
 4      677MB   77,6GB  76,9GB  ntfs            Basic data partition          msftdata
 5      77,6GB  78,1GB  537MB   fat32                                         msftdata
 6      78,1GB  86,7GB  8590MB  linux-swap(v1)
 7      86,7GB  256GB   169GB

But in my case, still sdb2 the Windows EFI Partition is flagged. But it doesn't recognize the "moved" EFI/1Microsoft/Boot/bootmgfw.efi but just moves on to the not as esp flagged sdb5 which i created whilst installing Manjaro.
And directly boots into Manjaro instead of just showing me at least the grub screen, i think that could maybe be to separate problems.
e.g. Not beeing shown the grub screen AND an other I'm not quite sure off till now.

i tried the UEFI-Safe Boot trick, adding the bootmgfw.efi (from Mircrosoft) and the grubx64.efi (from Manjaro) but i still end up without booting into Grub nor having a choice in the Boot-Order Menu of the Bios.

@SGS I still have to read the entire manual at least once or twice more before I'll try my luck with it.

1 Like

you have to
suppress this fat partition sdb5 , then
restore Grub ,

launch USB manjaro install
open a terminal

efibootmgr ( check EFI is ok )
manjaro-chroot -a ( select 1 if one line )
lsblk -fs ( UUID /dev/db2 )
cat /etc/fstab ( check /boot/efi with UUID /dev/sdb2 and update UUID if it's false ) 
grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck --verbose
exit( leave chroot )

now in the /etc/fstab there is mounted sdb5 as /boot/efi => i should change the UUID to sdb2 - did i got that right? So sdb2 (the Windows EFI) gets mounted instead of sdb5 (Manjaro's EFI)?

# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=4BE7-4EB0                            /boot/efi      vfat    defaults,noatime 0 2

and then I'm installing via

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck --verbose

the "new" grub into the then as /boot/efi mounted sdb2 (Windows EFI) partition?

everything of course within the Live-Environment

Go to your bios and use this method for your Aspire E15.
It's in the link of the link that SGS posted above.

And if you further mess up (and cannot boot now) by doing chroot (selecting the wrong $esp or root partition), boot using that SGS link to boot into manjaro instead of chroot again.

1 Like

Sadly that Manual doesn't work for me. I'm able to do step 1,2,and 3 BUT in step 4 were the new EFI file should appear as an entry in the Boot-Order Tab within the BIOS, yeah it just doesn't. I already tried clearing SecureBoot. Doesn't do it either.

could you read my previous post and confirm what i recapped, I'm still kinda hesitating....

Okay, I don't have an Acer. But in that link, the OP first step is to enable secure boot so that he can get to select the manjaro file in the security section of the second step.

You may want to ping the user @Eldrik to ask further, but he is not too frequent in our forum and not sure if can respond. But good luck.

I did enable SecureBoot, I'd guess I would say I understand what @Eldrik did try in his Thread. Sadly it (the BIOS) just seems to ignore that I'm trying to add an other .efi file.

But I also know that especially this ACER Notebook has at least one other BIOS flaw, it was able to to virtualization via AMD Hyper-V but there was just no Option to activate it. But after a long search in the interwebs, there came along a Manual how to modify the BIOS.

So maybe, there's even an other flaw, just to "force" people staying at Windows. Or at least trying to scare them of.

1 Like

It seems to be this. If your notebook can use kvm, I recommend you use Windows with qemu-kvm virtual machine. In fact, as the wiki says, this problem can be solved, and his solution will be very ugly.

Sorry for quoting my own post, but did i understood that right? Mounting the fstab in the live Environment of my installed Manjaro, but then i have to unlock the LUKS container of my / (root) partition sdb7
Unlocking it wouldn't be no problem, but sounds odd.

and reinstalling grub onto sdb2 ( Windows EFI) partition?

@stephane would you have a look at my post and check if i got something wrong or missunderstood something. Thanks

And NOW the off-topic is going to start:

How much performance do i gain if i use qemu-kvm compared to virtualbox? I only tried virtualbox and I'm serioulsy starting to rise a point to give it all a f*** (Windows)
BUT for example i never got Catia to render anything properly within virtualbox. And the sad thing is i NEED a working Catia Environment, ain't need to be Windows native. Does qemu-kvm have those "limitations" of the display driver capacity because i don't even know were to begin if i had to install a qemu-kvm system lol

It seems that you need better 3D graphics, and your notebook seems to have a separate graphics card, you can assign a discrete graphics card to the virtual machine through pci pass-through.
In fact, the performance loss of the kvm virtual machine CPU is very low, usually around 5%.
I have played a 3D game for a year with a GPU pass-through KVM virtual machine.

soo...I started to read the Arch GRUB article and slowly starting to think it could have been a smart idea to create at Install not only a unencrypted EFI partition for Manjaro mounted as /boot/efi but to do as well a unencrypted /boot or would it have been possible, to just create a /boot whilst installation and flagging it with boot, esp

Sadly a lot of the hourlong trail&error methods are adjourned till the weekend. Including possible re-Installation, but I first kind-of want to know what actually not working now, to more or less understand what I probably f*d up so far.

Yeah I definitely diving down the ginormous rabbithole of direct virtualization via qemu-kvm.... but that an entire new story go to and I probably starting a Thread once I knew at least a bit about what I actually want/need/should do....

Have you encrypted the /boot partition? This sounds terrible. Finally, have you confirmed that your laptop BIOS can enable IOMMU?:thinking:

On Install I only excluded the /boot/efi suggested from the Tutorial so NOW it's obvious to me that therefore grub is "not visible" to my UEFI bootloader of my Notebook, as long as my system is starting to boot, because it's still encrypted. => FAIL

Maybe that's the background to @stephane 's idea of additionally installing grub onto sdb2 (EFI Partition of Windows) till it's still unencrypted.

Yeah, nah.... I know by recapping the knowledge I gained it's capable of AMD-V so it should be able to handle IOMMU - but as the actual "Activation" of that Function was a more or less dirty hack (https://www.youtube.com/watch?v=SVK943_upho) and as an Acer E5-553G Owner you weren't supposed to activate AMD-V it definitely could be possible some other sub-functions were f***ed up by Acer, just to annoy the customer.

I'm still trying to find myself some good Tutorial/Manual or alike to get into qemu but it's either very specific tailored to certain system configs or just way of my league.....

In fact, if you only need to use GPU pass-through, the support provided by ArchLinuxWiki is enough. It's very simple. I even use a graphical interface to configure the QEMU/KVM virtual machine. He is very easy to use.
Compared to this, I hope that you have actually used the following command to confirm that your computer can use IOMMU.:thinking:
sudo dmesg | grep -i -e DMAR -e IOMMU
In fact, as long as IOMMU is enabled, IOMMU can be detected in manjaro even without any configuration of manjaro.

@Dark_iaji Thanks, those links are very useful.

and thanks to your command, I again learned something and it seems to be available on my System:

[    0.805322] AMD-Vi: IOMMU performance counters supported
[    0.805747] iommu: Adding device 0000:00:01.0 to group 0
[    0.805809] iommu: Using direct mapping for device 0000:00:01.0
[    0.805839] iommu: Adding device 0000:00:01.1 to group 0
[    0.805894] iommu: Adding device 0000:00:02.0 to group 1
[    0.805910] iommu: Adding device 0000:00:02.2 to group 1
[    0.805926] iommu: Adding device 0000:00:02.3 to group 1
[    0.805944] iommu: Adding device 0000:00:02.4 to group 1
[    0.806013] iommu: Adding device 0000:00:03.0 to group 2
[    0.806030] iommu: Adding device 0000:00:03.1 to group 2
[    0.806086] iommu: Adding device 0000:00:08.0 to group 3
[    0.806154] iommu: Adding device 0000:00:09.0 to group 4
[    0.806169] iommu: Adding device 0000:00:09.2 to group 4
[    0.806224] iommu: Adding device 0000:00:10.0 to group 5
[    0.806284] iommu: Adding device 0000:00:11.0 to group 6
[    0.806340] iommu: Adding device 0000:00:12.0 to group 7
[    0.806410] iommu: Adding device 0000:00:14.0 to group 8
[    0.806428] iommu: Adding device 0000:00:14.3 to group 8
[    0.806513] iommu: Adding device 0000:00:18.0 to group 9
[    0.806529] iommu: Adding device 0000:00:18.1 to group 9
[    0.806545] iommu: Adding device 0000:00:18.2 to group 9
[    0.806565] iommu: Adding device 0000:00:18.3 to group 9
[    0.806580] iommu: Adding device 0000:00:18.4 to group 9
[    0.806598] iommu: Adding device 0000:00:18.5 to group 9
[    0.806615] iommu: Adding device 0000:01:00.0 to group 1
[    0.806717] iommu: Adding device 0000:01:00.1 to group 1
[    0.806795] iommu: Adding device 0000:02:00.0 to group 1
[    0.806808] iommu: Adding device 0000:03:00.0 to group 1
[    0.806847] iommu: Adding device 0000:07:00.0 to group 2
[    0.807375] AMD-Vi: Found IOMMU at 0000:00:00.2 cap 0x40
[    0.809508] perf/amd_iommu: Detected AMD IOMMU #0 (2 banks, 4 counters/bank).
[    7.052585] vboxpci: IOMMU found
[    8.808006] AMD IOMMUv2 driver by Joerg Roedel <jroedel@suse.de>
[ 7934.814295] vboxpci: created IOMMU domain 000000009799d535
[10478.894035] vboxpci: freeing IOMMU domain 000000009799d535

It looks great, good luck.
I always thought that notebooks can't use Intel VT-d and AMD-Vi.
The A12-9700P of the excavator architecture does not look very good, but it only makes the work efficiency lower and does not make the work impossible.

1 Like

Yeah, so i found a solution. I also had to remove the GRUB_ENABLE_CRYPTODISK=y which was added a second time at the end of my /etc/default/grub file. After then recreating the grub.cfg (update-grub) I was again prompted at Boot with the LUKS decrytion, BUT after entering the password an the appearance of the message the the "Slot 0 has been opened" I could hit ESC an FINALLY I was able to get into Grub and also Choose to boot into Windows.

Forum kindly sponsored by