Dualboot with Windows: /boot/efi doesn't look like an EFI partition

Hi there,

I've got the problem that the Installer ( manjaro-xfce-18.0.4-stable-x86_64.iso ) always fails to install at the Bootloader step. (it even took me a while to get past the "waiting for 1 module" step).

Here is the output of the installer (started via terminal).

My Setup:

  • One SSD with Windows
    • EFI Partition for Windows (I think about 100mb)
    • Windows
  • NVME SSD for Games (50% Windows, 50% ext4 for Linux (/usr/games))
  • One SSD for Linux
    • EFI Partition (500mb with boot and esp flag)
    • root
    • swap
    • home

The reasons for having two EFI partitions comes down to Windows. I usually re-install Windows with every big update and don't want my Linux bootloader to be wiped, thus I created a second efi partition on my linux ssd.
This setup worked fine so far using either AntergOS (with Grub) or native Arch Linux (with systemd-boot), but seems to fail using Manjaro.
Any ideas how to solve this problem?

FAT32 ?

I assume you cannot boot to manjaro. If you can, boot up to manjaro your way. Tell us how.
If you cannot, boot up using the first post here. Remember to start your install media in uefi.

Provide the information as stated there, namely...

efibootmgr -v
sudo parted -l
sudo blkid
findmnt -s
findmnt /boot/efi

info of all disks, do not omit, do not truncate.
Explain partitions if not clear (like having these OS's or usr or games...) like..
sda1 is manjaro $esp
sda4 is antergos / root
/dev/nvme0n1p1 is windows $esp
/dev/nvme0n1p4 is manjaro /usr

And since you have a separate usr partition, provide as well

grep keymap /etc/mkinitcpio.conf

More questions: not pertinent for the issue, just for my understanding

  1. Was your Antergos install /boot/efi ($esp) in nvme sharing with windows or in a separate disk like you have here for manjaro?
  2. How about your Arch install? Is the systemd-boot $esp (and I assume it is /boot, not /boot/efi) sharing with windows in nvme or in separate disk?
  3. Do you still have any of them (arch and antergos) or their partitions?

Yes, it's FAT32.

It's not that I cannot boot to Manjaro. The install media boots fine (uefi). The installation fails at installing the boot manager.
Thus, my setup on the Linux SSD is the setup I've used to have and I've set it up this way in the installer of manjaro via manual partitioning.

To your three questions:

  1. Windows efi and Linux efi were located on a separate (sata) SSD.
  2. Same goes for Arch (and yeah, I think it was boot, not boot/efi).
  3. No, I wiped them to make space for Manjaro while the nvme partition did not exist as it is a new drive (currently formatted with: 50% NTFS for Windows and 50% ext4, the remains of the failed Manjaro installation)

This is necessary to understand your setup. Your posts have too many words but very few bits of actually valuable information. At least from live system.

Sad fact about your problem is that it may be a real bug of the installer btw.

I was asking if you can boot to the installed manjaro OS, not booting livecd.
Apparently you cannot, I think.

Based on your answers on the 3 questions (nvme is a new drive, not pertinent to your installs of Antergos and Arch), I suggest you have the manjaro $esp located at nvme. You can make a separate $esp for manjaro separate from windows $esp but at the nvme drive. You can decide where you want to put your other partitions but be aware a separate usr requires a parameter at HOOKS line, and many will find a separate usr unnecessary.

And yes, the info will be useful for us to work on.
Take care. Goodbye.

After checking the calamares installation log (partial log I guess), it seems there are some messages that point to a calamares issue.

There you go.
I hope this information helps.

Only the NVME drive is new. Everything else existed already with the same partition layout (only that the linux partitions got wiped clean/formatted to make room for Manjaro).

You got it wrong. I don't have Manjaro installed, I'm trying to install it.
Currently I've only got Windows and the remaining partitions of my tries to install Manjaro which brought me here.

I've thought about creating it as a place to install all of my Games under Linux on a seperate drive (like I usually do with Windows).
\home goes where Linux goes, but a seperate partition
Games go to a seperate disk

Maybe there is a better way of doing this?

It's the complete log. I started calamares within a terminal so I can see what's wrong as the GUI doesn't really provide any useful information. Afterwards I copied everything calamares printed to the terminal and pasted it here.

Have you tried this?
Use the [More Complicated Setups] as you would not have a working grub.cfg.
And you do not have a separate boot partition - a /boot/efi (esp) is not a separate boot partition.

1 Like

Not really. You said you tried installation and got error about the bootloader. It's assumed that you may already have system partitions and only failed the last step for bootloader.
Did you check partitions contents?

I see. It's the normal log. I thought you used the verbose flag.

1 Like

Ah, that's how it's meant. No, I did not check the partitions contents.

Ok, I just tried this setup, but it fails after step 6 at the uefi specific commands. After the boot command at the end of step 6, I typed in ```
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi

cp: cannot stat '/boot/grub/x86_64-efi/core.efi': No such file or directory

Have you booted to the installation successfully?
Have you run grub-install as you should?
Have you rebooted?
That additional commands are only if boot fails, after normal grub installation.
Post from your installed Manjaro

lsblk -f
cat /etc/fstab

You have to do 'sudo grub-install' command first (it's in the link). It will generate that core.efi file.

If command still fails, this time the error is something like
"/boot/efi/efi/boot directory not found",
Then make directory and repeat command

sudo mkdir /efi/efi/boot

No wonder some find the tutorial too difficult and Ubuntu has to use microsoft shim.

Ah, ok. I thought you'd have to use them always.

Ok, I got it working now. Thx for the help. :slight_smile:

Goody! I hate to fail. :rofl:
And you're welcome. Cheers.

Still grousing about it, let alone it's totally unrelated to the topic and grub as it is?

Yes! I'm just a grumpy, grouchy old man.
You got a problem with it? :rofl:


Oh no, I'm pretty much the same :laughing:
Not that old though :smile:

1 Like

Forum kindly sponsored by