Dunst not starting on startup

Yesterday I run into a problem with notifications on my system. When I try to make a screenshot with Flameshot and then click to copy the screenshot the system freezes for about 20 seconds. I had this problem 1 year ago and then it turned out that the problem was with notifications on my system (Flameshot was trying to show notification that the screenshot has been copied) - the solution was to install Dunst which will take care of notifications.
Now the problem is present again, however it affects also Rambox and Wire - whenever these apps are about to send a notification they crash/freeze. Dunst is installed however I noticed that it does not start on startup. When I manually run /usr/bin/dunst everything works fine again.
When I run the command:

systemctl --user status dunst

The result is:

● dunst.service - Dunst notification daemon
     Loaded: loaded (/usr/lib/systemd/user/dunst.service; disabled; vendor preset: enabled)
     Active: inactive (dead)
       Docs: man:dunst(1)

I followed the instructions from ArchWiki on Dunst (https://wiki.archlinux.org/index.php/Dunst#Installation) and made sure that ~/.config/dunst/dunstrc exists (to my surprise it didn't so I copied it from /usr/share/dunst/dunstrc).

The result of inxi -Fxxxz`:

System:    Host: wojtek-pc Kernel: 5.6.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 Desktop: KDE Plasma 5.18.5 
           tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Micro-Star product: GE62 7RD v: REV:1.0 serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: Micro-Star model: MS-16J9 v: REV:1.0 serial: <filter> UEFI: American Megatrends v: E16J9IMS.309 
           date: 11/28/2016 
Battery:   ID-1: BAT1 charge: 46.7 Wh condition: 47.2/53.4 Wh (88%) volts: 12.2/10.9 model: MSI BIF0_9 type: Li-ion 
           serial: N/A status: Unknown 
CPU:       Topology: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP arch: Kaby Lake rev: 9 L2 cache: 6144 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44817 
           Speed: 800 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 800 2: 801 3: 800 4: 802 5: 800 6: 800 7: 800 8: 800 
Graphics:  Device-1: Intel HD Graphics 630 vendor: Micro-Star MSI driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:591b 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Micro-Star MSI driver: nvidia v: 440.82 bus ID: 01:00.0 
           chip ID: 10de:1c8d 
           Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia alternate: fbdev,intel,nouveau,nv,vesa 
           compositor: kwin_x11 tty: N/A 
           OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 20.0.7 direct render: Yes 
Audio:     Device-1: Intel CM238 HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:a171 
           Sound Server: ALSA v: k5.6.16-1-MANJARO 
Network:   Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi v: kernel port: e000 bus ID: 02:00.0 
           chip ID: 8086:24fb 
           IF: wlp2s0 state: up mac: <filter> 
           Device-2: Qualcomm Atheros Killer E2500 Gigabit Ethernet vendor: Micro-Star MSI driver: alx v: kernel port: d000 
           bus ID: 03:00.0 chip ID: 1969:e0b1 
           IF: enp3s0 state: down mac: <filter> 
Drives:    Local Storage: total: 1.14 TiB used: 439.18 GiB (37.5%) 
           ID-1: /dev/sda vendor: A-Data model: SU800NS38 size: 238.47 GiB speed: 6.0 Gb/s serial: <filter> rev: 8BS 
           scheme: GPT 
           ID-2: /dev/sdb vendor: HGST (Hitachi) model: HTS721010A9E630 size: 931.51 GiB speed: 6.0 Gb/s rotation: 7200 rpm 
           serial: <filter> rev: A3U0 scheme: MBR 
Partition: ID-1: / size: 199.51 GiB used: 180.35 GiB (90.4%) fs: ext4 dev: /dev/sda2 
           ID-2: swap-1 size: 34.47 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 66.0 C mobo: 27.8 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 258 Uptime: 26m Memory: 31.29 GiB used: 5.94 GiB (19.0%) Init: systemd v: 245 Compilers: gcc: 10.1.0 
           alt: 8 clang: 10.0.0 Shell: bash v: 5.0.17 running in: yakuake inxi: 3.0.37 

How can I make Dunst run on startup?

'sudo systemctl enable dunst.service' and afterwards ''sudo systemctl start dunst.service'

When I try to run this command I get:

sudo systemctl enable dunst.service
[sudo] password for wojtek: 
Failed to enable unit: Unit file dunst.service does not exist.

weird but no problem. open pamac and install dunst from the repository. after installing redo the commands. seems that dunst isn't installed in the right way.

I have already reinstalled Dunst 30 minutes ago.

https://wiki.archlinux.org/index.php/Dunst#Installation

Dunst fails to start via systemd

When using dunst without a Display Manager, the DISPLAY environment variable might not be correctly set.[7]

To fix this, add the following to your .xinitrc :

systemctl --user import-environment DISPLAY

Thank you for your answer. I added this line and restarted the computer, however nothing changed. Still when I run

systemctl --user status dunst

the result is:

● dunst.service - Dunst notification daemon
     Loaded: loaded (/usr/lib/systemd/user/dunst.service; disabled; vendor preset: enabled)
     Active: inactive (dead)
       Docs: man:dunst(1)

I'm not sure if it helps but after checking what notification servers are installed this is the result:

[wojtek@wojtek-pc ~]$ grep -r org.freedesktop.Notifications /usr/share/dbus-1/services
/usr/share/dbus-1/services/org.kde.plasma.Notifications.service:Name=org.freedesktop.Notifications
/usr/share/dbus-1/services/org.kde.plasma.Notifications.service:Exec=/usr/bin/plasma_waitforname org.freedesktop.Notifications
/usr/share/dbus-1/services/org.knopwob.dunst.service:Name=org.freedesktop.Notifications

Also, I can still run Dunst manually (by running ./dunst in the usr/bin/) so I don't know why this is such a problem to run it automatically. I would appreciate any help as now it is difficult to use Manjaro.

Ok, what I did is not really a direct solution but it works. I uninstalled dunst and turned on the default KDE notification widget. Apparently now the notifications work even with the flameshot. The problem that I had may be associated with what is written in ArchWiki:

Cinnamon, Deepin, Enlightenment, GNOME, GNOME Flashback and KDE Plasma use their own implementations to display notifications, and it cannot be replaced.

Why it worked before - I cannot say. However it seems that it is no longer possible to use dunst with KDE Plasma.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by