Earphones not working

---No sound in earphones or speaker ,but Bluetooth devices are working
also output of alsamixerupload

in (audio mixer>configuration>profile) all are (unplugged)&(unavailable)

inxi -Fxxxz :-
System:
Host: hari-pc Kernel: 5.4.52-1-MANJARO x86_64 bits: 64 compiler: gcc
v: 10.1.0 Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4
dm: LightDM 1.30.0 Distro: Manjaro Linux
Machine:
Type: Laptop System: ASUSTeK product: X556UF v: 1.0 serial:
Mobo: ASUSTeK model: X556UF v: 1.0 serial:
UEFI: American Megatrends v: X556UF.404 date: 05/20/2016
Battery:
ID-1: BAT0 charge: 3.7 Wh condition: 3.7/38.0 Wh (10%) volts: 7.6/7.6
model: ASUSTeK ASUS Battery type: Li-ion serial:
status: Not charging cycles: 1394
CPU:
Topology: Dual Core model: Intel Core i5-6200U bits: 64 type: MT MCP
arch: Skylake rev: 3 L2 cache: 3072 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 19204
Speed: 800 MHz min/max: 400/2800 MHz Core speeds (MHz): 1: 800 2: 800
3: 800 4: 800
Graphics:
Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: ASUSTeK driver: i915
v: kernel bus ID: 00:02.0 chip ID: 8086:1916
Device-2: NVIDIA GM108M [GeForce 930M] vendor: ASUSTeK driver: nvidia
v: 440.100 bus ID: 01:00.0 chip ID: 10de:1346
Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia
unloaded: nouveau alternate: fbdev,intel,nv,vesa
resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 20.1.3
direct render: Yes
Audio:
Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:9d70
Sound Server: ALSA v: k5.4.52-1-MANJARO
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK driver: N/A port: d000 bus ID: 02:00.0 chip ID: 10ec:8168
Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter vendor: Lite-On
driver: rtl8723be v: kernel port: c000 bus ID: 03:00.0 chip ID: 10ec:b723
IF: wlp3s0 state: up mac:
Drives:
Local Storage: total: 931.51 GiB used: 152.55 GiB (16.4%)
ID-1: /dev/sda vendor: Toshiba model: MQ01ABD100 size: 931.51 GiB
speed: 6.0 Gb/s rotation: 5400 rpm serial: rev: 5J scheme: GPT
Partition:
ID-1: / size: 915.60 GiB used: 152.55 GiB (16.7%) fs: ext4 dev: /dev/sda2
Sensors:
System Temperatures: cpu: 49.0 C mobo: N/A
Fan Speeds (RPM): cpu: 3000
Info:
Processes: 180 Uptime: 1h 32m Memory: 7.64 GiB used: 1.62 GiB (21.2%)
Init: systemd v: 245 Compilers: gcc: 10.1.0 Shell: bash v: 5.0.18
running in: xfce4-terminal inxi: 3.0.37

Hi and welcome!

Here is an older post of a similar problem: https://forums.linuxmint.com/viewtopic.php?f=48&t=267963&sid=e1419618432a98be9d539d72a2d0b8cd&start=20#top

by tyensen » Mon Dec 24, 2018 12:39 pm
I had the same problem and tried all the fixes on various message boards. What finally fixed it for me was updating the BIOS on my motherboard (Asus Z170M-Plus). Not entirely sure why this fixed it but I believe it broke after applying a bunch of Ubuntu updates that I had left pending for quite some time that appeared to include fixes for Spectre/Meltdown. The BIOS updates contained similar updates for these exploits so perhaps this was related. (seems like a bit of a stretch - but hey its working now)

Is your EFI updated? https://www.asus.com/Laptops/X556UF/HelpDesk_BIOS/

As i see

Your UEFI is from 2016. Current one is from 2019.

PS: And please... please use code blocks for code like this:

```
code
```

is look then like this:

code

Thanks , can you tell me how can i update bios without a flash-drive ?

Never done but you try this: https://www.flashrom.org/Flashrom

Here is more information: https://wiki.archlinux.org/index.php/Flashing_BIOS_from_Linux#Flashrom

Flashrom is available in the official repo.

But seems your mainboard is not supported: https://www.flashrom.org/Supported_hardware#Supported_mainboards

Thanks again, i am gonna try it now.

1 Like

Better use a flash drive and let the UEFI read from there :wink:

I can't try it.
There is a warning for using it on notebook.

okay, now i just have to find a flash-drive.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by