[EeePC 1000H] 80% of screen black with 4.14 (i686)

Spoke too soon. The new 4.13./4.14 kernel causes a weird glitch:

  • the left side 80% of the screen distort at boot animation
  • at desktop, the left 80% of the screen is black, the 20% is ok
  • clicks on the black bit are 'getting through' to windows below, mouse-overs of windows below are visible on cursor icon status changes, if you open a terminal via keyboard you can 'feel' your way to the title bar, drag it into the 20% and use it
  • if you remote desktop into your glitched machine there is no glitch
  • the glitch is 'fixable'

How to 'fix' it:

and the glitch is gone!

I recon any command to xrandr would do the same, e.g in 'Monitor settings', haven't tried that yet, though. If I set the 'newrez to default' command to run at startup I can use the machine.

I have a triple boot on this machine, 2 18.3 Mints and 1 Manjaro32; the glitch happens on 1 Mint and on Manjaro, it does not happen on Mint Mate 18.3. Tried removing/installing intel-ucode, makes no difference.
There is an about 6-8 second delay at boot with this kernel.

If anyone has any idea I can try things. Could this be related to the window manager?

If the installer installs, then the installer works. If a later kernel update breaks that's not the fault of the installer image, so it should go in its own thread. :wink:

Can you be more specific as to your kernel version? For example, 4.13 isn't available for i686.

A known issue.
Resolvable by editing /etc/default/grub GRUB_GFXPAYLOAD_LINUX=text and running update-grub from chroot.
@jonathon, maybe it can be made the default?

1 Like

If GRUB_GFXPAYLOAD_LINUX=keep works that might be a better default so people don't lose Plymouth or Bootsplash or whatever they have.

Otherwise, if it's an intel driver issue that should be resolved by an update.

Using the default linux49 is a workaround which is less invasive, I agree.

Sorry about not being clear on this. I stumbled on this when replying to a user in the Mint forum. Since I had similar hardware I tried to confirm the error with the 4.13.0-26 on Mint, but weirdly it affected only one of the 2 installs.

I then booted Manjaro32 17.1.1.rc2 (4.9.76-1LTS?); there were updates incl a kernel update (4.14.13LTS?), installed and run 4.14, - and had the same problem.

Edit: Ok, I believe I worked this out:
This is not a kernel issue by itself but a grub issue that is triggered by the 'fixed' kernels of the 4.13/4.14 series, both in Mint and Manjaro:

On my multi-boot Asus eee-pc (2 Mint, 1 Manjaro (intel-ucode removed) whatever OS is in charge of grub will glitch when one of the 'fixed' kernels is booted (4.13.0-26 on Mint, 4.14.13-1 on Manjaro). Booting the 'fixed' kernels of the other OS further down the grub menu works fine.

If I then sudo grub-install /dev/sda from there, the error shifts to the new OS in control of grub, allowing both of the others to boot without problem, including the one that glitched when in control of grub.

In a nutshell: If I boot a 'fixed' kernel of the 4.13 or 4.14 series via the 2 top lines of grub it will glitch, both on Mint and on Manjaro, all other grub options below work fine.

1 Like

No, it doesn't, only 'text' does.

However, if I leave grub alone and run these 3 commands (my default res) on the glitched desktop:

xrandr --newmode "1024x600_60.00"   49.00  1024 1072 1168 1312  600 603 613 624 -hsync +vsync
xrandr --addmode VGA1 1024x600_60.00
xrandr --output VGA1 --mode 1024x600_60.00

then the last one fixes the problem on-the-fly.

If this can be run at startup it may be a better option since at boot-up you'll notice if an update has sorted this, in which case just remove the startup entry.

1 Like

Forum kindly sponsored by