EEPROM update working!

Just wanted to let you all know that there is an AUR package for rpi-eeprom and I was just working with the guy to get it fixed to install properly on Manjaro-ARM.

Easy process to update EEPROM and it worked on my Pi 4, Manjaro 20.02.

From PAMAC, install raspberrypi-userland-aarch64-git and rpi-eeprom

echo 'export PATH="/opt/vc/bin:$PATH"' >> ~/.bashrc
source ~/.bashrc
sudo rpi-eeprom-update
sudo rpi-eeprom-update -a
sudo reboot

Hope this helps out!

Why is the userland package needed?

I assuemd it was because the updater needs the vc commands in /opt/vc/bin ?

Fair enough.

Glad it worked. :slight_smile:
So you have USB boot?

Haven't tried it yet. Was going to leave boot on the SD card and move root over to the USB SSD.

1 Like

Not sure if this will affect my current boot from SD and run off SSD situation, lol. Gonna run it though.Screenshot_20200228_194020

ran it, I already had the latest firmware?

Nice! Mine had the firmware from July so it updated it.

Does this install all relevant files in /opt/vc
Like include folder etc?

Yup it's there for me.

You should mention that the default branch is critical.

If one's intention is to upgrade the eeprom for MSD boot this guide should not be used. The rpi-eeprom package in AUR does not have the latest required firmware/beta/pieeprom-2020-05-15.bin and also in addition It requires the latest *.elf and *.dat files in /boot.

I have pushed all of the necessary files for MSD boot with the latest in the unstable branch. Install with:

Switch to the unstable branch:

sudo nano /etc/pacman-mirrors.conf and change Branch = line to reflect unstable

Branch = arm-unstable

Update pacman mirrors, update pacman database and install needed packages:

sudo pacman-mirrors -f5
sudo pacman -Syy
sudo pacman -S raspberrypi-bootloader raspberrypi-bootloader-x raspberrypi-userland-aarch64-git rpi-eeprom

Switch back to the Manjaro-ARM branch you were using prior to unstable and rerun:

sudo pacman-mirrors -f5
sudo pacman -Syy

Now switch to the beta branch from critical in rpi-eeprom-update:

sudo nano /etc/default/rpi-eeprom-update

FIRMWARE_RELEASE_STATUS="beta"

At this point /opt/vc/bin will not be in the system path but will be after a reboot so for now just export the path first in the terminal and then run the commands:

Note: The commands
sudo rpi-eeprom-update will give you the current status
sudo rpi-eeprom-update -a will flash the eeprom if needed

export PATH="/opt/vc/bin:$PATH"
sudo rpi-eeprom-update
sudo rpi-eeprom-update -a
sudo reboot

After a successful reboot remove the temporary files that was written in /boot:

sudo rpi-eeprom-update -r

Check status with:

sudo rpi-eeprom-update

eeprom

This topic was automatically closed after 90 days. New replies are no longer allowed.

Forum kindly sponsored by