Efibootmgr does not show manjaro after install (dual boot uefi)

Hey everyone, I'm new here, and I was trying to dual boot windows 10 (uefi) and manjaro (xfce de). I followed this guide here:

I have a hard disk and a ssd, and my windows is booted on the ssd. I made some space on the ssd for manjaro as well. So I created partitions as per the guide (refer pic)IMAG0119
The installation went fine, but after the installation, the efibootmgr command does not show up manjaro. (Refer pic)
How do I go about solving this? Laptop directly boots up windows when started. Any help is appreciated, thanks!

go into your bios boot from manjaro once booted into manjaro do in a terminal sudo update-grub once that has finished reboot you should see windows and manjaro

1 Like

Take a look at this. First post.

Do [Additional UEFI commands] at step 6. Read completely first post.

Thanks for the quick reply.
I get a invalid volume error on running that.

error: invalid volume
grub-probe: error: cannot find a GRUB device for /dev/sda1. Check your device.map.
Found windows boot manager on /dev/sdb2@/efi/Microsoft/Boot/boogfw.efi

My hdd is sda, my ssd is sdb, the 512 mb partition created during installed is on my ssd (sdb)

I did read the entire post, and I get this when I do sudo update-grub:
Generating grub configuration file ...
Found background: /usr/share/grub/background.png
Found linux image: /boot/vmlinuz-4.14-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-4.14-x86_64.img
Found initrd fallback image: /boot/initramfs-4.14-x86_64-fallback.img
error: invalid volume.
grub-probe: error: cannot find a GRUB drive for /dev/sda1. Check your device.map.
Found Windows Boot Manager on /dev/sdb2@/efi/Microsoft/Boot/bootmgfw.efi
Found memtest86+ image: /boot/memtest86+/memtest.bin

efibootmgr -v
BootCurrent: 0009
Timeout: 1 seconds
BootOrder: 0003,0000,0008,0007,0002,0001,0004,0005,0006,0009
Boot0000* Windows Boot Manager HD(2,GPT,372f04fd-9d26-11e8-b360-183da2f52778,0x153cf800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}....................
Boot0001 Diskette Drive BBS(Floppy,Diskette Drive,0x0)..BO
Boot0002* Internal HDD BBS(HD,P0: TOSHIBA MQ01ABD100 ,0x0)..BO
Boot0003* manjaro HD(4,GPT,c6447d3c-707a-49d6-8d48-4e0ed4c32c5e,0x155ad000,0x100000)/File(\EFI\manjaro\grubx64.efi)
Boot0004 CD/DVD/CD-RW Drive BBS(CDROM,CD/DVD/CD-RW Drive,0x0)..BO
Boot0005* Onboard NIC BBS(Network,Realtek PXE B03 D00,0x0)..BO
Boot0006* System Device Bay BBS(HD,P1: SanDisk SDSSDA240G ,0x0)..BO
Boot0007* USB Storage Device BBS(USB,USB Storage Device,0x0)..BO
Boot0008* UEFI: SanDisk SDSSDA240G, Partition 2 HD(2,GPT,372f04fd-9d26-11e8-b360-183da2f52778,0x153cf800,0x32000)/File(EFI\Microsoft\Boot\bootmgfw.efi)..BO
Boot0009* UEFI: SanDisk SDSSDA240G, Partition 4 HD(4,GPT,c6447d3c-707a-49d6-8d48-4e0ed4c32c5e,0x155ad000,0x100000)/File(EFI\boot\bootx64.efi)..BO

sudo parted -l
Model: ATA TOSHIBA MQ01ABD1 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 32.3kB 1000GB 1000GB primary

Model: ATA SanDisk SDSSDA24 (scsi)
Disk /dev/sdb: 240GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 182GB 182GB ntfs msftdata
2 182GB 183GB 105MB fat32 boot, esp
3 183GB 183GB 897MB ntfs diag
4 183GB 184GB 537MB fat32 msftdata
5 184GB 193GB 8590MB linux-swap(v1)
6 193GB 240GB 47.5GB ext4

sudo blkid
/dev/sda1: LABEL="The D" UUID="4020A9DA20A9D6E6" TYPE="ntfs"
/dev/sdb1: LABEL="SSD" UUID="F84A63994A635382" TYPE="ntfs" PARTUUID="372f04fc-9d26-11e8-b360-183da2f52778"
/dev/sdb2: UUID="6E59-BD4D" TYPE="vfat" PARTUUID="372f04fd-9d26-11e8-b360-183da2f52778"
/dev/sdb3: UUID="01D42C11B1F003B0" TYPE="ntfs" PARTUUID="372f04fe-9d26-11e8-b360-183da2f52778"
/dev/sdb4: UUID="C18A-78E5" TYPE="vfat" PARTUUID="c6447d3c-707a-49d6-8d48-4e0ed4c32c5e"
/dev/sdb5: UUID="f4b2a2a2-47c4-4c0b-8e07-f28d546a7219" TYPE="swap" PARTUUID="6ef35391-65c4-4681-9562-ec3c285b77b8"
/dev/sdb6: UUID="42d12622-c2a4-43de-8573-cd0e70284149" TYPE="ext4" PARTUUID="66995774-34e0-464b-9415-a0267bc6862e"

findmnt -s
/boot/efi UUID=C18A-78E5 vfat defaults,noatime
swap UUID=f4b2a2a2-47c4-4c0b-8e07-f28d546a7219 swap defaults,noatime,discard
/ UUID=42d12622-c2a4-43de-8573-cd0e70284149 ext4 defaults,noatime,discard
/tmp tmpfs tmpfs defaults,noatime,mode=1777

findmnt /boot/efi
/boot/efi /dev/sdb4 vfat rw,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro

This is all my info (as per the linked post) and I am running a dell vostro 3559

EDIT: My problem is solved, thank you all for helping!

(Although the update-grub failed, subsequent restarts and I can see the dual boot menu. The 2 commands specially for uefi systems with appropriate /dev/ directory has done the trick! )

Your primary drive (sda) is msdos though your secondary drive (sdb -gpt) contains $esp for both windows and manjaro (sdb2 and sdb4).

Yes, it is working but since your system is uefi, better to have primary drive as gpt and best to have all drives in gpt.

You can change the cables to the drives but your system may (may not) lose the efiboot entries and you can repeat the procedure again to fix it all back.

1 Like

Thanks, I'll look into it (was thinking of replacing cables)

Not replacing, but disconnect cable from sda and connect to sdb and vice versa.

1 Like

Yes that is what I meant (reading back it doesn't sound that way!) haha thanks mate for all the help!

1 Like

if windows was installed on first hard drive and then install manjaro on second hard drive this problem would not happen thats how I fixed it on my asus laptop the only thing I did notice windows was slugish so I changed first hard drive to ssd problem solved but I dont run winows anymore so no problems at all

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by