Efibootmgr unable to create EFI entry

Hi, idk what is happening but I use manjaro in two pcs, and I've got the same problem when trying to create a new UEFI entry using efibootmgr or grub-install (After the Windows update which obviously breaks everything)
No error is reported, the entry is just not created, I have to boot manually using super grub disk or (only in my laptop) setting manually from the bios the grubx64.efi
Same issue with the latest (I think it is the latest iso) manjaro live (not chrooting, the installer itself which also uses efibootmgr)
Any ideas?
I've tried everything, also efibootmgr manually without grub-install

update windows means :
suppress all line EFI that do not goes to windows or any shime secure ( one to rule all others ),
and bios always looks for bootx64.efi

can your return

sudo efibootmgr -v
sudo parted -l
sudo blkid
cat /etc/fstab

Care to write down what you tried?

I will explain it better, just for the blame of curiosity after windows update I already knew that it would have break everything, so after that I went straight and manually deleted the manjaro EFI entry from a live USB linux distro and tried to re-create the efi entry with grub-install unsuccessfully, the other things I tried were reinstalling manjaro with the latest xfce iso in my desktop PC but before that I disconnected my windows ssd, and that worked but just because of the BIOS automatically detecting the .efi file (In fact, the uefi entry name was a generic UEFI OS instead of 'manjaro' which grub-install/efibootmgr creates)
So when I tried plugging the Windows SSD back, deleting the previous created efi entry and files, and using the usual EFI partition in that separate storage as I always do didn't worked. I also tried if the btrfs file system I use was the issue but nothing, I've also reinstalled Windows, re-created the EFI partition and nothing, so I obviously thought of an efibootmgr bug, also tried the "raw" efibootmgr command which apparently created a new entry but when I ran 'efibootmgr' a second time it did not
The only thing I did on both pcs were booting a linux mint live USB, I can't think of anything else.

Anyway, here is the output of those commands.

BootCurrent: 0003
Timeout: 2 seconds
BootOrder: 0000,0006,0001,0002,0004,0005,0007,0003
Boot0000* Windows Boot Manager	HD(1,GPT,6f8337a5-e1ea-4e86-b601-39c19f7cdcf2,0x800,0x7d000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}...-................
Boot0001* Diskette Drive	BBS(Floppy,Diskette Drive,0x0)..BO
Boot0002* M.2 SATA SSD	BBS(HD,P0: Crucial_CT275MX300SSD4    ,0x0)..BO
Boot0003* Grub	PciRoot(0x0)/Pci(0x17,0x0)/Sata(0,65535,0)/HD(1,GPT,6f8337a5-e1ea-4e86-b601-39c19f7cdcf2,0x800,0x7d000)/File(\EFI\Manjaro\grubx64.efi)
Boot0004* CD/DVD/CD-RW Drive	BBS(CDROM,CD/DVD/CD-RW Drive,0x0)..BO
Boot0005* Win	PciRoot(0x0)/Pci(0x14,0x0)/USB(1,0)/HD(1,GPT,a1c9adfd-b6fa-490d-9d5f-7c228ff5b900,0x800,0x3b9f7df)/File(\efi\boot\bootx64.efi)
Boot0006* UEFI: Crucial_CT275MX300SSD4, Partition 1	HD(1,GPT,6f8337a5-e1ea-4e86-b601-39c19f7cdcf2,0x800,0x7d000)/File(EFI\Microsoft\Boot\bootmgfw.efi)..BO
Boot0007* USB Storage Device	BBS(USB,USB Storage Device,0x0)..BO

Please note that this is my notebook where I can add an UEFI entry manually from the BIOS, to that "grub" entry is created manually by me.

Modello: ATA Crucial_CT275MX3 (scsi)
Disco /dev/sda: 275GB
Dimensione del settore (logica/fisica): 512B/512B
Tabella delle partizioni: gpt
Flag del disco: 

Numero  Inizio  Fine   Dimensione  File system  Nome                  Flag
 1      1049kB  263MB  262MB       fat32        EFI system partition  avvio, esp
 2      263MB   182GB  182GB       ntfs         Basic data partition  msftdata
 3      182GB   183GB  867MB       ntfs                               nascosta, diag
 4      183GB   275GB  91,8GB      btrfs

Modello: Sconosciuto (unknown)
Disco /dev/zram0: 2051MB
Dimensione del settore (logica/fisica): 4096B/4096B
Tabella delle partizioni: loop
Flag del disco: 

Numero  Inizio  Fine    Dimensione  File system     Flag
 1      0,00B   2051MB  2051MB      linux-swap(v1)

/dev/sda1: LABEL="SYSTEM" UUID="2626-ECD0" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="6f8337a5-e1ea-4e86-b601-39c19f7cdcf2"
/dev/sda2: UUID="01D2E48435767F60" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="a129145d-6264-47a3-8972-ad6bd5575dff"
/dev/sda3: UUID="6A027246027216F3" TYPE="ntfs" PARTUUID="f3ba160e-6d53-4a00-b1d8-cdf5c1240cb5"
/dev/sda4: UUID="3fa9c03c-446b-49de-a6ec-7759397eb60c" UUID_SUB="a85c7a1b-ace2-4013-86c0-c0817b6b077f" TYPE="btrfs" PARTUUID="be7e9254-ccf8-477f-8edc-b221203cf013"
/dev/zram0: UUID="de2be463-89a5-4041-800a-bbf880df6cdf" TYPE="swap"

# /etc/fstab: static file system information
# <file system>	<dir>	<type>	<options>	<dump>	<pass>
/dev/sda4	/	btrfs	defaults,ssd	0	1

I will however do a further testing with a VMware EFI Virtual machine

Asus? Please let us know. It's important for some points later on.

Your 'parted -l' does not include all disks.
I still don't understand why people do not print out all disks when asked for 'parted 'l' or 'lsblk -l' .
You also missed out blkid, it is needed to understand 'efibootmgr -v'

But the most important thing in your case....
You do not have /boot/efi entry in your fstab.
Without assuming you 'forgot' to mount $esp during installation, can you explain why this is missing?
Is this deliberate?

ps: There are 2 other recent Spanish speaking members who do not have a /boot/efi $esp partition.
Could it be a coincidence or is the 'wiki' in the Spanish Manjaro website missing this? (yes, I understand you're Italian).

Nope, this is a Dell XPS 15 9550, anyway as I said this is my notebook, here I got just a single SSD and no other disks, my desktop has more than one disk but since the problem is releated to the distro/software I don't see the reason... I could also run those commands there if you want.

lsblk -l

sda     8:0    0 256,2G  0 disk 
sda1    8:1    0   250M  0 part 
sda2    8:2    0 169,7G  0 part /run/media/root/ata-Crucial_CT275MX300SSD4_16291
sda3    8:3    0   827M  0 part 
sda4    8:4    0  85,5G  0 part /
zram0 254:0    0   1,9G  0 disk [SWAP]

Anyway I put the blkid command... before the fstab and right after the 'parted -l' if in case you didn't see it.

Anyway yes, I edited my fstab for testing purposes, I mount my /boot/efi partition manually when I need it, of course I did it before all this tests (it would give me an error otherwise)

Okay, thanks for the explanation.
But here's the problem.
We need /boot/efi for grub-install command to work and for efibootmgr entries to be generated. [1]
In other words, it must be in fstab.
To explain further, if you mount it manually, and not mounted as '/boot/efi', it will still be a problem.
If mounted manually as /boot/efi, and commands carried out, but upon reboot, /boot/efi will still be missing. In other words, why not just put the $esp in fstab.

Can we please focus on one computer system, say laptop or desktop so we (I particularly) do not confuse what is what and mess up commands. We can handle the next system if you like once one system is cleared up.

Right, to start, first put the $esp (hopefully /boot/efi) in fstab. Tell us desktop or laptop (and repeat makes of both so I can get it clear)
Then...see this and do the commands in step 6 (repeat, fstab and /boot/efi already fixed beforehand) and with the extra 2 commands [UEFI -additional commands] done.

If your Dell does not put in the entry (though most Dell have no problems), do your way to include the 'manjaro' entry (let us know - we need to list it down as another computer system that needs 'special handling').

Good luck. Ciao.

[1] - even then, it may not with recent 'grub-install'. But still, efi-directory must be specifically 'spelled out' for all efi commands.

Anyway I've updated my fstab right now so I can do more "decent" testing, I think however that the issue is releated to the a software bug, since in my desktop the fstab is fresh new from the Manjaro installer so it is not touched by me, and the issue there still persists, I mess a lot with the EFI bootloaders but this is the first time I'm having issues, I've also tried installing Manjaro in a Virtualbox EFI virtual machine and there still persist the issue I'm having, no UEFI entry is created but since the VBox BIOS automatically detects the EFI file no problem, but in systems like my Desktop which don't always happen especially when more disks are present the story can be different.
Here is a screenshot


Anyway I will put the results of those commands later as I have to reboot my laptop

This Dell is a little bit strange, sometimes I have to manually put the EFI entry from the BIOS especially when I install Windows from USBs, but it always worked nice with Linux and grub-install.

In short words It is a problem that came up recently

So uhh back from some tests...From both laptop and desktop.

I feel stupid because the thing that actually worked for both computers was that "efibootmgr" command you listed and I already did that before hours ago and I in fact said it seemed to work since it showed a new entry but after a second time running the efibootmgr command showed nothing...

The results


After grub-install no efi entry (the last cmd line is just to show the command I executeed)

Efibootmgr solved the situation again
So long story short, the issue is just that I can no longer create an EFI entry using grub-install for some reasons in both my Desktop or Laptop, here is the --debug --recheck output from my desktop.


Still the grub-install command no longer works as I was used to...
Did some update broke the functionality? To be honest I made this forum post to discuss a possible severe bug not to solve the issue in my computers since it is not a big deal at least for me who know how to boot the system eventually.

On all above, yes, you're right.
Recent grub-install (and installation too) do not make an entry for 'manjaro' in the uefi bootentry.
And that is why I asked you to do the 2 extra commands in the link (which you did) to handle the situation.
I had informed the developers somewhere and petsam had reminded them too. [1]

And for Dell, we'll see if other Dell users need to do the things you have to do before naming Dell as a 'special case', maybe just your model or they have an undated firmware.

So, good to hear you've fixed it and cheers. Ciao.

[1] - I'm not in the habit of nagging - intel-ucode, installing uefi in msdos, ... are some of the things still not addressed, but hey, which distro's don't have their bad points?

[2] - Perhaps if I don't help out others in problems like these, maybe the issues will be fixed? :smiling_imp: After all, I can work out these myself. Why do I care, huh? :laughing:

Uhm yeah, I've got another friend with the XPS 15 9550 with an i7 CPU and there are some strange reasons with this computer especially with uefi USB devices where you need to add the entry manually, never had problems with Linux actually because It worked flawlessly since now, "happy" to know it is a grub issue anyway. Thanks for the help hope they will solve It soon because Manjaro is the distro I prefer and also the one I suggest to everyone for its user friendlyness, and this is some serious issue with some desktops like mine If you want to install It with this bug now.

1 Like

I had the same problem and I'm running Manjaro Deepin on a Asus N46VM but I've fixed it with rEFInd.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by