Electron applications launch invisibly

Hi,

So I've had this issue where application when I reboot, some applications (like Riot/element and google-keep-nativefier , sometimes even discord) launch (I can see them in ksysguard) but they aren't visible on the desktop. (they're not on a virtual desktop either)

What I have noticed is that when this happens, usually the invisible applications are under systemd instead of under plasmashell (in ksysguard):
Screenshot_20200803_083208
When I manually open Discord:
Screenshot_20200803_083339

I have them set in autostart in the system settings:
Screenshot_20200807_131342
And it's also set to only start when plasma has been started.

I should also mention that I have another problem which might be related?:
They seem to lose their settings. So with Riot/element, I have to reenter my login most of the time.
And with Discord as well, and the history of my emote usage is also gone. I'm not sure how that's possible though

i've already re-installed them multiple times

I don't know what's going wrong. Any ideas?

Maybe they are set to "Launch automatically at boot/login"?
Do you have a tray icon with them?

Maybe they are set to "Launch automatically at boot/login"?

Well yeah, I set to autostart, via the autostart menu in the system settings. Like I said in my post

I don't see the icon in the system tray

Maybe you have to hit the Advanced button, once one selected, and set to Autostart only in Plasma.
With the changes of the Tray, maybe a delayed startup will help too.
For example:
Exec=sleep 10s && discord
in the discord.desktop file inside your ~/.config/autostart/

I already have it set to only start in plasma.

And don't think that adding a sleep is going to help it appear. Keep in mind, the window itself is just also invisible. it's not just that there is no icon in the system tray

Ok, i will install it myself and make a test even tho i don't use it, since it seems we have to get argumentative here.

Was the same with pamac

Edit: Made my own test on two installs. Discord starts from Autostart with no problem, and no need to change anything about the autostart. The window of the app is visible with the default Manjaro provided theme.

image

huh.... weird.

what should I change in the exec field on the .desktop file so that it logs to a file (can't find a proper solution online).
Maybe that'll clear something up?
Screenshot_20200808_225044

ACTUALLY:

I just noticed something. So the 'autostart in plasma' option wasn't checked for Discord (even though i'm 200% it was).
So I checked it.
Rebooted.
Discord launched and was logged in (so kept it's settings I guess).
BUT when I checked the Autostart again in the system settings now. That checkbox was UNCHECKED again.
So somehow it's not saving that checkbox.. or changes it?

Yeah, there is something to it. I was able to reproduce the issue you described on a very old VBox VM install, but nothing concludent to shade some light of why is happening.
Try to force fix the ownership of your home directory to your user if only this is the issue at hand.

If you use autologin, sometimes the files get owned by your username and the group autologin, and that changes sometimes too, making some settings to not survive the reboot. I have no clue why does that sometimes, but i did noticed it.

Just so I don't fck anything up. What is the exact chmod command I should run on my home directory?

sudo chown -R $USER $HOME
should do it.

Forum kindly sponsored by