Electron Apps crashing randomly

Hi everybody,

From a moment I'm experiencing crashing application.
It's happening with electron app (slack and KeeWeb).
I have Manjaro i3.

So after a moment the application doesn't respond anymore.
The only thing I can do is to kill it.
When I experience a crash in one application and if both of these programs were running, then both of them crash.

However I cannot say from when exactly this happen.
I'm currently running kernel 5.0.5-1 if it matters.

Thank you very much for any direction I can follow to fix or understand what's happening.


Does the app crash when you are supposed to get a notification? This happened to me with Slack (Same kernel too, but I doubt it's related to that). You can test it on Slack from your profile page.

Installing xfce notification daemon and configuring it fixed the crashes for good.


Anyway as both programs are build on Electron it seems like the problem is somewhere between the browser and your system that makes all its processes fail.

I have the notifications (from i3) that work well...
I just noticed something new..
I keep slack, KeeWeb and code (Visual studio code) running to see how there are affected..
slack crashes are occurring frequently (sometimes within a couple of minutes sometimes within hours).
And finally others app are not always affected..
VS Code is the least affected and most of the times it's still working.
Something I noticed is that my mouse cursor seems to respond to what's underneath the slack view.
BTW I didn't precise that but when the app is crashing the display became frozen.
So it appears that the app is still running (I hear some of the notification sound in the background) but the display is not refreshing.

So it's really weird..

When I googled for "electron app crash" there are many cases related to libc 2.28 which is the version manjaro seems to have..

But I don't really know what to do from there..

I'm using Archlinux, but I get exactly the same error using i3 and twmnd (notifications are working perfectly) with electron apps. Exactly the same behavior, so I think that it's somehow located in the "common base" between manjaro and arch. Im curious did you find any solution in the meantime? The problem kind of drives me crazy :frowning:

Using Arch Linux and Awesome WM I have the same error, all electron apps randomly freeze (no more display). Didn't find anything useful in the logs.. Might be an electron bug.

Hi everybody...
Unfortunately the problem is still occurring..
This makes me mad..
Today I had to work with 3 vscode windows (I'm not used to have more than one instance..)
And it makes me crazy.. Every couple of minutes vscode crash!
I added the --disable-gpu flag but this doesn't changed anything (I have an intel gpu core i7 anyway)
I really don't know what to do..
Now I'm working on a project and I cannot start a clean installation..

Edit: I remembered I updated to kernel 5.1.1-2 yesterday
I switched back to the previous one (5.0.15-1) and the problem regarding vscode crashing within a couple of minutes doesn't happen anymore..
So, I will stick with this one in the meantime..

It still happen!
I really don't know what's going on here!
Now chrome didn't freeze, regarding slack and KeeWeb seem also not..
But only vscode!
Such a randomness is really annoying!
And make difficult to understand what's happening..

I would love to fix this issue!!
Please!!! :exploding_head:

I have the same issue using Manjaro/i3 since kernel >= 5.0, also seemingly not related to notifications which work fine.

I open slack, switch to other workspace, come back, sporadically but pretty frequently slack is frozen and its tile becomes transparent. In some cases, the freeze also affects other workspaces.

For me, rolling back to kernel 4.20 solved the issue and brought my system including slack back to running 100% stable, so maybe this is a short term solution for @sanjibukai and others too, but of course one would like to move on to the latest kernel...

So if anyone knows where the problem originates and how to fix, a hint would be highly appreciated.

I have exactly the same issue! I'm on Kernel 5.2

I have the exact same problem.
Since Linux Kernel 5+ all electron apps just randomly crash after some time.
It's so annoying, because the recent update (especially nvidia) isn't compatible with kernel 4.20, so I either have to go down even further or deal with electron not working.
There are just too many electron apps. For me Signal, Wavebox, Spotify and VS codium just crash all at once, though Spotify doesn't stop playing and together with VS code have to be killed with -9 or they won't go away.
I also noticed, that the windows seem to be still "there". The workspace stays open and in tabbed mode, the tab with the name is still there, but I'm only seeing the background.

Has somebody found a solution except going back to kernel 4.20 or earlier?
It seems to be connected to notifications, can anybody confirm that? And if so, does switching from dunst to something different help?

What do we all have in common? I'd guess using Manjaro/i3 and electron apps of course.

I had the same problem. Electron Apps crashing randomly and quite often (even every few minutes).
App first freezes (does not react to any input), then after a switch to another screen and back it just does not get rendered (either I can see desktop background or what was there on previous screen), but the container is still there (I can see gap between containers, for example) with some shadow sometimes.
But I switched from kernel 5.1 to 5.2 and problem is gone.
Manjaro 18.04 with i3

You really got my hopes up there :disappointed_relieved:
I'm also using Manjaro with i3 but 5.2 still breaks Electron apps.
I was trying 5.3.rc4 as well but that also doesn't work :upside_down_face:

I'm experiencing the same thing. Chromium and all my electron apps -- e.g. slack, vscode -- seem to lock up at the same time, which is really puzzling because they're separate processes. I have to kill them and restart them. The locking up manifests as the window no longer updating, and if I move another window over the frozen window it "paints" across. I also noticed that the mouse cursor does seem to react to moving across the frozen apps by changing its icon (e.g. into a text input icon when over a text field). I've had this setup for over a year and this issue is relatively new.

Arch Linux, bspwm, kernel 5.2.11, on a Razer blade with proprietary nvidia drivers. This is a real problem for me and any insights are helpful!

Well, same problem here :frowning:

Here's the stack trace from the dump:

#0  0x00007f431e37f75c in ?? () from /snap/core/current/lib64/ld-linux-x86-64.so.2
No symbol table info available.
#1  0x00007f431e388861 in ?? () from /snap/core/current/lib64/ld-linux-x86-64.so.2
No symbol table info available.
#2  0x00007f431e383574 in ?? () from /snap/core/current/lib64/ld-linux-x86-64.so.2
No symbol table info available.
#3  0x00007f431e387db9 in ?? () from /snap/core/current/lib64/ld-linux-x86-64.so.2
No symbol table info available.
#4  0x00007f431dd2ef09 in ?? () from /snap/core/current/lib/x86_64-linux-gnu/libdl.so.2
No symbol table info available.
#5  0x00007f431e383574 in ?? () from /snap/core/current/lib64/ld-linux-x86-64.so.2
No symbol table info available.
#6  0x00007f431dd2f571 in ?? () from /snap/core/current/lib/x86_64-linux-gnu/libdl.so.2
No symbol table info available.
#7  0x00007f431dd2efa1 in dlopen () from /snap/core/current/lib/x86_64-linux-gnu/libdl.so.2
No symbol table info available.
#8  0x000055ba16da9bf7 in ?? ()
No symbol table info available.
#9  0xffffffffffffff00 in ?? ()
No symbol table info available.
#10 0x0000000000000000 in ?? ()
No symbol table info available.

Can confirm that launching electron apps with --disable-gpu works for me. I was having this issue with Slack and Atom. I tested this for about a day with and without the flag.

To test open a terminal window and run:

For Atom

killall electron
atom --disable-gpu

For Slack

killall slack
slack --disable-gpu

For a more permanent fix add the following to your ~/.bashrc

alias atom="atom --disable-gpu"
alias slack="slack --disable-gpu"

Note that dmenu does not pickup shell aliases

In order to use dmenu I created scripts called atom- and slack- which run the same commands. So far this seems like a good fix, I just have to make sure to add the - in dmenu.

I'm currently experiencing this issue with the open-source Intel drivers on a laptop with only Intel HD hardware. Had the same issue on my other laptop, which uses Optimus but was running with only the open-source drivers installed at the time (no bumblebee etc.). Ended up having to run X11 through the framebuffer (i.e. no drivers installed) for other reasons on that machine, but interestingly enough it seemed to solve the issue with Electron apps too. (Would not recommend this as a fix, using the framebuffer is slow and bad)

EDIT: tried the --disable-gpu workaround, works so far so good, just a shame there's not a clean fix...

Yeah I can confirm the --disable-gpu trick works for me. It's a real shame. From your description @rookie1024 it sounds like an intel driver bug?

That's my guess...either that or some kinda driver quirk. Strange that this only affects Chromium...

In Manjaro with Awesomewm (Linux53) I was noticing this happening (electron?). The apps that kept crashing on me were VSCode, Atom and Chromium. I just kept killing them when they crashed. Then today something weird happened. Thunar crashed in the same way that the others were crashing. Why would Thunar crash if it was electron?

I haven't tried the --disable-gpu yet, but glad I found it because this is starting to get frustrating. Hope it works for me.

Forum kindly sponsored by