Enable Autologin in XFCE

Hi,
after the install i selected: ask for password.
Now i want to enable autologin for faster booting. I have not found the icon in XFCE Lightdm-Settings,
nor did work some forums posts here for me.

i did as there was mentoined:
https://wiki.archlinux.org/index.php/LightDM#Enabling_autologin
sudo gedit /etc/lightdm/lightdm.conf

and then un-commenting a few lines to make it look as follows:

[Seat:*]
#type=xlocal
pam-service=lightdm
pam-autologin-service=lightdm-autologin
#pam-greeter-service=lightdm-greeter
#xserver-command=X
#xmir-command=Xmir
#xserver-layout=
#xserver-config=
#xserver-allow-tcp=false
#xserver-share=true
#xserver-hostname=
#xserver-display-number=
#xdmcp-manager=
#xdmcp-port=177
#xdmcp-key=
#unity-compositor-command=unity-system-compositor
#unity-compositor-timeout=60
#greeter-session=example-gtk-gnome
#greeter-hide-users=false
#greeter-allow-guest=true
#greeter-show-manual-login=false
#greeter-show-remote-login=true
user-session=xfce
#allow-user-switching=true
#allow-guest=true
#guest-session=
session-wrapper=/etc/lightdm/Xsession
#greeter-wrapper=
#guest-wrapper=
#display-setup-script=
#display-stopped-script=
#greeter-setup-script=
#session-setup-script=
#session-cleanup-script=
#autologin-guest=false
autologin-user=myuser
autologin-user-timeout=0
#autologin-in-background=false
#autologin-session=
#exit-on-failure=false

groupadd -r autologin

sudo gpasswd -a myuser autologin

any hint?
LF

Ah, i've found it,

i had to disable some lines above, which were not visible in his post: @lerner17

#pam-greeter-service=lightdm-greeter
#greeter-session=lightdm-gtk-greeter

Now its working.
LF

1 Like

By the way, should not be there a checkbox for re-enabling autologin via the settings manager?
LF

lightdm

Or at the session and starting manager?
session and starting

or at managing the user accounts???
user accounts

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by