Enlightenment update

Enlightenment has recently been updated to E20.7 in the mother repository (now already being flagged as out-of-date). As we know from the last posts of the previous forum or may have experienced ourselves, it has a bug regarding startup programs. One option is to downgrade back to E20.5, another is to wait for Arch (can be months), and yet another is to download, compile and install E20.8. Here the problem is gone and if installed correctly, when Arch eventually catches up, it will be normally updated.

  1. You do this entirely at your own risk.
  2. Make sure your system is up to date and backed up - have the latest E (and EFL etc.) from Arch.
  3. Create the following directory structure: ~/Build/E20_8 and go there.
    (You can use Build for other projects as well.)
  4. Download http://download.enlightenment.org/rel/apps/enlightenment/enlightenment-0.20.8.tar.xz to here (inside E20_8).
  5. Extract: tar -xvf enlightenment-0.20.8.tar.xz
  6. This creates further subdirectories: ~/Build/E20_8/enlightenment-0.20.8/pkgbuild - go there.
  7. Edit the file PKGBUILD to remove the dependency 'bluez4' and save.
  8. Do: makepkg -sr
    (This compiles everything, makes installable packages, and can take a while.)
  9. Do: sudo pacman -U enlightenment-0.20.8-1-x86_64.pkg.tar.xz
  10. Reboot and hold thumbs.
1 Like

Thanks @Bertie. It worked. This is the first time using makepkg.

You can combine steps 8&9 by running

makepkg -sri
instead.

'LLo,

Yep, it's better for the clipboard, but imho E is always a bit too capricious for a release..
On the other hand, just for building something else:

& the result in virtual live "buildy" mode, too (work in progress..)

Ps: The last manjaro-tools (unstable) works better & better :slight_smile:

Yes, I knew about makepkg -sri, but just makepkg -sr in this case creates 2 packages for E, the normal one and a debug one. With -sri which one will be installed ? or will I get the opportunity to choose?

Edit: I also like to see the process broken up into recognisable and manageable chuncks, should something go wrong.

That makes sense.

'LLo,

I'm pretty sure it uses the normal one with -sri, but as for simplicity i use makepkg alone & with #option=('debug') in PKGBUILD, i can't say more.
Imho, the important is to save & put the obtained *.pkg.tar.xz in cache if you want to do the same with last & really "bleeding edge" 0.21.0-beta:
http://download.enlightenment.org/rel/apps/enlightenment/enlightenment-0.21.0-beta.tar.xz
(But even with that, it's often not easily downgradable, so "at your own risk") :relaxed:

I wanted to give this a try with the .21 beta but I see that EFL and Elementary have been updated to a newer version than the ones installed: https://www.enlightenment.org/news

The recommendation is to install (update) those packages before installing Enlightenment but the existing header files and libraries for those 2 should be deleted before installing. The tree under "Files" in Octopi is very extensive and I'm not sure what files to delete. Any ideas on what files they are referring to in that post?

Regards

'LLo,

I use them since a couple of day without deleting anything (just makepkg in the pkgbuild folder after extract and pacman -U when it's done) :wink:

Good info - I found that the method used by Bertie worked best as it makes for more options. Elementary had several packages (+test) to choose from so that mind-changing and then installing a different package is trivial and quick. .21 Beta seems meh and not much different from previous - or maybe there really is some headers and library files that should be removed but I don't think so as the normal update process would not normally do that extra work.

It still seems like with all these updates and releases that E17 is the best and will continue to run my desktop. My laptop may go with KDE though as the latest RC is sweet and I can wait out this Gnome thing that has even affected my XFCE experience.

Regards

'LLo,

As always, imho, too many different way of doing the same thing !
"enjoy the simplicity" spirit's guiding me & I always choose the simpliest & working one :wink:
So, with "a bit capricious but as it is" e20-buildy (that's why i love it & play with) that you could find here (sesame=pwd=manjaro), maybe the opposite:
One way of doing different things !
Multiboot & 15 GB partition free needed somewhere on your DD, a manuel install with calamares only (remember, one way..!) & no bootloader at all & once done:
You could easily rebuild (right- click everywhere -> spacefm) the flavour-minimal you want with editing:

  • Packages-Yourflavour for modify software demand (added or commented ones)
  • Packages-Live for installers (optional)
    & a final buildiso -p yourflavour-minimal -q to check & without -q to build !
    When's done (various time according to your machine), you could directly test/install obtained iso in V-box !
    If it works -> "bare metal install" on e20-buildy place (au revoir !)
    & if not -> "Same player build again/Same builder shoot again !"
    I hope you'll love that..!

Ps: For AMD's addicts, I'm intel-centric here & a french manjarian tester was not able to (easilly) play with..?

Fantastic fassil. I installed in VBox and posting from it now. Had to add kb module to switch to US and guess that Sesame=pw (default on live is manjaro of course). The ISO with a little refinement should be good for Community Editions with some more testing. Please continue...

Maybe separate topic and get more installers feedback - I realize there is not a big interest in E here but for me this ISO is looking very good.

Regards

Ok silly forum will not allow me to post more than 3 replies so I will edit instead:imp:

@fassil Build it and they will come!!!

My preference is for a little less transparency so I adjusted the slider with Colors>Objects which do not have focus. It is good that you discovered that 4 years ago and it still works:wink:

SpaceFM opens only as root? I know it is good because EFM has no root option but how does SpaceFM open as a normal user?

Regards

Thanks palo :wink:

For forgotten pwd too !
Now, maybe time to build..!

For SpaceFM as normal user, several ways, but maybe the simpliest:
Rename ~/.local/share/applications/spacefm.desktop in space-fm.desktop -> edit it & delete gksu on exec line, so there'll be two entries in sub-menu system (you can add it in favorites menu too)

O_ops -> doesn't work ! (no more SpaceFM as root, pfuuu)
I try to think about another way...

It did work without a problem. First I had to copy and rename and follow your instruction. Now I have 2: named SpaceFM and SpaceFM(Root):wink:

Regards

Yep, it was working yesterday, but not today -> strange..?

??? Nothing changed for me. Still 2 entries:

Must find a way to make a visual distinction though - maybe a red bg color if possible to tell which is on desktop. A different icon is not enough(borderless mode).

Using the "Show root indicator color" in Preferences makes a red color but the font does not look good against it. Is there anything wrong with the more refined Thunar?

Regards

'LLo,

No Thunar is fine but with xfce all around ! (& this release could also easily be/named xfce-buildy !)
With E, there's some annoying/useless dependancies (i.e exo).
Imho, a root file manager is only needed to make the part "rebuilding something minimal easy as pie" of this release, for a current use it's not necessary.
Have you try to rebuild something ?

Hi @fassil sorry I got a little carried away. My first time using the tool - I chose the kde-minimal for no good reason. At (in)completion I got:

--> Setting mirrorlist branch: stable
Generating locales...
en_US.UTF-8... done
de_DE.UTF-8... done
Generation complete.
-> Copying [root-overlay] ...
==> Configuring [root-image]
-> Configuring lsb-release
-> Configuring logind ...
==> Done configuring [root-image]
--> Restoring [/var/lib/manjaro-tools/buildiso/kde-minimal/x86_64/root-image/et
c/pacman.conf] ...
-> Cleaning [root-image]
==> Done [Base installation] (root-image)
--> Loading Packages: [Packages-Kde] ...
==> Prepare [Desktop installation] (kde-minimal-image)
--> overlayfs mount: [/var/lib/manjaro-tools/buildiso/kde-minimal/x86_64/kde-minimal-image]
--> mirror: http://mirror.netzspielplatz.de/manjaro/packages/stable/$repo/$arch
==> Creating install root at /var/lib/manjaro-tools/buildiso/kde-minimal/x86_64/kde-minimal-image
-> Installing packages to /var/lib/manjaro-tools/buildiso/kde-minimal/x86_64/kde-minimal-image
:: Synchronizing package databases...
core 136.1 KiB 298K/s 00:00 [######################] 100%
extra 1900.5 KiB 1288K/s 00:01 [######################] 100%
community 3.8 MiB 1667K/s 00:02 [######################] 100%
multilib 186.8 KiB 2.40M/s 00:00 [######################] 100%
error: target not found: kcm-msm
==> ERROR: Failed to install packages to new root
==> ERROR: Failed to install all packages
==> ERROR: A failure occurred in make_image_custom().
Aborting...
--> overlayfs umount: [/var/lib/manjaro-tools/buildiso/kde-minimal/x86_64/kde-minimal-image]
[pat@manj-e20-buildy-1606 ~]$

I have a lot to learn about this tool.

Regards

'LLo palo,

Not a lot, there was just kcm-msm (line just before first ERROR) missing in repository, i assume. It's integrated manjaro-settings-manager in kde control panel, i think.
You can comment it (#) in Packages-Kde & do without it !
"Same builder shoot again" :wink:

Forum kindly sponsored by