"enter" key did not work correctly in terminal after install zsh

I've been manjaro for 2 month. It's great but there are two bugs I can't solve.

  1. After I installed zsh, the 'enter' key did not work when I wanted to end my input. I have tried, but couldn't find any problem.
    Details: firstly my keyboard works good at any other applications. Secondly after installed zsh my 'enter' didn't work when I wanted to end my input. But it works when I change to tty not x11. And it work when I unlock my num keyboard. I have 3 computers everyone suffering with this bug.
  2. My touchpad didn't work when I unlock my screen. But it work if I set it not to lock my screen after sleep. I think it maybe something wrong with my x but I don't know any knowledge of it. This one I think is hard to fix. I appreciate anyone thinking this for me.
    That is all.
    Thanks for every reply for me!

this is my computer:

  Host: rick-laptop2018 Kernel: 4.14.57-1-MANJARO x86_64 bits: 64 
  compiler: gcc v: 8.1.1 Desktop: Xfce 4.12.4 Distro: Manjaro Linux 
  Type: Laptop Mobo: AMI model: Aptio CRB serial: <root required> 
  UEFI: American Megatrends v: ZB-BI-14-S133AR110-034-A date: 03/13/2018 
  ID-1: BAT0 charge: 48.0 Wh condition: 48.0/N/A Wh 
  model: Intel SR 1 SR Real Battery status: Charging 
  Topology: Quad Core model: Intel Celeron N3450 bits: 64 type: MCP 
  arch: N/A L2 cache: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 8756 
  Speed: 1713 MHz min/max: 800/2200 MHz Core speeds (MHz): 1: 1713 2: 1865 
  3: 1637 4: 1585 
  Card-1: Intel driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.19.6 driver: intel unloaded: modesetting 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 500 (Broxton 2x6) 
  v: 4.5 Mesa 18.1.4 direct render: Yes 
  Card-1: Intel Celeron N3350/Pentium N4200/Atom E3900 Series Audio Cluster 
  driver: snd_hda_intel v: kernel bus ID: 00:0e.0 
  Card-2: lihappe8 USB 2.0 Camera type: USB driver: uvcvideo,snd-usb-audio 
  bus ID: 1:5 
  Sound Server: ALSA v: k4.14.57-1-MANJARO 
  Card-1: Intel Wireless 3165 driver: iwlwifi v: kernel bus ID: 01:00 
  IF: wlp1s0 state: up mac: f8:63:3f:d7:dd:8b 
  Local Storage: total: 119.24 GiB used: 22.94 GiB (19.2%) 
  ID-1: /dev/sda model: NT-128 size: 119.24 GiB 
  ID-1: / size: 107.92 GiB used: 22.94 GiB (21.3%) fs: ext4 dev: /dev/sda2 
  ID-2: swap-1 size: 8.80 GiB used: 8 KiB (0.0%) fs: swap dev: /dev/sda3 
  System Temperatures: cpu: 52.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 195 Uptime: 1d 34m Memory: 5.66 GiB used: 3.34 GiB (59.1%) 
  Init: systemd Compilers: gcc: 8.1.1 clang: 6.0.1 Shell: zsh v: 5.5.1 
  inxi: 3.0.18 

I understand you have an issue with your terminal emulator. Which app do you use? Can you check for keybinding related settings or profiles in the app's settings? Did you try another emulator app?
You may want to read about keybindings setup/customizing in zsh.

You need to search for errors or any related message in /var/log/Xorg.0.log and in your journal (i.e. journalctl -b), you can use TTY for this.
Check this general troubleshooting tutorial.
Also Search

I don't use zsh

This is an old kernel version.
Please update your system and reboot:
sudo pacman-mirrors -f3 && sudo pacman -Syyu
sudo reboot

Maybe it fixes it...

Thanks for your reply. But it did not work at all.
I update to 4.14.60 just now.

Thank you a lot!!
I fixed it use bindkey.
I guess maybe there is some mistake with my 'Enter' status or keymap. In terminal emulator it may think I'm using num keyboard 'Enter', but it locked.
So I try use :

bindkey -s "^[OM" "^M"

Luckily, it works!

And I'm still trying to solve my Touchpad problem.
I find

10:02:32 rick-laptop2018 kernel: i2c_hid i2c-SYNA3602:00: i2c_hid_get_input: incomplete report (27/1286)

in my journal log and

Failed to load module "fbdev" (module does not exist, 0)

frame buffer devices fail.
But I don't know how to do with it.
Sorry I'm just a fresher at computer science.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by