Epson EPL 6200L via USB not detected

Thanks Samiul, I followed everything step by step but I got nothing. I like his videos too.

Thanks steanne, I splitted the line like the rest of the document:

*% COMDATA # example of a very long line I have 
*% COMDATA # splitted like this

I've tried many times, some of them I could use the original PPD file without the splitted line.

I convinced a friend (with a lot of experience on Linux) to help me.
After several hours trying, he got nothing.

On Windows it takes a minute to make it work.
On KDE Neon this is what I did ...

  1. I add the printer and select the PPD file
  2. I install the file epsoneplijs-0.4.1.deb
    Nothing else was necessary. It works this way.

Based on this I looked for this file and found epsoneplijs-0.4.1.tgz
I followed the README instructions...

sudo make install

After "make" ir returns...
make: Nothing to be done for 'all'
After sudo make install it returns
/usr/bin/install -c ijs_server_epsonepl -c /usr/local/bin/ijs_server_epsonepl

I have no idea what else I could try.

Bus 002 Device 005: ID 04b8:083f Seiko Epson Corp. PX-A620 [Stylus CX3900/DX4000/DX4050]
idProduct=083f (your will be diff)
sudo nano /etc/udev/rules.d/10-usbprinter.rules
ATTR{idVendor}=="04b8", ATTR{idProduct}=="083f", MODE:="0660", GROUP:="lp"
Then http://localhost:631/
Add printer

It took me a little to understand this post. I know very little about Linux.

lsusb in my case shows:
Bus 001 Device 005: ID 04b8:0005 Seiko Epson Corp. Printer

I've created this file (/etc/udev/rules.d/10-usbprinter.rules) with this text:
ATTR{idVendor}==“04b8”, ATTR{idProduct}==“0005”, MODE:=“0660”, GROUP:=“lp”

I reinstalled the printer and the result is the same:
**Filter failed**

If there's a driver for Debian distros how can't there be one for arch distros?
I abandoned KDE Neon because I didn't like the chaos of DEB files, so many ones for different subversions. I think the use of PPAs is another big chaos.
Then I found Manjaro and I really love it. Installations are really great.
That's very important for me because I use more than 60 different programs.
Now I can't use my printer. Where can I go? What other distro could I use?
I'm really trying to abandon Windows but it's very hard.

aur/epson-inkjet-printer-escpr 1.6.22-1 (+129 2.18%)
Epson Inkjet Printer Driver (ESC/P-R) for Linux
This is the driver you need its in AUR been their all the time, also the driver is in gutenprint, What you have done is totally messed up printing, For KDE you should install print-manager also make sure you install the optional dep for it.
Not the same printer after I installed the driver rebooted automagicaly the printer was installed the way it should prints fine no need to play with permissions this is 2018.

Please, read this tutorial about how to properly format file/terminal output, to be readable and repair your posts.
I guess you can notice the awkward formatting.. :crazy_face:

1 Like

You're 100% right. My mistake.

Thanks a lot but I can't install it.

I opened a Konsole and wrote:
yaourt -S epson-inkjet-printer-escpr

It returns this:
Failure while downloading

and finally:
Makepkg was unable to build epson-inkjet-printer-escpr.

Maybe the solution is to edit the PKGBUILD.
I've never done anything like that and I don't think I should because I'm a newbie about Linux and I'm worried to break something.
Most of the time I don't know exactly what I'm doing when I write something on the konsole.

I've seen that there's another aur called epson-inkjet-printer-escpr2.
I installed it (no problem with this one) and the result is the same: Filter failed.

sudo systemctl stop org.cups.cupsd.service

sudo systemctl disable org.cups.cupsd.service

sudo pacman -Rsn manjaro-printer

sudo pacman -S gutenprint

sudo pacman -S cups cups-filters cups-pdf cups-pk-helper system-config-printer

sudo systemctl daemon-reload

sudo systemctl enable org.cups.cupsd.service

sudo systemctl start org.cups.cupsd.service

sign in has root
Add printer

I've followed that ... step by step very carefully ... using a clean installation of the system Manjaro KDE.
I'm afraid the result when I try to print was the same "Filter failed". Before that, no error message.
Yesterday I could install the scanner Epson Perfection 1670 and it took me only 5 minutes.
I have spent countless hours trying to install this printer and I'm unable to do it. I don't know the reason.
I can install and use it on Windows and on KDE Neon but not on Manjaro KDE.
I'm about to give up.
I'm really grateful for all your support. Thank you everybody very, very much.

In my own experience cups is really awful. Had some troubles with a brother printer. Try manjaro printer manager or install system-config-printer.

Had no luck with cups interface and a network printer. Installed drivers and run system-config-printer. Printer worked immediately

are you sure escpr2 is the correct driver?

also if I download PKGBUILD of escpr, source points to version 1.6.23 (not .22) ?


1.6.23 can be downloaded without error


to install:
first, uninstall/remove whatever you have previously installed regarding the printer
second, drop all aur helpers, you dont need them (they're nonsense and not needed)

cd ~
mkdir AUR
tar xvf epson-inkjet-printer-escpr.tar.gz
cd epson-inkjet-printer-escpr
makepkg -srci

vetzki, I've tried what you've said.
No error messages in the process.
Then I tried to print ... and it happened the same ... "FILTER FAILED".

I have bought a new printer. It arrives tomorrow.
If this new printer works with Manjaro I'll give the old printer to my nephew (he has Windows 10) and forget everything about it because now it's almost a nightmare.

As I always say ... THANK YOU ALL !!

you can try to check /var/log/cups/error_log to see which filter fails.

also arch wiki has some tips regarding that issue

Unlike other Manjaro editions, the default install of Manjaro KDE does not include manjaro-printer (I don't know why). This package uses Gutenprint to install printer drivers. Different make & model, but my Canon MG5750 works without needing any additional driver packages, once I've installed manjaro-printer and added my printer in Print Settings.

(Thread renamed from "Install printer (I've tried everything)" to "Epson EPL 6200L via USB not detected" to make the issue clear)

Much better and clear the name you've chosen.

I have received the printer I bought (Brother HL-L2350DW).
It took me more than an hour to install it and succeed printing but I finally got it.
The only way I could get it was with the CUPS http application.
Now, my doubt is what I should do with this post, because I haven't solved my original problem but I don't need it to be solved anymore. I won't buy an Epson again.

One last time, thank you everybody for all your wonderful support. I hope I can do the same for somebody soon. That would mean my Linux level is good.
Now, I made a huge list of things I had to know before I could jump from Windows to Linux and I'm almost there. Very, very close!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by