Epson L3101 Printer Scanner AIO Not Working

I just bought an Epson L3101 PrinterScanner AIO, but it's not working on Manjaro. I tried to get it working on Ubuntu on my brother's laptop and it worked there. But it's not working on Manjaro. I have tried Skanlite, but instead of detecting the scanner it detects my Webcam. I tried Epson Image Scan For Linux but it does not recognize my L3101 and tells to check the status. The moment I plug in the printer, KDE detects it but can't find any drivers for my printer. I downloaded the drivers for my AIO from Epson's website and manually configured the printer using PPD file provided in the tarball, but it says that Idle- 'File "/usr/lib/cups/filter/epson-escpr-wrapper" not available: No such file or directory'. Please help me. Here's my Manjaro system info for reference.

inxi -Fx
  Host: distroHopper Kernel: 5.6.19-2-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 10.1.0 Desktop: KDE Plasma 5.19.3 Distro: Manjaro Linux 
  Type: Laptop System: ASUSTeK product: X555LA v: 1.0 
  serial: <root required> 
  Mobo: ASUSTeK model: X555LA v: 1.0 serial: <root required> 
  UEFI: American Megatrends v: X555LA.310 date: 04/10/2015 
  ID-1: BAT0 charge: 12.4 Wh condition: 17.5/37.3 Wh (47%) 
  model: ASUSTeK X555-50 status: Charging 
  Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard K230 
  charge: 100% (should be ignored) status: Discharging 
  Device-2: hidpp_battery_1 model: Logitech Wireless Mouse 
  charge: 55% (should be ignored) status: Discharging 
  Topology: Dual Core model: Intel Core i3-4030U bits: 64 type: MT MCP 
  arch: Haswell rev: 1 L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 15171 
  Speed: 1599 MHz min/max: 800/1800 MHz Core speeds (MHz): 1: 798 2: 798 
  3: 798 4: 798 
  Device-1: Intel Haswell-ULT Integrated Graphics vendor: ASUSTeK 
  driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.20.8 driver: intel unloaded: modesetting 
  resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2) 
  v: 4.5 Mesa 20.1.3 direct render: Yes 
  Device-1: Intel Haswell-ULT HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 00:03.0 
  Device-2: Intel 8 Series HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k5.6.19-2-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8169 v: kernel port: e000 bus ID: 02:00.0 
  IF: enp2s0 state: down mac: 14:dd:a9:20:c3:a5 
  Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter 
  vendor: Lite-On driver: ath9k v: kernel port: e000 bus ID: 03:00.0 
  IF: wlp3s0 state: up mac: ac:b5:7d:8d:8b:da 
  Local Storage: total: 238.47 GiB used: 94.89 GiB (39.8%) 
  ID-1: /dev/sda vendor: Intel model: SSDSC2KW256G8 size: 238.47 GiB 
  ID-1: / size: 50.00 GiB used: 15.68 GiB (31.4%) fs: btrfs dev: /dev/sda2 
  ID-2: /home size: 179.99 GiB used: 79.20 GiB (44.0%) fs: btrfs 
  dev: /dev/sda4 
  ID-3: swap-1 size: 8.00 GiB used: 10.8 MiB (0.1%) fs: swap dev: /dev/sda3 
  System Temperatures: cpu: 46.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 2800 
  Processes: 232 Uptime: 32m Memory: 3.73 GiB used: 1.80 GiB (48.2%) 
  Init: systemd Compilers: gcc: 10.1.0 clang: 10.0.0 Shell: bash v: 5.0.18 
  inxi: 3.0.37 

This is the driver install it from AUR epson-inkjet-printer-escpr its need to be built, enable AUR in pamac 1st. Works just fine builds fine. scanner should work with skanlite just make sure its showing your scanner when it opens it show 3 different models for me mine being the last one.

I checked it now in the AUR, saw the supported printers in the list and it includes mine. I installed it and now it's working. Scanning is also working using XSane. But Epson's own utility, Epson Image Scanning For Linux(iscan) is not working.

Yes imagescan has not worked for a while unfortunatly

Skanlite which came with Manjaro KDE by default, is also not working.

Skanlite is working totally fine with Ubuntu-20.04 LTS by the way.

well works fine here


What do you mean where on my computor where else did you install the extra deps or just install blind ?
Did you read the Arch wiki? skanlite, xsane, simplescan, all work

Forum kindly sponsored by