error: disk hd0,gpt2 not found on Windows booting

Hello,

I recently install Manjaro alongside with Windows 10.
First I install the Manjaro and after the Windows. After that I fix grub-efi via chroot.

Booting to Manjaro works fine, but when I try to boot to Windows 10 in grub it getting errors:
error: no such device: 4612-EJ7F.
error: disk 'hd0,gpt2' not found.

How to fix that? Is it need to change some config files like changing device name?

can you return

sudo fdisk -l
sudo efibootmgr -v

have you created /boot/efi ?

sudo fdisk -l


Disk /dev/sdb: 22,4 GiB, 24015495168 bytes, 46905264 sectors
Disk model: KINGSTON RBU-SMS
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xfb24c946

Device     Boot   Start      End  Sectors  Size Id Type
/dev/sdb1          2048  1640447  1638400  800M 83 Linux
/dev/sdb2  *    1640448  2254847   614400  300M ef EFI (FAT-12/16/32)
/dev/sdb3       2254848 46905263 44650416 21,3G 83 Linux


Disk /dev/sda: 465,8 GiB, 500107862016 bytes, 976773168 sectors
Disk model: HGST HTS545050A7
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 81C7DA45-32C3-4DB9-8EAE-3AD073172726

Device         Start       End   Sectors   Size Type
/dev/sda1       2048   1023999   1021952   499M Windows recovery environment
/dev/sda2    1024000   1228799    204800   100M EFI System
/dev/sda3    1228800   1261567     32768    16M Microsoft reserved
/dev/sda4    1261568 206061567 204800000  97,7G Microsoft basic data
/dev/sda5  206061568 218349567  12288000   5,9G Linux filesystem
/dev/sda6  218349568 284770303  66420736  31,7G Linux filesystem
/dev/sda7  284770304 939909119 655138816 312,4G Linux filesystem
/dev/sda8  939909120 976773119  36864000  17,6G Linux filesystem

Manjaro root on /dev/sdb3
Windows on /dev/sda (sda1-sda4)

sudo efibootmgr -v

BootCurrent: 0001
Timeout: 2 seconds
BootOrder: 0001,0000,0005,000C,000D,000E,0002,0003,0004
Boot0000* Windows Boot Manager  HD(2,GPT,09b39e58-11ff-49f4-8ab5-73c1aa4e4e2f,0xfa000,0x32000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot0001* manjaro       HD(2,MBR,0xfb24c946,0x190800,0x96000)/File(\EFI\MANJARO\GRUBX64.EFI)
Boot0002* UEFI:CD/DVD Drive     BBS(129,,0x0)
Boot0003* UEFI:Removable Device BBS(130,,0x0)
Boot0004* UEFI:Network Device   BBS(131,,0x0)
Boot0005* opensuse-secureboot   HD(2,MBR,0xfb24c946,0x190800,0x96000)/File(\EFI\OPENSUSE\SHIM.EFI)
Boot000C* opensuse      HD(2,MBR,0xfb24c946,0x190800,0x96000)/File(\EFI\OPENSUSE\GRUBX64.EFI)..BO
Boot000D* UEFI OS       HD(2,MBR,0xfb24c946,0x190800,0x96000)/File(\EFI\BOOT\BOOTX64.EFI)..BO
Boot000E* UEFI: JetFlashTranscend 8GB 1100      PciRoot(0x0)/Pci(0x14,0x0)/USB(13,0)/HD(1,MBR,0x0,0x3e78a0,0x2000)..BO

The OpenSuse stayed for some reason from previous Linux instalation. Similary with "JetFlashTranscend" - I Don't know how to remove this from efi.

have you created /boot/efi ?
Yes, efi on /dev/sdb2, boot on /dev/sdb1 (btrfs).

You can delete those with efibootmgr -b 0005 -B e.g..

can you also return

inxi -Fxxxz
lsbk -fs

inxi -Fxxxz

...
Drives:
  Local Storage: total: 488.13 GiB used: 310.10 GiB (63.5%) 
  ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS545050A7E680 size: 465.76 GiB 
  speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: A3B0 scheme: GPT 
  ID-2: /dev/sdb vendor: Kingston model: RBU-SMSM151S324GD size: 22.37 GiB 
  speed: 6.0 Gb/s serial: <filter> rev: 01B9 scheme: MBR 
Partition:
  ID-1: / size: 20.83 GiB used: 8.17 GiB (39.2%) fs: ext4 dev: /dev/sdb3 
  ID-2: /boot size: 800.0 MiB used: 69.4 MiB (8.7%) fs: btrfs dev: /dev/sdb1 
  ID-3: /home size: 31.05 GiB used: 17.81 GiB (57.4%) fs: ext4 dev: /dev/dm-0 
  ID-4: /var size: 5.70 GiB used: 2.65 GiB (46.5%) fs: ext4 dev: /dev/sda5 
Sensors:
...

lsbk -fs

NAME    FSTYPE    LABEL    UUID                                 FSAVAIL FSUSE% MOUNTPOINT
sda1    ntfs      Recovery 3AB8F8F0B8F8AC0F                                    
└─sda                                                                          
sda2    vfat               4612-EJ7F                                           
└─sda                                                                          
sda3                                                                           
└─sda                                                                          
sda4    ntfs               3EE80CA8E80C610F                                    
└─sda                                                                          
sda5    ext4               181972ef-16ec-4e36-8c72-7e85e000f724    2,8G    47% /var
└─sda                                                                          
sda7    ext4               5e98bbfc-f59b-4017-af1e-09a2ebb92d67    9,5G    92% /media/DAT
└─sda                                                                          
sda8    ext4      home     1dec941e-a295-4368-be28-acef6ed715bf                
└─sda                                                                          
sdb1    btrfs              b67c6996-152a-4839-9250-49625e48ebd5  654,1M     9% /boot
└─sdb                                                                          
sdb2    vfat               477E-B213                             299,4M     0% /boot/efi
└─sdb                                                                          
sdb3    ext4               ba82cff4-f81d-4b32-8b8a-fc8f9588e923   11,6G    39% /
└─sdb                                                                          
luks-7631e158-9451-4f6c-bdc0-ed1adf0c6e30
│       ext4               2a03a3c7-28f9-45df-a1dc-eb76089cd1b9   11,7G    57% /home
└─sda6  crypto_LU          7631e158-9451-4f6c-bdc0-ed1adf0c6e30                
  └─sda  

Check in addition whether secure boot ist enabled in Windows.

open a terminal

manjaro-chroot -a ( select 1 if one line )
ls -la /boot/efi ( check ok )
efibootmgr -v ( check efi ok )
grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck
efibootmgr -c -d /dev/sda -p 2 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"
update-grub
exit ( leave chroot , have to be done always with chroot )

I can boot in Manjaro, it's Ok, the command

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck

already was done when I repair grub after Windows installation.

Now I can't boot in Windows, for some reason errors occur. Seems Windows efi not determined or incorrectly determined.

Also Windows starting successfully when I install it after Manjaro, the errors on Windows booting apped after grub reinstallation.

Just checked, secure boot is disabled.
When I enable it, grub not starting, but Windows booting.

Please post

findmnt -s
cat /etc/fstab
lsblk -f

:laughing:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by