Error: Failed to add a new Printer

Hi everyone,

I have two printers 1.: Samsung ML 2010 and 2.:Epson Stylus SX125. Both connected via USB. I have a minimal installation of Manjaro Gnome from the Architect Iso. Normally I followed the instructions here: https://wiki.manjaro.org/index.php?title=Printing and then went into Settings and hit the "add" Button.

When I got to Settings -> Printers -> Add A Printer both printers show up with the correct name but when I hit add I just get a message "Failed to add new printer".

I am looking forward for recommendations how to solve this, thanks.

I had the same problem but with different printer, a Canon MP 280.

same here, canon ix6500 :confused:

Just wanted everyone to know that I dealed with this problem by opening http://localhost:631/printers/ and adding the printers manually. For the Epson there was no fitting driver so I choose the one for SX100 which works and for the Samsung there was even a fitting driver.

I would however prefer if the OS option in settings actually works.

Had the same problem with epson. I installed the package epson-escpr as indicated here http://www.openprinting.org/printer/Epson/Epson-WF-2650_Series and the driver showed up in the CUPS page on http://localhost:631.

Hi again! I just wanted to let you know I figured out why I had the issue that the printers could not be configured automatically.

When I installed Manjaro I choose "minimal installation" so only the most basic packages are installed on my system by default. But to automatically find the correct driver for the printer (if there is one) you not only need to install the package manjaro-printer for general printer support, but also the optional dependency package "system-config-printer". After I followed the instructions to install printing support I installed the optional dependency "system-config-printer" in the "Add/Remove Software" program and I was able to just hit the "add printer" button and everything worked like a charm.

2 Likes

This topic was automatically closed after 90 days. New replies are no longer allowed.

Forum kindly sponsored by