Error in instalation

Just receive this error while formating my manjaro KDE

Command 'grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Manjaro --force' returned non-zero exit status 1.
Installing for x86_64-efi platform. grub-install: error: /boot/efi doesn't look like an EFI partition.

File "/usr/lib/calamares/modules/bootloader/", line 444, in run

  File "/usr/lib/calamares/modules/bootloader/", line 411, in prepare_bootloader
    install_grub(efi_directory, fw_type)

  File "/usr/lib/calamares/modules/bootloader/", line 285, in install_grub

  File "<string>", line 5, in <module>

That should give you a clue. If you are on a UEFI system your HDD/SSD has to have GPT partition table and the EFI partition has to be marked as /boot/efi ESP.
IF you are on a Legacy BIOS machine, MBR partition table and the boot has to be as /boot ...

Please have a look at

If you prefer that someone will help out, provide from terminal (while in the Live Install Manjaro media)
inxi -Fxxxz
lsblk -f
Use ``` above and bellow that text when you paste it here.

1 Like

Already did that anda still same situation

That's not my case

Next time i'll do that

You're sure the flag ESP is set on the partition?

1 Like

Yep, set the /boot/efi with boot label and esp

Never mind, let's sort all this out. See this first post here.
Start up install media in uefi.
When booted to installed manjaro, at its terminal, provide

efibootmgr -v
sudo parted -l
sudo blkid
findmnt -s
findmnt /boot/efi

Try the [Simple First Start] first, if unable use [More Complicated Setups].

You said "Just receive this error while formating my manjaro KDE"
Formatting? Or when installing? I think you tried to get installer to set up a $esp partition and it failed. We'll see if you have one.

[manjaro@manjaro ~]$ sudo grub-install /dev/sbd
Instalando para a plataforma x86_64-efi.
grub-install: erro: cannot find EFI directory.

[manjaro@manjaro ~]$ efibootmgr -v
BootCurrent: 0004
Timeout: 1 seconds
BootOrder: 0003,0000,0004,0001
Boot0000* Pop!_OS 18.10 HD(1,GPT,6500b9c8-45d8-4aba-9006-221090c4621c,0x800,0xf9fff)/File(\EFI\systemd\systemd-bootx64.efi)
Boot0001* Hard Drive    BBS(HD,,0x0)AMGOAMNO........m.S.T.>..Gd-.;.A..MQ..L. . . . . . . . . . . . .1.S.A.D.Y.J.4.X......AMBOAMNO........m.S.a.n.D.i.s.k. .S.D.S.S.D.A.2.4.0.G....................A.........................>..Gd-.;.A..MQ..L. . . . . . . . ......AMBOAMNO........i.L.e.x.a.r. .J.u.m.p.D.r.i.v.e. .;.A..MQ..L.A.A.J.P.P.8.O.5.4.R.A.T.A.Q.R.N......AMBO
Boot0003* Manjaro       HD(1,GPT,6500b9c8-45d8-4aba-9006-221090c4621c,0x800,0xf9fff)/File(\EFI\Manjaro\grubx64.efi)
Boot0004* UEFI: Lexar JumpDrive 1100    HD(1,MBR,0x0,0x3e78a0,0x2000)/File(\EFI\BOOT\BOOTX64.EFI)AMBO
[manjaro@manjaro ~]$ sudo parted -l
Modelo: ATA ST1000DM003-1CH1 (scsi)
Disco /dev/sda: 1000GB
Tamanho do setor (lógico/físico): 512B/4096B
Tabela de partições: gpt
Opções de disco: 

Número  Início  Fim     Tamanho  Sistema de arquivos  Nome  Opções
 1      1049kB  1000GB  1000GB   ext4

Modelo: ATA SanDisk SDSSDA24 (scsi)
Disco /dev/sdb: 240GB
Tamanho do setor (lógico/físico): 512B/512B
Tabela de partições: gpt
Opções de disco: 

Número  Início  Fim     Tamanho  Sistema de arquivos  Nome  Opções
 1      1049kB  525MB   524MB    ext4
 2      525MB   95,0GB  94,5GB   linux-swap(v1)
 3      95,0GB  240GB   145GB    ext4

Modelo: Lexar JumpDrive (scsi)
Disco /dev/sdc: 3951MB
Tamanho do setor (lógico/físico): 512B/512B
Tabela de partições: msdos
Opções de disco: 

Número  Início  Fim     Tamanho  Tipo     Sistema de arquivos  Opções
 2      2096MB  2100MB  4194kB   primary                       esp

[manjaro@manjaro ~]$ sudo blkid
/dev/loop0: TYPE="squashfs"
/dev/loop1: TYPE="squashfs"
/dev/loop2: TYPE="squashfs"
/dev/loop3: TYPE="squashfs"
/dev/sda1: UUID="49d79bf6-4726-4439-99ed-4da3aa1a72b5" TYPE="ext4" PARTUUID="8d66a15a-e9d6-4852-b85a-712802a182ef"
/dev/sdb1: UUID="850f6ebf-3f34-44a8-b44e-5ab9b2845fa8" TYPE="ext4" PARTUUID="a46e1d2d-f3b7-4ae9-be4b-230e24030b18"
/dev/sdb2: UUID="adcb00e1-397e-4a4e-a980-84ff3c2a4c92" TYPE="swap" PARTUUID="804a68ed-fa5a-4cd0-a825-12b171937c93"
/dev/sdb3: UUID="db2b5dd6-6df6-46c0-9ab1-a7b49be003b3" TYPE="ext4" PARTUUID="5adc69db-3619-4454-a786-d0f292c9d573"
/dev/sdc1: UUID="2019-03-12-09-50-33-00" LABEL="M1804" TYPE="iso9660"
[manjaro@manjaro ~]$ findmnt -s
/      /dev/mapper/root-image auto   defaults
[manjaro@manjaro ~]$ findmnt /boot/efi
[manjaro@manjaro ~]$ 

[manjaro@manjaro ~]$ inxi -Fxxxz
  Host: manjaro Kernel: 4.19.28-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: KDE Plasma 5.15.2 tk: Qt 5.12.1 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Desktop System: Gigabyte product: N/A v: N/A serial: <filter> 
  Chassis: type: 3 serial: <filter> 
  Mobo: Gigabyte model: H61M-S1 v: x.x serial: <filter> 
  UEFI: American Megatrends v: F4 date: 09/30/2014 
  Topology: Quad Core model: Intel Core i5-3570 bits: 64 type: MCP 
  arch: Ivy Bridge rev: 9 L2 cache: 6144 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 27147 
  Speed: 3721 MHz min/max: 1600/3800 MHz Core speeds (MHz): 1: 3425 
  2: 3579 3: 3265 4: 3452 
  Device-1: NVIDIA GP104 [GeForce GTX 1070] vendor: 
  driver: nvidia v: 418.43 bus ID: 01:00.0 chip ID: 10de:1b81 
  Display: x11 server: X.Org 1.20.4 driver: nvidia compositor: kwin_x11 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: GeForce GTX 1070/PCIe/SSE2 v: 4.6.0 NVIDIA 418.43 
  direct render: Yes 
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio 
  vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:1c20 
  Device-2: NVIDIA GP104 High Definition Audio vendor: 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:10f0 
  Device-3: SteelSeries ApS type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-1.1:3 
  chip ID: 1038:1211 serial: <filter> 
  Sound Server: ALSA v: k4.19.28-1-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Gigabyte driver: r8169 v: kernel port: d000 bus ID: 03:00.0 
  chip ID: 10ec:8168 
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Local Storage: total: 1.13 TiB used: 1.43 GiB (0.1%) 
  ID-1: /dev/sda vendor: Seagate model: ST1000DM003-1CH162 
  size: 931.51 GiB speed: 3.0 Gb/s rotation: 7200 rpm serial: <filter> 
  rev: CC46 scheme: GPT 
  ID-2: /dev/sdb vendor: SanDisk model: SDSSDA240G size: 223.57 GiB 
  speed: 3.0 Gb/s serial: <filter> rev: 80RL scheme: GPT 
  ID-3: /dev/sdc type: USB vendor: Lexar model: JumpDrive size: 3.68 GiB 
  serial: <filter> rev: 1100 scheme: MBR 
  ID-1: / size: 5.82 GiB used: 487.2 MiB (8.2%) fs: overlay 
  source: ERR-102 
  System Temperatures: cpu: 52.0 C mobo: N/A gpu: nvidia temp: 50 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
  Processes: 185 Uptime: 6m Memory: 7.76 GiB used: 1.44 GiB (18.6%) 
  Init: systemd v: 241 Compilers: gcc: 8.2.1 Shell: bash v: 5.0.0 
  running in: konsole inxi: 3.0.32 
[manjaro@manjaro ~]$ lsblk -f
     squash                                                  0   100% /run/miso/
     squash                                                  0   100% /run/miso/
     squash                                                  0   100% /run/miso/
     squash                                                           /tmp/tmpwl
     ext4         49d79bf6-4726-4439-99ed-4da3aa1a72b5                
│    vfat         C781-B828                             299,4M     0% /tmp/calam
│    ext4         624316d3-89df-4ba9-84cb-d66af84eb4ab  198,2G     1% /tmp/calam
     swap         36016f64-cd71-4d86-9380-d9fb90aa017e                
sdc  iso966 M1804 2019-03-12-09-50-33-00                              
│    iso966 M1804 2019-03-12-09-50-33-00                     0   100% /run/miso/
     vfat   MISO_EFI
[manjaro@manjaro ~]$ 

That means you are not booted in uefi or that you do not have a /boot/efi, more the latter.
Oh.. yes, you do not have /boot/efi.

[manjaro@manjaro ~]$ findmnt /boot/efi
[manjaro@manjaro ~]$ 

Now put an entry of /boot/efi into fstab, then mount that partition to /boot/efi and do the same grub-install command again.
That should fix it. Just make sure you always boot in uefi mode, it is important (I think you are in uefi mode now; but make sure it is always in uefi mode)

How can i do that?

Ah... your partuuid 6500b9c8-45d8-4aba-9006-221090c4621c that is in manjaro efiboormgr but not listed anywhere in blikd. Where is this? it is the first partition of some disk and that disk is missing. Note partuuid will never change even if formatted. I may be deleted.

Currently you do not have any partition in fat32.

I suggest you reinstall. Probably easiest for you. Before installation make a partition in 150 MB size in fat 32 format. Then at installation, select that partition as $esp and mount as /boot/efi (in addition to a root partition in ext4)

Remember you must have a fat 32 partition. If you have one, we can proceed. You do not have any. That's why your installation failed. Reminder, always boot anything in uefi, including the install media for installation.

Another thing is that in my boot menu pop os option still avaliable, that can be causing the problem?

That worked, i leaved the /boot/efi as fat32 and it worked. Thank you!

Your pop OS? I don't see any partition for it I don't see any other disk in your parted -l. I don't see any fat32 partition. Did you remove that drive? Is pop OS working? 'parted 'l ' command must contain all information, all drives otherwise we read wrong things into it.
If there is another disk containing pop OS, 'pop' it in and provide new data of blkid, parted -l and efibootmgr. Perhaps that manjaro $esp is in there and I don't know. What I don't know, I cannot help. If it is disk, is that removable? Is that removed now? If removed, that won't work without an additional command. But anyway, there is no fstab entry for /boot/efi in ytour manjaro is there?
Is your pop OS in msdos/bios-legacy? I don't see a efibootentry for it.

See, that's a lot to write. It's not nice to me. Lucky for you it is not morning time for me.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by