Error in pacman -Syyu

Did you try install libreoffice-still again?

@AgentS Nope.Still not able to install libre office. I have downloaded .rpm package of libre office is there any way I can install libre office through that? Please help me out. I amnot able to install open office also. Same error is thrown by that also.

Is it only libreoffice that you cannot install or any package?
Did you try install some other app/package?

Edit: you can always download and install the package locally from manjaro repos or arch repos. Installing from rpm, deb, or source is not recommended.
http://repo.manjaro.org.uk/stable/extra/x86_64/?C=N;O=A

Have you followed this step from archwiki?

Make sure to correct the time, for example with ntpd -qg run as root, and run hwclock -w as root before subsequent installations or upgrades.

I can guess wrong system time is the reason you can't import that signature.

1 Like

I triple the bet for the time as the reason of the problem.
Who pays! :grin:

1 Like

I am still getting same error. I have no idea how to install libre office or open office. Whatever you have asked me to do, I have tried everything. Still no remedy.

➜ ~ sudo ntpd -qg
2 Aug 19:59:17 ntpd[2600]: ntpd 4.2.8p8@1.3265-o Sat Jun 4 14:58:28 UTC 2016 (1): Starting
2 Aug 19:59:17 ntpd[2600]: Command line: ntpd -qg
2 Aug 19:59:17 ntpd[2600]: proto: precision = 0.558 usec (-21)
2 Aug 19:59:17 ntpd[2600]: unable to bind to wildcard address :: - another process may be running - EXITING

Then I stopped the service and started again

# systemctl stop ntpd
# ntpd -qgd

➜ ~ sudo ntpd -qgd
2 Aug 20:04:14 ntpd[2911]: ntpd 4.2.8p8@1.3265-o Sat Jun 4 14:58:28 UTC 2016 (1): Starting
2 Aug 20:04:14 ntpd[2911]: Command line: ntpd -qgd
2 Aug 20:04:14 ntpd[2911]: proto: precision = 0.489 usec (-21)
Finished Parsing!!
restrict: op 1 addr 0.0.0.0 mask 0.0.0.0 mflags 00000000 flags 000005f0
restrict: op 1 addr :: mask :: mflags 00000000 flags 000005f0
restrict: op 1 addr 127.0.0.1 mask 255.255.255.255 mflags 00000000 flags 00000000
restrict: op 1 addr ::1 mask ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff mflags 00000000 flags 00000000
move_fd: estimated max descriptors: 1024, initial socket boundary: 16
2 Aug 20:04:14 ntpd[2911]: Listen and drop on 0 v6wildcard [::]:123
2 Aug 20:04:14 ntpd[2911]: Listen and drop on 1 v4wildcard 0.0.0.0:123
2 Aug 20:04:14 ntpd[2911]: Listen normally on 2 lo 127.0.0.1:123
restrict: op 1 addr 127.0.0.1 mask 255.255.255.255 mflags 00003000 flags 00000001
2 Aug 20:04:14 ntpd[2911]: Listen normally on 3 wlp9s0 172.16.82.124:123
restrict: op 1 addr 172.16.82.124 mask 255.255.255.255 mflags 00003000 flags 00000001
2 Aug 20:04:14 ntpd[2911]: Listen normally on 4 lo [::1]:123
restrict: op 1 addr ::1 mask ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff mflags 00003000 flags 00000001
2 Aug 20:04:14 ntpd[2911]: Listen normally on 5 wlp9s0 [fe80::7d57:80ee:a76f:7dbb%3]:123
restrict: op 1 addr fe80::7d57:80ee:a76f:7dbb%3 mask ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff mflags 00003000 flags 00000001
2 Aug 20:04:14 ntpd[2911]: Listening on routing socket on fd #22 for interface updates
event at 0 0.0.0.0 c016 06 restart
peer_name_resolved(0.arch.pool.ntp.org) rescode 0
key_expire: at 0 associd 58019
peer_clear: at 0 next 0 associd 58019 refid INIT
event at 0 123.108.200.124 8011 81 mobilize assoc 58019
newpeer: 172.16.82.124->123.108.200.124 mode 3 vers 4 poll 6 10 flags 0x101 0x1 ttl 0 key 00000000
peer_name_resolved(1.arch.pool.ntp.org) rescode 0
key_expire: at 0 associd 58020
peer_clear: at 0 next 3 associd 58020 refid INIT
event at 0 45.125.255.54 8011 81 mobilize assoc 58020
newpeer: 172.16.82.124->45.125.255.54 mode 3 vers 4 poll 6 10 flags 0x101 0x1 ttl 0 key 00000000
peer_name_resolved(2.arch.pool.ntp.org) rescode 0
key_expire: at 0 associd 58021
peer_clear: at 0 next 3 associd 58021 refid INIT
event at 0 125.62.193.121 8011 81 mobilize assoc 58021
newpeer: 172.16.82.124->125.62.193.121 mode 3 vers 4 poll 6 10 flags 0x101 0x1 ttl 0 key 00000000
peer_name_resolved(3.arch.pool.ntp.org) rescode 0
peer_xmit: at 1 172.16.82.124->123.108.200.124 mode 3 len 48 xmt 0xdb4b2de7.aa3e1fe6
auth_agekeys: at 1 keys 0 expired 0
event at 1 123.108.200.124 8024 84 reachable
clock_filter: n 1 off -0.040187 del 0.123217 dsp 7.937501 jit 0.000000
select: combine offset -0.040187438 jitter 0.000000000
event at 1 123.108.200.124 903a 8a sys_peer
clock_update: at 1 sample 1 associd 58019
2 Aug 20:04:15 ntpd[2911]: ntpd: time slew -0.040187 s
ntpd: time slew -0.040187s

Then > ran sudo hwclock -w
Then > sudo pacman -S libreoffice-fresh
Again failed with same error.
I don't know where I am missing out.

I even tried offline installation by downloading the package from http://repo.manjaro.org.uk/stable/extra/x86_64/?C=N;O=A
Then > pacman -U libreoffice-fresh-5.1.4-1-x86_64.pkg.tar.xz

loading packages...
resolving dependencies...
looking for conflicting packages...

Packages (6) libcmis-0.5.1-2 libexttextcat-3.4.4-1 libfbclient-2.5.5.26952-2
libixion-0.11.1-1 liborcus-0.11.2-1 libreoffice-fresh-5.1.4-1

Total Installed Size: 363.51 MiB

:: Proceed with installation? [Y/n] y
(6/6) checking keys in keyring [######################] 100%
(5/6) checking package integrity [######################] 100%
(5/6) loading package files [######################] 100%
(6/6) checking for file conflicts [######################] 100%
(6/6) checking available disk space [######################] 100%
:: Processing package changes...
(1/6) installing libixion [######################] 100%
(2/6) installing liborcus [######################] 100%
(3/6) installing libexttextcat [######################] 100%
(4/6) installing libfbclient [######################] 100%
(5/6) installing libcmis [######################] 100%
(6/6) installing libreoffice-fresh [######################] 100%
error: could not extract /usr/lib/libreoffice/program/libcuilo.so (Lzma library error: No progress is possible)
error: problem occurred while installing libreoffice-fresh
Optional dependencies for libreoffice-fresh
java-runtime: adds java support [installed]
java-environment: required by extension-wiki-publisher and
extension-nlpsolver
pstoedit: translates PostScript and PDF graphics into other vector formats
libmythes: for use in thesaurus
beanshell2: interactive java -- good for prototyping/macros
vigra: C++ computer vision library, usable in Basebmp
libmspack: library for Microsoft compression formats for use in FontOOo
libwpg: library for importing and converting WordPerfect Graphics format
[installed]
sane: for scanner access
unixodbc: adds ODBC database support
gst-plugins-base-libs: for multimedia content, e.g. in Impress [installed]
libpaper: takes care of papersize [installed]
postgresql-libs: for postgresql-connector
coin-or-mp: required by the Calc solver
gtk3: for GTK3 integration [installed]
kdelibs: for KDE desktop integration [installed]
error: could not commit transaction
error: failed to commit transaction (transaction aborted)
Errors occurred, no packages were upgraded.

And also there is no such file /var/cache/pacman/pkg/libreoffice-fresh-5.1.4-1-x86_64.pkg.tar.xz
The only libre files the location has are :
libreoffice-fresh-af-5.1.4-1-any.pkg.tar.xz
libreoffice-fresh-am-5.1.4-1-any.pkg.tar.xz
libreoffice-fresh-ar-5.1.4-1-any.pkg.tar.xz

Please look into this. Its getting frustrating.
Thanks

except libre and open office, eveything else is working fine.
I tried installing abiword, it installed flawlessly.
I downloaded from the link you provided, still getting error while installing.

pacman -U libreoffice-fresh-5.1.4-1-x86_64.pkg.tar.xz

loading packages...
resolving dependencies...
looking for conflicting packages...

Packages (6) libcmis-0.5.1-2 libexttextcat-3.4.4-1 libfbclient-2.5.5.26952-2
libixion-0.11.1-1 liborcus-0.11.2-1 libreoffice-fresh-5.1.4-1

Total Installed Size: 363.51 MiB

:: Proceed with installation? [Y/n] y
(6/6) checking keys in keyring [######################] 100%
(5/6) checking package integrity [######################] 100%
(5/6) loading package files [######################] 100%
(6/6) checking for file conflicts [######################] 100%
(6/6) checking available disk space [######################] 100%
:: Processing package changes...
(1/6) installing libixion [######################] 100%
(2/6) installing liborcus [######################] 100%
(3/6) installing libexttextcat [######################] 100%
(4/6) installing libfbclient [######################] 100%
(5/6) installing libcmis [######################] 100%
(6/6) installing libreoffice-fresh [######################] 100%
error: could not extract /usr/lib/libreoffice/program/libcuilo.so (Lzma library error: No progress is possible)
error: problem occurred while installing libreoffice-fresh
Optional dependencies for libreoffice-fresh
java-runtime: adds java support [installed]
java-environment: required by extension-wiki-publisher and
extension-nlpsolver
pstoedit: translates PostScript and PDF graphics into other vector formats
libmythes: for use in thesaurus
beanshell2: interactive java -- good for prototyping/macros
vigra: C++ computer vision library, usable in Basebmp
libmspack: library for Microsoft compression formats for use in FontOOo
libwpg: library for importing and converting WordPerfect Graphics format
[installed]
sane: for scanner access
unixodbc: adds ODBC database support
gst-plugins-base-libs: for multimedia content, e.g. in Impress [installed]
libpaper: takes care of papersize [installed]
postgresql-libs: for postgresql-connector
coin-or-mp: required by the Calc solver
gtk3: for GTK3 integration [installed]
kdelibs: for KDE desktop integration [installed]
error: could not commit transaction
error: failed to commit transaction (transaction aborted)
Errors occurred, no packages were upgraded.
Please look into this once.

My friend I regret its far above my superpowers. :sweat:
Don't worry, there are many experienced Manjarians to help you. Sit tight and pray not all of them to be on vacation like me.
May the FOSS be with you! :sunglasses:

Try remove the file /var/cache/pacman/pkg/libreoffice-still-5.0.6-2-x86_64.pkg.tar.xz and try again.

sudo rm /var/cache/pacman/pkg/libreoffice-still-5.0.6-2-x86_64.pkg.tar.xz

I removed it every time it shows up in that location, and then tried again to install, but unfortunately same error when I try to do pacman -S libreoffice-still or libreoffice-fresh.
Something else do I need to provide.

Thank you very much for the help you provided.
Much obliged.
Waiting for some experienced Manjarians to help me out now.

Can you post here the error message again? Is it still about signature?

Use this for the workaround

sudo pacman -Syu --ignore libreoffice-still

Until you can fix the signature error, first update the system :slight_smile:

Yes it is about signatures
Error message:

resolving dependencies...
looking for conflicting packages...

Packages (1) libreoffice-fresh-5.1.4-1

Total Download Size: 86.81 MiB
Total Installed Size: 342.01 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
(1/1) checking keys in keyring [######################] 100%
(1/1) checking package integrity [######################] 100%
error: libreoffice-fresh: signature from "Andreas Radke andyrtr@archlinux.org" is invalid
:: File /var/cache/pacman/pkg/libreoffice-fresh-5.1.4-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: failed to commit transaction (invalid or corrupted package (PGP signature))
Errors occurred, no packages were upgraded.

Hi, you can try these following things:

  1. Look for .part files in pkg folder and delete them with
    find /var/cache/pacman/pkg/ -iname "*.part" -exec rm {} \;
    and then try to update.
  2. Clear out the cache completely with Sudo pacman -Scc and then try to update.
  3. Create a new pkg folder in /var/cache/pacman/ and renaming the original to pkg.bak and then try to update.

Good luck :innocent:

:: Synchronizing package databases...
core is up to date
extra is up to date 0.0 B 0.00B/s 00:00 [----------------------] 0%
community is up to date 0.0 B 0.00B/s 00:00 [----------------------] 0%
multilib is up to date
:: Starting full system upgrade...
warning: gtk2: local (2.24.30+95+g876b5f7-1) is newer than extra (2.24.30-3)
there is nothing to do

Even without ignoring libre office, same message.

Just as a sanity check, can you boot from live media, update mirrors and update all packages including libreoffice? Just to be sure your net and hardware is OK.

Tried out all 3 steps. Whenever I try to do pacman -S libreoffice-fresh, it automatically creates the libreoffice-fresh-5.1.4-1-x86_64.pkg.tar.xz in /var/cache/pacman/pkg/ directory and always asks to delete the same as it is corrupted. Stuck in the loop indefinitely.
system update has no problem, it's showing nothing to do.

Yeah sure I will try that. And update you with the result.
Thank you.

And if you try with:
sudo pacman -S archlinux-keyring
sudo pacman -Syu
?

Forum kindly sponsored by