error: missing python3-pyqt4 to do HP printer installation

which one should i install ? i tried hplip 3,18 , worst.. hp

so i reinstalled hplip from repos..
hence back to the same problem: plug-in installation choice:

  1. download and install the plug-in from an HP authorized server (recommended)
  2. select and install existing local copy of the plug-in file (advanced)

i can't choose 2, because i don't have the plug-in file. hence chose option 1.

unable to receive key from keyserver
without this, it is not possible to authenticate and validate the plug-in prior to installation. do you still wan to install the plug-in ?

plug in installed successful.

the device you are trying to setup requires a binary plug-in. some functionalities may not work as expected without plug-ins.
please run "hp-plugin" as normal user to install plug-ins..

why run as normal user to install plug in ? can't i install with root user ? ! anyway.. hplip does not work on manjaro

somebody help me!
i need to get things going :frowning:

Each utility that is provided by Manjaro should be installed from Manjaro repository.
HPLIP is one of such utility, but it does not automatically installing the drivers for your printer. That is why i asked for the printer model.
Each model has either an installer package driver, or a plugin. The hplip-plugin might or might not be suitable for your printer model.

Tell us the model.

HP LaserJet Professional M1212nf MFP

chris titus said linux is about getting work done.. lol..
i want to believe that, but until today i am still struggling with a lot of things..
still, i like linux better than microsoft stuff.. but that doesn't mean it get work done better.

Please install the one with the logo back. The required file is in

Do the device setup/management again, let it discover the printer, and do what the popup is asking, and point to that file.

For the same reason why you don't swim with heavy knight armor on you :slight_smile:

1 Like

u mean this ?

your swimming knight description is perfect! lol

it only accepts *.run.. the file in HP is *.gz


OK, when I get your doublepostings correct, it is a notebook - xfce - stable branch.
Is manjaro-printer (meta pkg) installed ? This includes hplip 1:3.20.5-2 .
You are right, the direct download for hplip-plugin does not work atm.

  • Chris Titus said = Jesus said ???

Now you need to download the correct plugin from here . In your case it is .
You have to make the file executable (right click - properties - access rights) .
Btw it is never a good idea to get the plugin from AUR because it is not in sync with manjaro, especially stable branch. So we have to make it this way around .

  • disable firewall, you can set rules later.
  • enable cups and hp-setup from terminal.
sudo systemctl enable --now org.cups.cupsd.service
sudo systemctl start --now org.cups.cupsd.service
sudo hp-setup -u

...and follow the GUI. When ready, open HP Device Manager and set up your preferences.

You will need a plugin. Do NOT use AUR plugin, when you test scanning/printing
hp-setup will ask you to install the plugin, choose option two and pont hp-setup to your downloaded plugin. It will complain about missing key but ask you if you want to install anyway - you say yes, accept the license (it will again comlain) done.
Refresh your HP Device Manager, restart your scanning app and it should work.

Tip: simple-scan is a well working scanning app in xfce. I prefer over xsane.

i followed all your steps to the very details.
i installed manjaro-printer ( meta pkg)
and enable it to run as a program
firewall is disabled before this issue
cups is running and have made sure it is in running status.
run hp-setup -u from terminal
after i clicked "next", it won't allow me to do any interaction with gui, instead, i have to do it in the terminal.
anyway, i have installed the plugin as you told.. but the scanner software can't identify there is a scanner.
and hp device manager still the same, not printer added.



I have updated the plugins for three notebooks yesterday - stable and testing, because the hp server did not respond, we both noticed.
This is my last shot, then I am out of ideas

Screenshots are bad, copy/paste text.
But what I saw, it complained about root, so try without sudo, only

hp-setup -u

My printer only need the plugin for scanning, so it never ask me to install the plugin. I do this by opening the scanner app, it complains about the missing plugin.

scanner is not working, but i believe this shows my hp printer is working and setup properly right ? i am not that sure about linux printer setting.
the reason i asked before whenever i double clicked the "hp device manager" icon that reside in the tray bar, it shows this.. ( no installed hp devices found) which makes me think something is not installed right.. then again, my printer is working.
just the hp scanner is not. and by the look of the addressed showed on hp scan device, it is .. the scanner software shows my webcam as scanner.

i think if i type it out , it is hard to convince ppl that i have done all the steps.. i use screenshot as proof of my steps.. or maybe u guys can notice something that i missed out by typing.

how that the printer is working (except scanner) can you pls teach me how to unblock from ufw ? i will need to enable it sometime.. but when enable it, will it block the network printer ?

btw, pls explain to me, this printer thing is confusing.. according to the screenshots above, am i connecting to my network printer by CUPS ? or by what (hp device manager) ...?

this "common unix printing service".. how come it looks like a web interface instead of software interface (as of windows printer manager, which is software based)

what port or what is in used to comm between manjaro laptop and the printer ? i can allow all incoming and outgoing to to be allowed on ufw? surely works right ? but can be more specific ? like port or mac address or something specific, to narrow any possibility intrusion within network itself (although i have nothing in the lan itself that will intrude the laptop, need to learn complete anyway, in case i bring the laptop to a public lan )

Yes, it's cups. I don't get it. Have you opened HP Device Manager from your menu, have you ? Normally it will find your printer and you can configure it.
Firewall is gufw, GUI front for ufw. Click rules - ingoing/outgoing - network - printing - hplip and same with cups.

I have not read the entire thread in detail - but you have - for sure complicated your setup.

  1. When on your private network - any firewall application should be disabled
  2. Firewall is required on public or insecure network - and your private network is not insecure.
  3. qt4 is deprecated from upstream Arch and therefore anything related to qt4 is going to be a pain.
  4. As a general experience with networked printers - they all have a web interface http://x.y.z.n/
  5. Manjaro has a printer meta package manjaro-printer which installs almost everything needed.
  6. python-pyqt5 is an optional dependency of the hplip package in the repo and must be installed separately

Steps to get the majority of printers working:

  1. Install the packages manjaro-printer and python-pyqt5
  2. Enable and start cups
  3. Ensure your printer is connected to the network - (printer's panel for network settings)
  4. Launch system-config-printer and setup your printer.


  1. Install the packages

    sudo pacman -Syu manjaro-printer python-pyqt5

  1. Enable cups

    sudo systemctl enable --now org.cups.cupsd

  1. Connect the printer to the network using the control panel on the device.

  1. Setup the printer

Using the HP GUI requires the device to be setup before you can use it

Note: Only devices installed with the hp: or hpfax: CUPS backend will appear in the HP Device Manager.

To use the system printer utility - your user must be a member of the lp group - run the groups command to verify


If your user is not member of lp group - add yourself - logoff and login after adding yourself.

sudo gpasswd -a $USER lp

Use the printer control panel

  • Unlock the settings (upper right corner) - and setup your printer.
  • Choose your printer connection
  • Select the HP Linux Imaging and Printing (HPLIP) driver


Before you can use the HP GUI ensure the following

  1. Complete the setup using the system utility
  2. The printer must be working before you can use HP GUI.


1 Like

after i entered the static ip address of the network printer of mine, this pops up.. what password is that ? i tried my manjaro sudo password - denied, tried key ring password - denied. tried no password - denied.
what password is that ? my printer has got no password setting in it (i just browsed thru my printer panel)
btw, how did you make the forum to hide the photo , so that user can expand as will ? it look neater..

I think your system is a mess - it looks like a password dialog for a samba share and the IP appears more like a router IP than a printer.

Use your printers physical control panel and connect the printer to your network using that physical panel.

To hide an image use the :gear: icon and select Hide Details - it will create a text like this (just ensure the bracketed content is on separate lines.


This text will be hidden

1 Like

u meant on my hp printer itself, connect it to network ?
my printer is connected to network.. it is a static ip that i have assigned on the physical printer itself.
my printer is set like this for years.. when i was still using microsoft os.

i never have being asked for password while installing or accessing or "anything" with the printer before.
this is the 1st time it pops up.

I never use the HPlip so the installation I showed you - was my wife's printer connected to a wireless AP in the opposite end of the house. My system is connected using cable.

So the steps above - are verified working steps.

Don't click Find Network Printer because that will initiate a workgroup/domain search.

Cancel the dialog - only click the → right left to Network Printer



And if your printer is visible on the network the printer name and IP will show up - just wait a few seconds



This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by