Error: resume: hybernation device not found

Hi,

inxi: Dump your "inxi -Fxxxza --no-host" here and bookmark it

During boot and shutdown I got mentioned error after switching from swap partition to swapfile. Currently it looks like:

# fdisk -l
Disk /dev/nvme0n1: 238,49 GiB, 256060514304 bytes, 500118192 sectors
Disk model: E12-256G-PHISON-SSD-B3-BB1              
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 5AFEF6D5-FA5F-5A4A-A10D-51C986106B91

Device          Start       End   Sectors   Size Type
/dev/nvme0n1p1   4096    618495    614400   300M EFI System
/dev/nvme0n1p2 618496 491728895 491110400 234,2G Linux filesystem
# cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=DD0E-CB17                            /boot/efi      vfat    umask=0077 0 2
UUID=74678a54-b65c-4aaa-a762-324eac5f4962 /              ext4    defaults,noatime 0 1
#UUID=ac8943df-cf40-4d30-b5f4-e3e551a9659f swap          swap    defaults,noatime 0 2
/swapfile                                  none          swap    defaults 0 0

# cat /etc/default/grub
GRUB_DEFAULT=saved
GRUB_TIMEOUT=10
GRUB_TIMEOUT_STYLE=hidden
GRUB_DISTRIBUTOR="Manjaro"
GRUB_CMDLINE_LINUX_DEFAULT="ipv6.disable=1 quiet udev.log_priority=3"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/usr/share/grub/background.png"
GRUB_THEME="/usr/share/grub/themes/manjaro/theme.txt"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

Originally there was a 8,8G swap partition which I added to the n1p2.
Then followed wiki to create a 8G swapfile:
https://wiki.manjaro.org/index.php?title=Swap#Using_a_Swapfile

Next I followed:


and got a slightly different error:
Error resume: No device specified for hibernation

Help appreciated,
Thanks

Read the "Hibernation into swap file" paragraph in the following Archlinux tutorial:

https://wiki.archlinux.org/index.php/Power_management/Suspend_and_hibernate

I think your grub file is not setup, properly. Using hibernation with a swap file requires setting the resume=swap_device and additionally a resume_offset=swap_file_offset kernel parameters. Both is missing in your grub file.

1 Like

Perhaps you still have the "resume" hook in the HOOKS line the /etc/mkinitcpio.conf. If your intention is to disable hibernation, remove the "resume" hook and run:

sudo mkinitcpio -P

Otherwise, +1 on @Wollie's post.

3 Likes

Thanks you both.

I do not need hibernation.
Removing resume did the trick.

Thanks.

2 Likes

Thank you for mentioning that the

tutorial didn't help you:

this is how we improve things as that tutorial now includes @marte 's mkinitcpio stuff as well, so the next person following that tutorial will not have the same problem you did (any more...).

:innocent:

2 Likes

Glad it helped the tutorial. :slightly_smiling_face:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by