Error starting domain: Cannot access storage file: qcow2: Permission denied

Hey.
Im trying to install Mac OS Catalina to virtual machine manager

I followed up this tutorial: https://www.youtube.com/watch?v=HipxJJhDPHA&list=LLLy5WM8EH_C8LuY7Gy_Vbvg&index=4&t=1590s

I got it working with terminal ( ./basic.sh )
but when i try to launch it with vm it just gives me this error:

Error starting domain: Cannot access storage file '/run/media/tomi/MacVM/MacVM/macOS-Simple-KVM/MyDisk.qcow2' (as uid:65534, gid:992): Permission denied

I am not going to watch that whole video for you. that person annoys me, its long, and your timestamp seems unrelated to your issue. Due to that it also smells like advertising.
Please remember to research any instructions you dont understand.
But .. from the first looks .. it seems it doesnt have permissions, like you need sudo, or something needs to be done about users/groups.
Why not ask the person who made this video?

1 Like

Im sorry if it seems like advertising, im very new with linux systems so i figured out that best way to show what i did is showing that video.

But yeah...

I think i have permission problems even though i tried it with logging in as a root.

Im not sure why i can start it with terminal. With code ./basic.sh in that folder, But not with vm even though i cloned it in there.

Do you have any suggestions how do i give full permission to virtual machine manager in that folder.

I tried changing permissions (user&groups) and gave read/write/delete permissions to kvm, my username but it didnt help

Also i googled that error code and tried couple terminal commands witch didnt work or i just didn't get them

Cheers.
Not my cup of tea .. so I wont be much help .. I will point to the relevant arch wiki stuff though as its probably related:
https://wiki.archlinux.org/index.php/KVM
https://wiki.archlinux.org/index.php/QEMU

Okay, thanks! <3

Exactly where Duckduckgo comes in:

Error starting domain: Cannot access storage file '~/macOS-Simple-KVM/ESP.qcow2' (as uid:65534, gid:992): Permission denied

I don't have enough space on my majaro disk so i would like to keep files in my seperate partition. I tried to run that command:
sudo chown libvirt-qemu: /var/lib/libvirt/images/BaseSystem.img
sudo chown libvirt-qemu: /var/lib/libvirt/images/macosdisk.qcow2

But it says
chown: invalid spec: ‘libvirt-qemu:’

I also tried adding more permissions to my accounts and even created an account named as qemu, and added my accounts to every single group my pc has.
Also i tried to move those files manually but seems like i dont have permissions to that either...

Update!!
I changed my file directories to documents and gave all permissions to that folder sooo...
now im facing this issue

Error starting domain: Path '/dev/dri/by-path/pci-0000:00:02.0-render' is not accessible: No such file or directory

Traceback (most recent call last):
File "/usr/share/virt-manager/virtManager/asyncjob.py", line 75, in cb_wrapper
callback(asyncjob, *args, **kwargs)
File "/usr/share/virt-manager/virtManager/asyncjob.py", line 111, in tmpcb
callback(*args, **kwargs)
File "/usr/share/virt-manager/virtManager/object/libvirtobject.py", line 66, in newfn
ret = fn(self, *args, **kwargs)
File "/usr/share/virt-manager/virtManager/object/domain.py", line 1279, in startup
self._backend.create()
File "/usr/lib/python3.8/site-packages/libvirt.py", line 1234, in create
if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirt.libvirtError: Path '/dev/dri/by-path/pci-0000:00:02.0-render' is not accessible: No such file or directory

Seems like i don't have that file...

I changed from spice server to vnc it worked, but now it's just super super glitchy
image

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by