Error: symbol ‘grub_file_filters’ not found problem

I tried to install Manjaro-openbox dual boots with Windows 10 on a partition I have created for linux. Let’s call my Window 10 partition as p1 and a partition I am intended to install Manjaro as p2.

Before I try to install Manjaro, I installed another distros, use them for a while, then I tried to replace it with Manjaro. This is where my grub related problem started (at least it is the first point I’ve noticed).

When I turned my laptop on, it was supposed to give me OS choices between Manjaro and Windows 10, but instead the screen displayed:

enter grub rescue: grub_file_filters not found

I tried fix it according to what I found on internet. I found that many suggested the problem might came from using a corrupted live usb to install and talked about burning a better one and replaced it with a better one. I tried that several times, changed usb, re-writed a new one, re-formatted and re-written the reused usb to install Manjaro. None of them success so I erased the partition and tried again. This time still the same.

I can access Windows 10 or live Manjaro-openbox when I plug-in the live usb, but once I remove the usb, I can access none and the error (the one in the topic) shows up.

I have to say that even though I have been using linux for quite a while, fixing something is still not my strong criteria so I am going to need a thorough explanation. I started using linux for its powerful command line and trying to find the one that is easy enough to use (and learn to use) and able to fix it when I run into problems from information I find on internet (wiki or community or else).

P.S. My laptop has NDVIA graphic card, but I have never really use it. I thought it was a default graphic card, but a while ago I found that it has its own app to run it. I am not sure where is the program now because I can’t find it - not sure that I might even delete it - accident or not, so I have tried to install Manjaro both free and non-free version. Both work just fine in live system mode. If there is anything wrong with any of them, I obviously did not notice any. My point is I am not sure that having a NVDIA graphic card plays a part in my problem or not. And since I have just found out that NVDIA was not the default graphic card so I assumed my graphic card has always been Intel and because I don’t really use it, I am not sure my device is under NVDIA hardware category or NVDIA hardware that need a special treatment when using with linux (I saw some info state that some old NVDIA machine worked just fine with Manjaro free version and apparently I don’t know if mine is in this group).

can you run on USB install manjaro
open a terminal and reports

fdisk -l 
inxi -Fxxxza
1 Like

You are probably mixing/booting up with wrong uefi/bios-legacy.
This topic has similar issue. It was fixed when it is was started up in the right boot (uefi/bios-legacy) and 'grub-install' (with the additional 2 uefi commands) done.
The main reference is here.

Be sure you have installed Manjaro in same mode as windows?
Meaning if windows is msdos/bios-legacy or gpt/uefi, manjaro is also installed similarly.
Otherwise suggest you reinstall manjaro in the right mode.
If unsure, at the link (second), provide output as stated, we'll work it out.

Oh, welcome to Manjaro.

sudo fdisk -l                                                             
Disk /dev/loop0: 47.10 MiB, 50311168 bytes, 98264 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/loop1: 164.6 MiB, 172580864 bytes, 337072 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/loop2: 1017.75 MiB, 1067167744 bytes, 2084312 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/loop3: 504.33 MiB, 528818176 bytes, 1032848 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/sda: 931.53 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: WDC WD10JPVX-22J
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: DEA6F664-B454-4BC2-B0ED-4CBE9DCE8949

Device          Start        End   Sectors  Size Type
/dev/sda1        2048    1230847   1228800  600M Windows recovery environment
/dev/sda2     1230848    1845247    614400  300M EFI System
/dev/sda3     1845248    2107391    262144  128M Microsoft reserved
/dev/sda4     2107392  960445440 958338049  457G Microsoft basic data
/dev/sda5  1918785536 1953523711  34738176 16.6G Windows recovery environment
/dev/sda6   960445441 1918785535 958340095  457G Linux filesystem

Partition 6 does not start on physical sector boundary.
Partition table entries are not in disk order.

Disk /dev/sdb: 14.46 GiB, 15514730496 bytes, 30302208 sectors
Disk model: USB FLASH DRIVE 
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x00000000

Device     Boot   Start     End Sectors  Size Id Type
/dev/sdb1  *         64 3675571 3675508  1.8G  0 Empty
/dev/sdb2       3675572 3683763    8192    4M ef EFI (FAT-12/16/32)


inxi -Fxxxza                                                              
  Host: manjaro-openbox Kernel: 5.2.8-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC 
  driver=free nouveau.modeset=1 i915.modeset=1 radeon.modeset=1 
  misobasedir=manjaro misolabel=MJRO1908 quiet systemd.show_status=1 
  apparmor=1 security=apparmor 
  Desktop: Openbox 3.6.1 info: tint2, polybar dm: LightDM 1.30.0 
  Distro: Manjaro Linux 
  Type: Laptop System: Acer product: Aspire E5-473G v: V1.09 serial: <filter> 
  Mobo: Acer model: Robin_BH v: V1.09 serial: <filter> UEFI: Insyde v: 1.09 
  date: 08/07/2015 
  ID-1: BAT1 charge: 25.5 Wh condition: 27.8/37.0 Wh (75%) volts: 17.3/14.8 
  model: SANYO 0032334135314C41 type: Li-ion serial: <filter> 
  status: Charging 
  Topology: Dual Core model: Intel Core i5-5200U bits: 64 type: MT MCP 
  arch: Broadwell family: 6 model-id: 3D (61) stepping: 4 microcode: 2D 
  L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 17565 
  Speed: 1611 MHz min/max: 500/2700 MHz Core speeds (MHz): 1: 797 2: 799 
  3: 798 4: 798 
  Vulnerabilities: Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Device-1: Intel HD Graphics 5500 vendor: Acer Incorporated ALI driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:1616 
  Device-2: NVIDIA GK208BM [GeForce 920M] vendor: Acer Incorporated ALI 
  driver: nouveau v: kernel bus ID: 04:00.0 chip ID: 10de:1299 
  Display: x11 server: X.Org 1.20.5 driver: intel,nouveau 
  unloaded: modesetting alternate: fbdev,nv,vesa compositor: compton 
  resolution: 1366x768~60Hz 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
  Device-1: Intel Broadwell-U Audio vendor: Acer Incorporated ALI 
  driver: snd_hda_intel v: kernel bus ID: 00:03.0 chip ID: 8086:160c 
  Device-2: Intel Wildcat Point-LP High Definition Audio 
  vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
  bus ID: 00:1b.0 chip ID: 8086:9ca0 
  Sound Server: ALSA v: k5.2.8-1-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 4000 
  bus ID: 02:00.1 chip ID: 10ec:8168 
  IF: enp2s0f1 state: down mac: <filter> 
  Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter 
  vendor: Foxconn driver: ath10k_pci v: kernel port: 4000 bus ID: 03:00.0 
  chip ID: 168c:0042 
  IF: wlp3s0 state: up mac: <filter> 
  Local Storage: total: 945.96 GiB used: 119.8 MiB (0.0%) 
  ID-1: /dev/sda vendor: Western Digital model: WD10JPVX-22JC3T0 
  size: 931.51 GiB block size: physical: 4096 B logical: 512 B 
  speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 1A01 temp: 35 C 
  scheme: GPT 
  ID-2: /dev/sdb type: USB model: USB FLASH DRIVE size: 14.45 GiB block size: 
  physical: 512 B logical: 512 B serial: <filter> rev: PMAP scheme: MBR 
  ID-1: / raw size: N/A size: 8.73 GiB used: 70.4 MiB (0.8%) fs: overlay 
  source: ERR-102 
  System Temperatures: cpu: 48.0 C mobo: N/A gpu: nouveau temp: 38 C 
  Fan Speeds (RPM): N/A 
  Processes: 181 Uptime: 1h 05m Memory: 11.64 GiB used: 692.8 MiB (5.8%) 
  Init: systemd v: 242 Compilers: gcc: 9.1.0 Shell: zsh v: 5.7.1 
  running in: termite inxi: 3.0.35 

Thank you so much. I have followed your link and guide and it works. I no longer need to use a live usb to boot whatever OSes I have on my laptop before it can start up.

By the way, thank you for this inspiring / encouraging. One never know one would really need it until one get one.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by