Error: unknown filesystem - How to fix this grub error?


So my grub seemed to stopped working and I am getting this error message (below). I am not sure what I have done, other than installing android studios onto my linux system ( I don't think this was the cause but that was a the last thing I have done in the Linux Environment) . I have both Windows 10 and Manjaro i3.

Also when I select an operating system by pressing F12, Windows Manager seems to load just fine, but my Manjaro doesn't. It goes straight to the grub with the same error message.

What commands can I give to the grub rescue so that I can access my Linux system again?



Follow this set of commands:

Command: ls

It will list all your drives and partitions, like:

(hd0) (hd0,msdos2) (hd0,msdos1)
If you don't know your manjaro boot partition, check them one by one:

ls (hd0,msdos2)/
ls (hd0,msdos1)/
When you hit the right one, you'll get a line mentioning lost+found, more importantly boot, and so on.

Assuming (hd0,msdos2) is the right partition:

set prefix=(hd0,2)/boot/grub
set root=(hd0,2)
insmod normal
Now you'll be able to boot into manjaro. Once you do, execute the following commands:

sudo update-grub
sudo grub-install /dev/sda

1 Like

It's always a good idea to have a Rescue USB-Stick handy. Download
Super Grub and flash it onto an USB-Stick. This tool finds all bootable installations including Windows. After booting into your Manjaro run:

sudo grub-install
sudo update-grub

Try this.

1 Like

Super Grub is a life saver!

This worked, but it took a while finding the right msdos. Wondering if there is a faster way...


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by