Error when updating packages with pacman: "missing required signature"

I've just tried running pacman -Syyu, but I get the following error message after entering Y to proceed with the installation:

error: pacman-mirrorlist: missing required signature
error: uboot-pinebookpro: missing required signature
error: failed to commit transaction (package missing required signature)
Errors occurred, no packages were upgraded.

I've tried running pacman-mirrorlist -g, but it hasn't helped.

Here's my output from inxi -Fxz:

System:    Host: Scatha Kernel: 5.4.0-2-MANJARO-ARM aarch64 bits: 64 compiler: gcc v: 9.1.0 Desktop: KDE Plasma 5.17.4 
           Distro: Manjaro ARM 
Machine:   Type: ARM Device System: Pine64 Pinebook Pro details: N/A serial: <filter> 
Battery:   ID-1: cw2015-battery charge: 100% condition: N/A model: N/A status: Full 
CPU:       Topology: 6-Core (2-Die) model: N/A variant-1: cortex-a72 variant-2: cortex-a53 bits: 64 type: MCP MCM arch: ARMv8 
           rev: 4 
           features: Use -f option to see features bogomips: 0 
           Speed: 1008 MHz min/max: 408/1416:2000 MHz Core speeds (MHz): 1: 408 2: 408 3: 408 4: 408 5: 1008 6: 1008 
Graphics:  Device-1: display-subsystem driver: rockchip_drm v: N/A bus ID: N/A 
           Device-2: rk3399-mali driver: panfrost v: kernel bus ID: N/A 
           Display: x11 server: X.org 1.20.6 driver: modesetting resolution: <xdpyinfo missing> 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:     Device-1: simple-audio-card driver: asoc_simple_card bus ID: N/A 
           Device-2: simple-audio-card driver: N/A bus ID: N/A 
           Sound Server: ALSA v: k5.4.0-2-MANJARO-ARM 
Network:   Device-1: wlan-platdata driver: N/A bus ID: N/A 
           IF-ID-1: wlan0 state: up mac: <filter> 
Drives:    Local Storage: total: 116.48 GiB used: 64.76 GiB (55.6%) 
           ID-1: /dev/mmcblk2 model: DA4128 size: 116.48 GiB 
Partition: ID-1: / size: 114.60 GiB used: 64.76 GiB (56.5%) fs: ext4 dev: /dev/mmcblk2p1 
Sensors:   System Temperatures: cpu: 18.8 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 172 Uptime: 21m Memory: 3.77 GiB used: 589.4 MiB (15.3%) Init: systemd Compilers: gcc: 9.1.0 
           clang: 9.0.0 Shell: bash v: 5.0.11 inxi: 3.0.37

Try:
sudo pacman-mirrors --country all && sudo pacman -Syyu

Then try to update the keys: https://wiki.manjaro.org/index.php?title=Pacman_troubleshooting#Errors_about_Keys

Hm. I just updated these 2 packages today.

I will look into what happened.

EDIT: yep, signatures are missing on the server. Fixing.

3 Likes

Fixed in repo. Wait until your mirror has synced and try it again. :slight_smile:

4 Likes

Thanks... sorted now.

Forum kindly sponsored by