Error while installing Manjaro

I wanted to install Manjaro Gnome, but when I was final of installation, it showed me this error.

I don't know how to fix it, please help me

If you have exited installation, boot to the installed OS using this [More Compicated Setup].

[edit] - renamed [More Complicated Setup] to [Kernel Boot Method]

1 Like

But I don't know how to boot livecd

It is in begin of installation

If you can reach final of installation, you can be at begin of installation.

You don't even need to start at begin.
You can start at start of begin.

Do not boot up to live OS, but press ‘c’ at the menu and we’ll get to the grub prompt (grub>).

Easier and faster than chroot. (And safer).

can you try booting with the Manjaro live USB and then execute a:

df --human

(just to rule out something simple like your EFI partition being out of space)

But I have problem, it said "Manjaro installed, restart pc and put out USB", I did these things and its gone

What things? And what is gone?

You're new here so please bear with us: We're trying to help you but you need to help us help you. Please follow instructions given to you as now it's unclear to us what your problem is and if we don't know what your problem is, we can't help you...



  1. When @gohlip says "Boot LiveCD" he means: boot whatever you used to install Manjaro and then follow the rest of his instructions elsewhere.

  2. When I say:

I mean:

  • boot whatever you used to install Manjaro with
  • press Ctrl+Alt+T
  • type df --human
  • copy-paste the output that command gives you back here
  • format it with the Preformatted text button like this:

Thank you for helping us help you!


Ok, i typed df --human and here is result

ilesystem      Size  Used Avail Use% Mounted on
dev             1.8G     0  1.8G   0% /dev
run             1.8G  104M  1.7G   6% /run
/dev/sdb1       2.4G  2.4G     0 100% /run/miso/bootmnt
cowspace        256M     0  256M   0% /run/miso/cowspace
overlay_root    2.6G   87M  2.6G   4% /run/miso/overlay_root
/dev/loop0       65M   65M     0 100% /run/miso/sfs/livefs
/dev/loop1      494M  494M     0 100% /run/miso/sfs/mhwdfs
/dev/loop2      1.2G  1.2G     0 100% /run/miso/sfs/desktopfs
/dev/loop3      582M  582M     0 100% /run/miso/sfs/rootfs
overlay         2.6G   87M  2.6G   4% /
tmpfs           1.8G     0  1.8G   0% /dev/shm
tmpfs           1.8G     0  1.8G   0% /sys/fs/cgroup
tmpfs           1.8G   28K  1.8G   1% /tmp
tmpfs           1.8G  2.3M  1.8G   1% /etc/pacman.d/gnupg
tmpfs           354M   40K  354M   1% /run/user/1000

But I have small problem, I tried gohlips "more complicated setup"
I typed echo $grub_platform and it returns EFI, then i typed search.file /etc/manjaro-release root and when i typed configfile /boot/grub/grub.cfg it cleared "grub terminal" and then i typed boot and it said You must load kernel first

Installation, I completed the installation, and when I tried to boot Manjaro without USB, It was gone, It cant boot and it redirected me to bios

Ok, I repaired it, and it works, but I have small problem, I want to install grub-vanilla to /dev/sda, and it said grub-install: error: efibootmgr failed to register the boot entry: Input/output error.

At manjaro terminal, print out output of

sudo parted -l
sudo blkid
cat /etc/fstab
pacman -Q grub
test -d /sys/firmware/efi && echo UEFI || echo BIOS
efibootmgr -v

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by