Error: You need to load kernel first

IMG_20200107_223530

Can you help me with this. Can't seem to select the option

on manjaro-chroot -a
--> select 1 if only one line enter
apply the rest

always exit for quit chroot properly

1 Like

This error pops up while updating grub

[manjaro-gnome boot]# sudo update-grub    
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your device.map.
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your device.map.
Found memtest86+ image: /boot/memtest86+/memtest.bin
done
[manjaro-gnome /]# lsblk   
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
loop0    7:0    0  64.1M  1 loop 
loop1    7:1    0 493.4M  1 loop 
loop2    7:2    0   1.2G  1 loop 
loop3    7:3    0   582M  1 loop 
sda      8:0    0 931.5G  0 disk 
|-sda1   8:1    0   100M  0 part /boot/efi
|-sda2   8:2    0    16M  0 part 
|-sda3   8:3    0 268.4G  0 part 
|-sda4   8:4    0   237G  0 part 
|-sda8   8:8    0     1G  0 part 
`-sda9   8:9    0   200G  0 part /
sdb      8:16   1  14.6G  0 disk 
|-sdb1   8:17   1   2.4G  0 part 
`-sdb2   8:18   1     4M  0 part 

reboot , this message is for USB manjaro you cant update

Didn't work. On booting, GNU grub terminal is shown

Refer this first post.. [More Complicated Setups] section.

At your 'GNU grub terminal ', first check that it is in uefi (not bios-legacy) with

grub> echo $grub_platform

If it is not in uefi, use the install media boot menu grub, and again make sure it is in uefi.
Then proceed with the rest.

2 Likes

Thanks was able to recover

I have the same issue, but was not able to follow through with the solution.
While loading the kernel, I get the error:
Premature end of file /boot/linux419-x86_64.kver
Can you please elaborate how you solved this problem

@Seegull
You had a similar post here
Can you continue from there or start a new topic?
Understand you're new here but please do not pepper your question everywhere.
We may not be able to get back to you 'timely' as we may be in different timezones and some of us have other engagements like festivities or other things.

I am having the same issue, it occurred after I completed an update and went to restart my PC. But now I have an additional problem after following these commands:
manjaro-chroot -a
mhwd-kernel -l
mhwd-kernel -i linux419
mhwd-kernel -i linux54
mkinitcpio -P
update-grub
exit

The grub menu now only shows windows 10 and memory tester as options for boot. How do I get my option to boot into Linux back and how do I resolve the initial boot issue?

Thanks in advance i have been struggling with this all day.

Over at this topic, it was resolved using pacman install of kernels instead of using mhwd-kernel.

OP's example like this at chroot

pacman -S linux419 linux419-headers 
mkinitcpio -P 

Those having problems can try it. I don't know why pacman works while mhwd-kernel does not.

Good luck all.

1 Like

Ok thanks for info. How do I resolve the issue of my option to boot into Linux disappearing from my grub menu?

You can still try to chroot into the OS and follow that example.
In your case, after fixing the kernel, and doing mkinitcpio, you should do a grub-install and a update-grub. Good luck.

Alright I'll give that a shot. I'll post my results back here just in-case anyone else might find it useful. Also thanks for quick replies.

1 Like

pacman -S linux419 linux419-headers
mkinitcpio -P
Commands above executed with no errors. But I did sudo install-grub /dev/sda2 in chroot I revive this message:
grub-install: warning: File system 'ext2' doesn't support embedding.
It also talks about how grub can only be installed using blocklists and how they can be unreliable.
This is comes up as a warning is this something I can ignore or something I should fix?


I was reading that stackexchange post and it recommends using: grub-install /dev/sda instead of grub-install /dev/sda2. I am unsure of inputting in this command without some guidance. please help
Thanks

Ok I solved issue I just had to reboot but is warning something I need to resolve?

The correct grub-install command in msdos/bios-legacy is to /dev/sda, not /dev/sdax.
We use /dev/sdax, a partition , not a device only when we want to set to partition, and we will need to use --force, else it won't proceed.

In uefi/gpt we don't need to specify any /dev/sdx because we have the $esp specified in fstab. Anyhow, if specified, it ignores it without error. (I don't know what happens if specified to a partition in uefi, never tried and nobody reported, until now? :slightly_smiling_face:)

But happy your problem is fixed.
But still puzzled why mhwd-kernel fails.

Cheers, take care.

PS: will try to grub-install to partition in my got uefi system later. Not home now. Things to do. Tell you later.

Here's the results.

In uefi

As above.

[pop@Dec ~]$ findmnt /
TARGET SOURCE FSTYPE OPTIONS
/ /dev/sda12 ext4 rw,noatime,stripe=8191
[pop@Dec ~]$ sudo grub-install /dev/sda12
Installing for x86_64-efi platform.
Installation finished. No error reported.

In bios-legacy

As above.

TARGET SOURCE FSTYPE OPTIONS
/ /dev/sdb8 ext4 rw,noatime
[pop@Eight ~]$ sudo grub-install /dev/sdb8
Installing for i386-pc platform.
grub-install: warning: File system `ext2' doesn't support embedding.
grub-install: warning: Embedding is not possible. GRUB can only be installed in this setup by using blocklists. However, blocklists are UNRELIABLE and their use is discouraged..
grub-install: error: will not proceed with blocklists.
[pop@Eight ~]$

[pop@Eight ~]$ sudo grub-install --force /dev/sdb8
Installing for i386-pc platform.
grub-install: warning: File system `ext2' doesn't support embedding.
grub-install: warning: Embedding is not possible. GRUB can only be installed in this setup by using blocklists. However, blocklists are UNRELIABLE and their use is discouraged..
Installation finished. No error reported.
[pop@Eight ~]$

Yours in chroot.

First chroot fails for mhwd-kernel but works for pacman install kernel
Now chroot allows for grub-install to partition without error with a warning.
chroot works in mysterious ways.

I managed to get a successful grub install:

sudo grub-install /dev/sda
Installing for i386-pc platform.
Installation finished. No error reported.

update-grub also executed without error (apart from two grub-probe errors when it scanned my storage partitions which haven't got grub)

I would consider playing around with mhwd but as I still very much a novice I think I'll leave it alone for now at least.

Again thanks for your assistance I definitely be using this site more from now on

1 Like

Hi I'm a real noob here, I can barely speak English. The thing is that I dished a pc with Manjaro a year ago, and yesterday I wanted to play a little with linux again (macOS user here) and tried sudo pacman -Syu and everything went well till today when I turned on the computer again: the system broke, it says that there is no kernel and have been reading this posts with similar issues, but none of the commands that you guys have suggested are working, it doesn't recognize sudo, neither pacman. When I type echo $grub_platform it replies "pc", that is how far I can go with this. Please help in this regard. Thank you all in advance.

Forum kindly sponsored by