Erstinstallation "/boot/efi doesn't look like an EFI partition"

Wenn ich auf Partition ersetzen gehe bekomme ich bei der Installation obigen fehler. Genauso wie hier:

Wenn ich auf manuell partitionieren gehe, kann ich nie auf "weiter" klicken, weils immer ausgegraut ist. Auf zurück ist alles wieder beim Alten aber vorwärts lässts mich nicht.

Habe wie es da steht eine 512 mb fat32 boot partition gemacht (versucht habe ich /boot und /boot/efi) und eine 100 gb ext4. Aber egal welche Partitionen ich anlege das Installationsprogramm lässt mich nur zurück aber nicht forfahren.

edt.: es sind gpt partitionen

This often happens when the system boots in Compatibility mode.

The obvious clue is - if the existing Windows boot partition is NTFS - then the system must be installed as a BIOS system.

Windows starts in UEFI mode on NTFS (from a different drive) so I have no clue what you mean. For the "compatibility mode" you mentioned it would have to be set to "legacy" in the UEFI-Bios which is not the case. If that's what you meant anyways.

If what you say is so obvious then why doesnt Manjaro create the right partition when I choose "replace partition"? Worked with other Linux Distris without a hitch.

I can not even use the KDE Partition Manager before the installation to remove existing partitions because it is asking for a password.

If the partition you have assigned as $esp in Calamares is formatted with NTFS the boot loader installation will fail.

The EFI specification states - the partition must be formatted using FAT32 and marked with partitiontype GUID 0xEF00.

If your existing EFI partition is formatted using NTFS then it is not a real EFI partition and the error message your describe is usually the result of trying to assign an NTFS formatted partition as $esp.

Using any other filesystem - except for FAT32 - used to format the $esp will also result in the message

Thats all lovely but it wont let me format the drive when I'm starting from the Manjaro ISO on the USB-Stick because as mentioned before it wont let me continue to make new partitions and the KDE partition manager asks for a password I dont have.

Also the failed installation already replaced the previous ntfs partition with a Linux partition which should have resolved the problem you are describing, should it not?

username: manjaro
password: manjaro

I restarted the installation process which gave me more options (than after the failed one) again and just choose "delete drive" instead of "replace partition".

That worked.

Forum kindly sponsored by