Ethernet connection 100Mbps instead of 1000Mbps

Hi everyone,

My ethernet connection seems to be slow.
I'm using cat6 cables and on windows i'm getting 1000Mbps, on Manjaro: 100Mbps.

I'm running the r8168 driver but i've tried the r8169 as well. I've tried to tweak the link negotiation settings to no result. I cant get a speedtest result over 100Mbps, not even using a local speedtest.
I've ruled out a problem with cables or hardware. That's why im posting here.

if i run inxi -n i get my ethernet card with 1000Mbps and a full duplex.

I'm honestly qlueless at this point and would appreciate any kind of help.

A full dmesg log would be helpful and the "ethtool [interface]" output.
The closed-source Windows vendor drivers typically include a lot of quirks to deal with chip hw issues. In your case such a hw issue may result in a link downshift. Interesting would be a test with other link partners.

system settings -> network -> connections -> link negtiation set to manual and then choose 1 Gbit. don't forget to accept itnetwork

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by